Jump to content

Help! Logic pro x recording volume lower than playback volume


Ocean 337

Recommended Posts

When I start recording and play a piece of piano, what I hear is slightly lower than the playback afterwards.

But what's odd is, the level seems just the same; and if I make a screen record, the volume is exactly the same!

Never adjust anything in the preference. My keyboard is S88MK2 and the piano I tried includes the Grandeur, Noire and Una Corda. They're all the same.

It feels like when I play something, it activated something like "protecting your ear", but I don't want that kinda stuff!

Link to comment
Share on other sites

Independent Monitor Level if turned on can have that effect.ScreenShot2023-06-16at17_32_59.thumb.png.ea3fb8cd58b64a99bc1af03cbc41a34a.png

 

If you're working with patches and/track stacks with the Low latency Monitoring it can do that too as it deactivates plugins and and routes the audio directly to output to reduce latency.

You may have inadvertently written automation to your track and it could be following the that level instead.  Try deactivating the "Read" option on your channel strip.

Do you have anything on the output??  A limiter or something??

 

  • Like 2
Link to comment
Share on other sites

4 hours ago, simon.a.billington said:

Independent Monitor Level if turned on can have that effect.ScreenShot2023-06-16at17_32_59.thumb.png.ea3fb8cd58b64a99bc1af03cbc41a34a.png

If you're working with patches and/track stacks with the Low latency Monitoring it can do that too as it deactivates plugins and and routes the audio directly to output to reduce latency.

You may have inadvertently written automation to your track and it could be following the that level instead.  Try deactivating the "Read" option on your channel strip.

Do you have anything on the output??  A limiter or something??

Thank you sir, but I did not activate the 3 paragraphs you mentioned. But yes, I do have a limiter on the output, is it the reason? If so, why? I think it should not have effect on the difference of volume between "when I was playing" and "when I playback it"...

Link to comment
Share on other sites

11 minutes ago, Ocean 337 said:

But yes, I do have a limiter on the output, is it the reason? If so, why? I think it should not have effect on the difference of volume between "when I was playing" and "when I playback it"...

it's easy enough to remove it and see whether it makes a difference - then you'll know whether it's involved in the behaviour you see, or not.

  • Like 1
Link to comment
Share on other sites

On 6/16/2023 at 11:05 PM, David Nahmani said:
On 6/16/2023 at 10:14 PM, Ocean 337 said:

If so, why? I think it should not have effect on the difference of volume between "when I was playing" and "when I playback it"...

Unless you use Low Latency Mode, which disables the plug-in during recording and re-enable it during playback.

Yes, it's an orange button in the toolbar.  Turning on the Low Latency mode in the toolbar will actually activate the option in the above preference.  Its essentially the she same thing and it can mess with your levels too.

  • Like 2
Link to comment
Share on other sites

20 hours ago, simon.a.billington said:

Yes, it's an orange button in the toolbar.  Turning on the Low Latency mode in the toolbar will actually activate the option in the above preference.  Its essentially the she same thing and it can mess with your levels too.

Thank you sir, I did not turn on that mode. And also I tried to trun off the limiter, but it's still like what I mentioned.

The most odd thing is, if I start a screen record before I do "start recording and then replay it", the record will show that the volume between them is just the same... Not like what I heard before.

Maybe it's because of the key noise going through my headset covering the piano sounds? I don't know... Sorry for my poor description. But I do have that problem... Thanks for your help.

Link to comment
Share on other sites

Just now, gacki said:

What audio interface are you using and how is it set up?

Focusrite Scarlett Solo 3rd Generation. And I think that "Software Monitoring" won't affect the sound of my software instruments like the Grandeur?

I have my headset connected to my audio interface, and my S88MK2 connected directly into my mac mini. Using logic, komplete kontrol to load the Grandeur, and using the basic Grandeur.

Link to comment
Share on other sites

59 minutes ago, Ocean 337 said:

And I think that "Software Monitoring" won't affect the sound of my software instruments like the Grandeur?

Indeed; I had somewhat forgotten that this isn't an audio recording situation.

Well, there's another thing to try: Put a metering plugin on the output bus and compare the values during recording and playback.

Link to comment
Share on other sites

1 hour ago, David Nahmani said:

How do you do your screen record? Do you include any audio from a live mic? 

I use shift+cmd+5 to start my screen record. And I use soundflower to record my computer sound. I also tried OBS, and it's all the same.

1 hour ago, gacki said:

Indeed; I had somewhat forgotten that this isn't an audio recording situation.

Well, there's another thing to try: Put a metering plugin on the output bus and compare the values during recording and playback.

Yes, I compared them with level meter, but it showed the before and the after are at the same peak level (sometimes not, but it's random, maybe because of the round robin stuff.)

Link to comment
Share on other sites

Oh I forgot to mention, many limiters add a "lookahead" time which will delay your signal.  

If you have Low Latency on and you select a software instrument or record arm an audio track Logic will  automatically bypass the limiter turning it orange, so you won't hear the added delay.  When you're just playing it back though, Logic will reenable the limiter and all your audio will be boosted again.

Is this maybe what is happening??

  • Like 1
Link to comment
Share on other sites

11 hours ago, simon.a.billington said:

Oh I forgot to mention, many limiters add a "lookahead" time which will delay your signal.  

If you have Low Latency on and you select a software instrument or record arm an audio track Logic will  automatically bypass the limiter turning it orange, so you won't hear the added delay.  When you're just playing it back though, Logic will reenable the limiter and all your audio will be boosted again.

Is this maybe what is happening??

Thank you sir, but I did not activate the low latency mode.

But what you said in the first paragraph inspired me: Will "Lookahead" affect the volume between before and after? I will try it after my traveling.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...