Jump to content

Logic Pro X/Universal Audio Arrow issues


Chris Evans

Recommended Posts

Hi there,

I have been having numerous issues with my Universal Audio Arrow. For the past few years, I've been using my Quad Cortex through it and straight into Logic Pro X with no issues. 

However, since Apple updated or maybe Universal Audio, my Arrow refuses to produce a signal into Logic Pro X. There is a signal going into the Arrow but nothing is coming up in Logic Pro x

I have tried everything to work this out. I have updated my laptop, my Quad Cortex, the Arrow numerous times and still nothing. Like I said, there is a clear signal coming into the Arrow from my Quad but Logic produces nothing. 

I have no idea on how to fix it and it's been like this for over 4 weeks. 

Any help would be greatly appreciated. 

Link to comment
Share on other sites

If you see the audio signal from the Quad in UAD Console but not in Logic then you should contact UAD tech support and ask them for help. It could be that you need a firmware update: 

https://help.uaudio.com/hc/en-us/articles/360050728032-UAD-Firmware-Updates

or some other kind of software update: 

https://help.uaudio.com/hc/en-us/articles/19237390771860-UAD-Software-Compatibility-with-macOS-Sonoma-14

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...