Jump to content

Do Intel Macs w/ Leopard still need Pro Application Support?


Bossanova Baby

Recommended Posts

Just wondering... it seems to required for FCP and Compressor, but is it needed for Logic Pro 8?

 

http://www.apple.com/downloads/macosx/apple/application_updates/proapplicationsupdate200702.html

 

Thanks In Advance!

I'm interested in finding out, as well. Since I don't have Final Cut Studio (and therefore no serial number to enter here), just Soundtrack Pro and Compressor, I can't seem to download the updates. :roll:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...