Jump to content

Cannot get Mackie Logic Control to update firmware..


Recommended Posts

I moved my setup to a new location and now when I boot up my logic control its just a blue screen. I've found its firmware has been blanked. I did some research and it seems emagic used to send users an old .mid file to fix it, but that was long ago. Now all I have is a 1.02 firmware .mid from Mackie, but every time I go to play the song it says error code 1 right away.


Does anyone know how to fix this? I think I turned off MTC and the midi clock, but still no go or not sure i did it right. Does anyone know how I can correct this within Logic pro 7? I run logic pro 7 with a Unitor 8 - LC is on port 1. Any help would be appreciated! Ive never had to do anything with logic control before this, but turn it on!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...