Jump to content

Multiple MIDI recording for a noobie


chromatica

Recommended Posts

I am setting up to record some two-piano pieces that my parents have played over the years. Right now I have two keyboards - a Yamaha P70 and an M-Audio controller. I bought an EMU MIDI interface with two MIDI IN/OUT pairs (from Musicians Friend). When I open up a new project in Logic Express and select External MIDI for the object type, I get two tracks and I have a menu that allows me to select channel 1-16 for both EMU Port 1 and EMU Port 2. When I record I can see the notes appearing in the proper regions, I just don't get any sound. There's a step I am missing that assigns each of these tracks to one of my software instruments. I think I am closing in on a solution. Any Logic experts out there?
Link to comment
Share on other sites

An external MIDI track is what you'd use to send MIDI data to connected devices. You want to create software instrument tracks, which are controlled by MIDI code, whether recorded on a track or live input. Select different MIDI channels for each input (at the top of each track's Inspector window), assign an instrument to each track (with a pop-up menu just under I/O on the Inspector's channel strip or via the Media browser), and you should be good to go.
Link to comment
Share on other sites

OK, I have created two Software Instruments and assigned them to MIDI channels 1 and 2. I can see at the bottom of the screen that the M-Audio is transmitting on channel one and the Yamaha is transmitting on channel 2. I have assigned strings to the M-Audio and Trumpets to the Yamaha. However, when I highlight the M-Audio track, the system responds to either keyboard with a strings sound. When I highlight the Yamaha track, the system responds to either keyboard with a trumpet sound. Don't think I have achieved channel separation. Still confused...
Link to comment
Share on other sites

When you select a track and play a note on that track's MIDI channel, you activate Live mode, and the active device triggers your chosen instrument.

 

I'm not sure what you mean by the "bottom of the screen" when you talk about your devices transmitting on MIDI channels 1 and 2. In any case, if both devices trigger samples in each track as it's selected, then both devices necessarily have to be transmitting on both assigned channels.

 

It sounds as though both devices are currently transmitting on all channels, which is a common default setting. Since the desired instruments are triggered when you select each track, you evidently have made MIDI assignments in Logic as you describe. However, you also need to tell each input device to transmit only on the channel corresponding to your assignments.

 

You may be able to run Audio MIDI Setup in your Applications/Utilities folder to set channels on these external MIDI devices; it depends on each device's driver. You can also consult the devices' manuals to learn how to set them manually to transmit on specific channels, without using AMS. Regardless of how you assign the devices' channels, once it's done each device should trigger only the track and instrument you assign in Logic.

 

This is the world of MIDI. Once you grasp its rudiments, you'll be able to do whatever you want. Until you attain a basic understanding, however, it may as well be ancient Greek. You're making progress, and you'll get there eventually. You just gotta keep at it.

Link to comment
Share on other sites

OK, I have created two Software Instruments and assigned them to MIDI channels 1 and 2. I can see at the bottom of the screen that the M-Audio is transmitting on channel one and the Yamaha is transmitting on channel 2. I have assigned strings to the M-Audio and Trumpets to the Yamaha. However, when I highlight the M-Audio track, the system responds to either keyboard with a strings sound. When I highlight the Yamaha track, the system responds to either keyboard with a trumpet sound. Don't think I have achieved channel separation. Still confused...

 

Click the Settings button in the Toolbar and choose "Recording", then make sure you select "Auto demix by channel if multitrack recording". That should be all you need to make it work now.

Link to comment
Share on other sites

Click the Settings button in the Toolbar and choose "Recording", then make sure you select "Auto demix by channel if multitrack recording". That should be all you need to make it work now.

 

Ah, David,

 

That did change things. However, I am no longer getting any sound out of the Yamaha. Well, if I play with the record enable buttons I can sometimes get sound but it's sound that belongs to the M-Audio. I have a sneaking suspicion that Logic Express may not support more than one MIDI Port. My EMU box has 2 MIDI Ports and each of them supports 16 channels of information. Perhaps my strategy of assigning tracks to different MIDI channels is unnecessary. I would try MIDI thru but neither my Yamaha or M-Audio has a MIDI thru connector. I sold an s03 yesterday that had a MIDI thru connector.

 

David,

 

Are you David Nahmani?

What's the best way to get a copy of your new book? Anyone in San Diego carry it or should I order it direct from you? How about the Users Group - do they sell copies? Just want to keep business in the family you know.

Link to comment
Share on other sites

I have a sneaking suspicion that Logic Express may not support more than one MIDI Port. My EMU box has 2 MIDI Ports and each of them supports 16 channels of information. Perhaps my strategy of assigning tracks to different MIDI channels is unnecessary.

Note that Logic Pro and Express by default merge all MIDI input ports.

So you need to separate the keyboard instruments by sending on a different channel,

and setting your tracks to the corresponding channel.

 

Basically you can also access the individual ports. But it requires some cabling in the environment.

Link to comment
Share on other sites

You'd benefit from reading the MIDI articles at the link below. They all pertain to the kind of questions you're facing:

 

http://www.recordingwebsite.com/articles/

 

Thanks for the link. I did go there and read up. I also ordered a copy of David's Book.

 

I achieved channel separation with an interesting configuration. I created two software instruments (not MultiTimbral) assigned to channel 1 and 2. And I click the auto demix box David referred to. This configuration alone still yields crosstalk. Then I added two more External MIDI devices and assigned them to Port 1 Channel 1 and Port 2 Channel 2. Voila - channel separation.

 

However, when I record, I only get a piano roll on the highlighted track, even though I have record enabled both tracks.

 

More study is required...

Link to comment
Share on other sites

  • 3 weeks later...
I discovered that my Yamaha keyboard does not remember channel settings when it is power cycled. I hooked up my EMU box to both keyboards, set the keyboard channels to 1 and 2, and created two software instruments (non-multi-timbral). I assigned one to a celeste and the other to a Steinway Piano and then went to Settings->Recording and checked Auto demux... Everything is working!
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...