Jump to content

Please help with logic connection to sound module


pharaoh1tay

Recommended Posts

hey guys,

 

i am a newbie to mac and MIDI but i'm slowly learning it day by day.

 

I've been trying to figure out this problem for almost a week now... i need some serious help.

 

i have a Imac OS X with logic pro 8.0.0. i purchased a small interface (presonus audiobox usb). i connected the USB from the interface to the mac. on the interface, i have my motif board (used as midi controller) connected MIDI IN and OUT to the presonus interface. on the motif, i have MIDI THRU going MIDI IN the roland. i can hear the sounds off the roland but i'm only able to record it as MIDI on logic. how can i convert it to audio so when i format my session to MP3, i'd be able to hear it? if helps more, i have a mixer connected to the interface as well through 1/4 inch cables.

 

from the mixer, i have the motif and roland connected as well using 1/4 cables. that's how i'm able to hear the sounds. is there a certain file on logic i need to click on to select a specific option? i select EXTERNAL MIDI when i open my logic session.

 

thanks in advance

Link to comment
Share on other sites

i select EXTERNAL MIDI when i open my logic session.

This creates Midi device in the "Midi Instr" enviro layer and midi track arrange track etc... but no audio routings, that's why you can record midi only. To be able to record the audio path of your hardware synth you need to create audio track corresponding to your audio interface inputs where the synths are hooked up.

Another way is to create new Audio Instrument (Software Instr.) and insert "External Instrument" on the instrument slot like you do with EXS ES1 etc...Read page 256 of the Manual to have an idea about. This way you can FX process your external device, save lots of audio track Enviro and Arrange workspace, HD room and finally the audio path will be included in the Bounce process.

 

Link to comment
Share on other sites

thank you for the reply. i did what you advised but now i can't hear the audio back at all. do i need to go a further step? i read page 256 but it doesnt really explain my problem. is there an option i need to check while recording from my module?

 

thanks.

Link to comment
Share on other sites

yes software monitoring is checked in my audio prefs. i selected "software inst." as my option, from there i selected external inst. my module is on channels 1 & 2 on the mixer. i raised up the channels on 1 and 2 on the mixer so i hear the audio while pressing the keys. i just cant hear it when i stop playing the keys. and the 1/4 cables are audio IN from the interface to audio OUT on the mixer.
Link to comment
Share on other sites

so i hear the audio while pressing the keys.

This means that your external midi controller is properly hooked up to the Logic Physical input - good...

i just cant hear it when i stop playing the keys.

Do you mean you have some arrange sequences and Logic is in play mode but you can not audition the external synth? If yes, then the Logic midi Out routings are bad.

and the 1/4 cables are audio IN from the interface to audio OUT on the mixer.

Here I'm confused as well. If you have an external sound module then its audio cables outputs must be routed to the Audio device A/D Inputs i.e Logic Audio Inputs or I misundersood ?

 

 

 

Link to comment
Share on other sites

With due respect to Vacheto's reply, your problem has nothing to do with the Environment (physical input, all that stuff). Don't even worry about that stuff for now. It's not necessary.

 

I want to clear a few things up for you:

 

i have a Imac OS X with logic pro 8.0.0.

 

First, I suggest you update to 8.0.2. There have been many bug fixes. This won't affect your situation, but I recommend updating to this.

 

Next...

 

i have my motif board (used as midi controller) connected MIDI IN and OUT to the presonus interface. on the motif, i have MIDI THRU going MIDI IN the roland. i can hear the sounds off the roland but i'm only able to record it as MIDI on logic. how can i convert it to audio so when i format my session to MP3, i'd be able to hear it? if helps more, i have a mixer connected to the interface as well through 1/4 inch cables.

 

from the mixer, i have the motif and roland connected as well using 1/4 cables. that's how i'm able to hear the sounds. is there a certain file on logic i need to click on to select a specific option? i select EXTERNAL MIDI when i open my logic session.

 

Since your mixer is already connected to the inputs of your presonus box, you should simply be able to "arm" a channel (i.e., put it in record) and record the output of your mixer. And in this case your probably want to turn software monitoring off since you can already hear the sound through your mixer.

 

It should be that simple.

Link to comment
Share on other sites

ski & vacheto:

 

thanks for the recommendation. i will upgrade to the 8.0.2 version. so i have decided to completely get rid of the mixer for now. so i have 2 1/4 cables plugged IN from the audiobox to 2 1/4 inch cables OUT the roland module. I have my motif board as my controller so i presume it would be MIDI IN the roland module to MIDI OUT the motif? if so, how do i connect the motif to the audio box? or should i just directly connect a USB from the roland to the IMAC?

 

also, in logic, i remember Vacheto's suggestion was selecting external instrument. is there an extra step i need to take to bounce back my tracks to MP3?

 

please someone walk me through this A,B, C... i have the logic book written by David Nahmani. i read it but it doesnt solve my problem. i surfed the web and also read the logic manual. i read the roland module manual as well. i know its probably a simple step i'm not getting.

 

thanks for the help.

Link to comment
Share on other sites

pharaoh,

 

There are many advantages to keeping the mixer. One important advantage is that you won't have to deal with the complications of the external instrument setup in Logic. But before I continue, what kind of mixer do you have?

Link to comment
Share on other sites

OK! Even though it's an inexpensive mixer, as long as it's not too noisy, it should be fine.

 

I am going to suggest that you do not use the external input in Logic. This is for several reasons:

 

1. Your Presonus only has two audio inputs. This means that you can only listen to one of your synths at a time. With the mixer, you can combine the sound of the synths and hear them both at once.

 

2. Monitoring Latency -- something you want to avoid. I'll explain:  when you use the external inputs to bring "live audio" into Logic (like the sound coming from your synths), you would need to use the software monitor function to hear it. This means that the sound has to get into Logic (via the external instrument) and then back out to your audio monitors. This doesn't happen instantaneously! There will always be a slight delay. It is unavoidable, and every audio system has this slight delay.

 

The delay is necessary to give the computer time to process audio data/plugins/audio instruments in real time. The delay is something you can set yourself -- it's called the I/O buffer -- see your audio prefs.

 

Buffer values range from 32 to 1024. Notice that there's no value of zero! So you can't turn it off (that's why I said it's unavoidable). Ideally, you want to set the I/O buffer to its lowest setting (low setting = least delay). But many systems don't work well at the lowest I/O buffer setting (32). If it's set too low you will hear digital garbage in your audio tracks or plugins. Most people have to use a setting of 64 or 128. Some even need to use 256.

 

Now, when you use software monitoring, the live audio from your synths has to get into Logic and then back out to your speakers. It's delayed on the way into Logic and also back out by the buffer amount (so it's buffer amount x2). And if your buffer setting is high, when you play a note on your synth, it will probably sound later than when you played it.

 

But even if you're able to run your system at a buffer setting of 32, the sound may still feel late.

 

So... if you use the mixer, you avoid all of these problems! (You still have to experiment to find the optimal buffer setting so your system runs correctly), but you will always hear your synths live and playing perfectly in time because you will always be hearing the direct audio from the mixer.

 

The Behringer seems set up nicely so that you can send audio to Logic for recording, but still hear your synths live.

 

So that's my advice: stick with your original setup. Do not use software monitoring of external instruments. Read your Behringer manual to learn how to use it to send audio to the Presonus for the sounds you want to record. Then, record your synth audio to regular audio tracks (just like you would for guitar, vocals, etc.).

Link to comment
Share on other sites

i have all my connects through the mixer correct but how would i convert the sounds from my module (using midi) to audio in logic?

 

is this what i do:

 

1) select empty project

2) select AUDIO

3) choose the format to STEREO rather than MONO?

 

i just tried that and was able to record and bounce the sounds from my motif board (not the roland module) but i'm still not hearing sounds from the roland because it is connected through a MIDI cable directly to the motif.

 

also, when i record in this format, the metronome is recorded along with what i'm playing. when i play back, the metronome is recored. is there a way i can disable this? the metronome is not giving me a click sounds, it's giving me a piano sound.

Link to comment
Share on other sites

You don't convert anything. You record your synths as audio, exactly the same as if you were recording a guitar or bass or something.

 

You select a stereo audio track if you're recording a stereo sound.

 

If you don't want the metronome, turn it off (click the metronome icon in the transport).

 

I want to suggest that you read the "Getting Started" manual to help you learn these basic things.

Link to comment
Share on other sites

"i just tried that and was able to record and bounce the sounds from my motif board (not the roland module) but i'm still not hearing sounds from the roland because it is connected through a MIDI cable directly to the motif. "

 

I think that herein lies the root of your problem. If you have only a midi cable from the Roland to the Motif - you are missing audio cables. Plug left and right outputs (or stereo out) from your Roland - either directly to 2 inputs on your interface if they're available - or into your mixer that's going in to your interface - Right Away.

 

Arm a stereo channel strip in Logic - put it in record - and choose for inputs in that channel strip whatever channels you routed your audio cables into. So, if you put your left and right audio outs from your Roland into (for example) inputs 3 and 4 of your interface... choose inputs 3 and 4 on your channel strip. If you plugged your audio outs from your Roland into your mixer - you'll have to choose whatever signal path you're using to feed the signal from your mixer to your interface. Forget the Motif in relation to the audio from your Roland. You're talking MIDI with that... not audio.

 

Hope you can work this out

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...