Jump to content

Making two audio regions the _exact_ same length?


submute

Recommended Posts

Sorry David, but your method does not work with Audio Regions otherwise I could show it first !

This method works with midi regions only, and will cause Audio Stretch if try to operate with audio slices, that's why I showed the tip with Event list length toggle of the target sequence !

If you follow the Topic title, the question is "audio regions".

Link to comment
Share on other sites

Sorry David, but your method does not work with Audio Regions otherwise I could show it first !

This method works with midi regions only, and will cause Audio Stretch if try to operate with audio slices, that's why I showed the tip with Event list length toggle of the target sequence !

If you follow the Topic title, the question is "audio regions".

 

Oops. Thanks for pointing that out. Event list it is!

Link to comment
Share on other sites

Command - Shift and edit right region corner in Arrange (it works, but you may have to move the mouse left/right a few times first).

 

Press the modifiers after you have grabbed the region edge.

 

I just tried it, it doesn't seem like holding Command-Shift does anything different than if you weren't holding them? In fact the help tag still says "Length Change". In any case it doesn't make the region lengths equal, at least not here (8.0.2, 10.5.4).

 

My guess is you meant "Option-Shift", but you didn't realize it was also time-stretching your audio regions? Does your help tag say "Stretch (Equal Length)"? If yes you're pressing Option-Shift, and you're time-stretching the regions, making them the same length.

Link to comment
Share on other sites

Command - Shift and edit right region corner in Arrange (it works, but you may have to move the mouse left/right a few times first).

 

Press the modifiers after you have grabbed the region edge.

 

I just tried it, it doesn't seem like holding Command-Shift does anything different than if you weren't holding them? In fact the help tag still says "Length Change". In any case it doesn't make the region lengths equal, at least not here (8.0.2, 10.5.4).

 

That's weird, I'm on the same OS/Logic version (Mac Pro) and it works here, even if it seems like it doesn't work at first attempt.

 

We're not talking about stretching, but editing region length - right?

 

It's a little buggy - you have to first make both regions very short - and then extend them to get this feature to work....

Link to comment
Share on other sites

What does the help tag say? I don't think Command-Shift is doing anything that you couldn't do without holding those modifiers. I can make all the regions the same length by shortening them without holding any modifiers, and as you're describing, I have to go left/right a few times until the length is "0", or 1 tick.
Link to comment
Share on other sites

Command - Shift and edit right region corner in Arrange (it works, but you may have to move the mouse left/right a few times first).

 

Press the modifiers after you have grabbed the region edge.

It's quite late here and I'm a way of my studio and L8, but as far as I remember my tests around, there was some phantom Logic behaviour about. I.e, only the first audio track could handle that but the rest do not....

Link to comment
Share on other sites

  • 7 years later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...