Jump to content

Battery 3 Multichannel


Kimono

Recommended Posts

I've followed some of the tips in this forum about using Kontakt in multichannel mode in Logic which are great, but I'm confused with Battery 3 in multichannel mode. I can add Battery 3 as a 16xMono, and add the extra Aux channels Battery 2-16 into the mixer fine, but setting each cell's channel in Battery is a bit weird because the output options listed are Master/ST3-4/ST5-6/ST7-8/ST9-1/ST11-12/ST13-14/ST15-16/Mono 17,18,19,20,21,22,23,24.. These are always the same regardless of the Battery plugin mode , 16xmono, 1xstereo,15 mono etc..

 

They don't match the input channels available in Logic, and no matter what I select as the output in Battery, nothing works unless I set the cell back to using master.

 

Is something screwy with my setup? It's a pretty brand new install of Logic and Battery...

 

thanks!

Link to comment
Share on other sites

If you are using a mono output channel of Battery, then when you create an aux in Logic you need to change that aux to mono by clicking the little figure-8 below the channel meter. This will allow the aux to see mono channels coming from Battery.
Link to comment
Share on other sites

I like your signature, so true...

 

Logic had already done that for me. But I've made some progress. Here's my layout.

 

Battery set to 1xStereo, 15xMono Output.

Inst 3 - Battery 1&2

Aux1 - Battery 3

Aux2 - Battery 4

Aux3 - Battery 5

Aux4 - Battery 6

 

I want the kick on Aux1, but when I try set the kick on cell 1 in Battery plugin, the output options only list all the stereo pairs 3/4 5/6 7/8 etc then all the mono pairs after it. It's as if Battery hasn't set itself up for 1xStereo 15xMono mode or something.

 

The strange thing is, when I set cell 1 to 3/4 in Battery, Both AUX 1 and AUX 2 show activity on their meters for the kick drum... So battery is sending stereo on 3/4 ... Is it a panning thing? Am I required to pan all the odd numbered cells one way and even's the other?

 

 

any tips appreciated... maybe this is the way it is..

 

 

KIMONO

Link to comment
Share on other sites

I want the kick on Aux1, but when I try set the kick on cell 1 in Battery plugin, the output options only list all the stereo pairs 3/4 5/6 7/8 etc then all the mono pairs after it. It's as if Battery hasn't set itself up for 1xStereo 15xMono mode or something.

Right. I'm not sure why Battery presents you with those options when selecting it as an instrument in Logic. It always loads with that output selection you describe.

 

The strange thing is, when I set cell 1 to 3/4 in Battery, Both AUX 1 and AUX 2 show activity on their meters for the kick drum... So battery is sending stereo on 3/4 ... Is it a panning thing? Am I required to pan all the odd numbered cells one way and even's the other?

No. Just set Cell 1 to one of the mono Battery outputs, eg 17. Then make sure aux 1 is set up as mono and select that Battery output as its input.

 

So, yes, that's just the way it is. You could ask NI, but its been my experience that's it's difficult to get useful and accurate answers from them.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...