Jump to content

Logic Pro 8 and Yamaha DM2000


Recommended Posts

Hello!

 

I have been Nuendo user for 8 years. Now I decided to buy a new Mac Pro and Logic Pro 8. It works very well, except "time display" on my Yamaha DM2000.

 

Under Nuendo works ok. The time shows correctly (the same as in Nuendo).

I set up midi timecode under Synchronization setup to Yamaha USB port.

 

Under Logic Pro 8 the Yamaha's display shows 00.00.00.00 all the time.

 

Where can I set up "transmision Midi Timecode" in Logic Pro 8? I try a few settings but it still don't work!

 

TNX for your help!

Link to comment
Share on other sites

Open OSX's Audio MIDI Setup. Create a new device and in its properties check Receive MIDI Timecode. Name the device DM2000. Cable it to the port you physically have it connected to.

 

In Logic, open Project Settings-Synchronization-MIDI tab. Under MIDI Time Code check Transmit MTC and select DM2000 from the dropdown list.

Link to comment
Share on other sites

On DM2000: Time reference: MTC USB-1, 25 frames

 

In Logic Pro: under Synchronization --> General --> Sync mode: Internal, Frame rate: 25 fps (auto detect format of MTC), Validate MTC: always.

 

Under Synchronization --> MIDI --> MIDI Time Code (MTC) - checked "Transmit MTC" - Yamaha DM2000 Yamaha DM2000 Port1

 

BTW... REMOTE Layer works ok (time code display under remote layer also), but under "normal" layer I want to display time from logic on DM2000 ... but ... :(

Link to comment
Share on other sites

All the time is just:

 

TIME SOURCE MESSAGE CHAN DATA

22:26:550 From YAMAHA DM2000 Port1 Note On 1 C-2 127

22:26:786

22:26:...

...

...

...

 

When I click on PLAY button in Logic nothing happen.

Link to comment
Share on other sites

That looks like your viewing what's coming into the Mac. You want to set it up to view what the port is outputting.

 

Wait, do you have this board set up as a HUI Control Surface?

 

What other option could he go for? DM2000 ain't got EuCon or anything....except MIDI which is basicly the same as HUI.

Link to comment
Share on other sites

It works!!!

Cool.

"Yes, I have HUI - USB 1-3.

That's why I asked. The Control Surface system in Logic blocks ports to/from the sequencer if the ports are assigned to a control surface.

 

Note your original question regarded strictly MTC and not in tandem with control surface use.

Link to comment
Share on other sites

Now it works as I said... But how can I SAVE this settings?

 

Always when I start Logic Pro and new project I must first click on Project Settings and set MTC Timecode...

 

Could this be saved once for everytime I open Logic Pro / new project?

 

Sorry about my English :oops:

 

TNX!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...