Jump to content

Control surface interruption


Lo-Fi Massahkah

Recommended Posts

Hi all,

 

Maybe I should first introduce myself. Been into electronic music for a while. I'm most comfortable with Ableton Live, but also use Max/MSP. Apart from my Nord Modular - I'm all software based nowadays. I do like the technical (geeky?) bits of music making, which is certainly distracting at times. Now to my problem...

 

I'm new to Logic and I'm having trouble with my control surfaces setup. I'd like to use my Faderfoxes (regular CC sending controllers) which are setup on their own port of my audio interface. Problem is that my Nord Modular (also on it's own ports) is sending a continous stream of sysex trying to communicate with it's editor. So when I click cmd+L to midi assign a knob/fader in Logic, the stream from the Nord is what's being assigned.

 

I've figured out that you can enter the environment to filter out certain ports - but as far as I understand that's only information going to the sequencer. All control surface data is still let through. Is there any way I can decide what ports I want Logic to listen to for controller data?

 

Cheers,

.m

Link to comment
Share on other sites

I'm not positive this will work as I haven't tried it, but in the Project Settings MIDI tab, Input Filter, try checking the System Exclusive box.

 

Fingers crossed!

 

Thanks. I actually tried that before as well. Seems to only filter data going to the sequencer. :(

 

Cheers,

.m

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...