Jump to content

change tempo without time stretch


bantam

Recommended Posts

i have audio tracks that were recorded at 115bpm. i brought them into a session with the default 120bpm but when i try to change to 115 so the grids line up it seems like its shifting things around. am i crazy?
Link to comment
Share on other sites

am i crazy?

Perhaps, but the behaviour you describe is normal. After all, why wouldn't you want your events to follow the tempo. If you don't want your regions to move when you change tempo, then select them, then in the Region menu select Lock to SMPTE. Now change your tempo.

Link to comment
Share on other sites

ok thanks

 

they were recorded at 115 and imported. if i change from 120 to 115 isn't that actually pushing them to 110.

bantam,

Please try to be more specific. In the title of your post, you say "time stretching" and then you refer to the tempo as "shifting things around".

 

Which is it?

Link to comment
Share on other sites

ok, as the regions shifted they appeared to get longer ( i though they were time streching) maybe this is just a zoom thing. thanks

 

That's purely visual, because Logic displays the bars at the new tempo with the same width as the old tempo. The regions are not time stretched, you can check that by soloing them and listening. Don't trust your eyes (or Logic's display for that matter)!

Link to comment
Share on other sites

  • 1 year later...

This articile might give you some good insights: http://support.apple.com/kb/HT3855

 

I've been having trouble with time-stretched audio when trying to adjust tempo. Ultimately, all tracks recorded with Logic Pro have embedded tempo information. So, if you change the tempo of the song, then the tempo of the track changes (causing perceived stretching).

 

I think if you essentially select a region, then use "Options--> Tempo--> Remove Tempo Information from Audio File" that you can then export the file and it will be naked. You can then import it into a project where the tempo is accurate. (You can also use beatmapping to adjust the tempo of the project, per the article.)

Link to comment
Share on other sites

  • 9 months later...
This articile might give you some good insights: http://support.apple.com/kb/HT3855

 

I've been having trouble with time-stretched audio when trying to adjust tempo. Ultimately, all tracks recorded with Logic Pro have embedded tempo information. So, if you change the tempo of the song, then the tempo of the track changes (causing perceived stretching).

 

I think if you essentially select a region, then use "Options--> Tempo--> Remove Tempo Information from Audio File" that you can then export the file and it will be naked. You can then import it into a project where the tempo is accurate. (You can also use beatmapping to adjust the tempo of the project, per the article.)

 

Sorry this is a late reply but yes!!! Thank you so much, this question has been asked hundreds of times on the net and the manual has no info that I can see, but people always answer it wrong until now. You are a legend, I ripped some vinyl straight into logic with a 120bpm setting on the project but realised the sample was 140bpm so it kept altering the file when I put it in a 140BPM project. Stripping the tempo is exactly what I needed. So simple!

 

Thanks

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...