Jump to content

Files will not rename


Stu Diddly

Recommended Posts

I am currently running Logic 7 Pro and I've recently moved all of my stufff over to a Pwermac G5. Well, I started a new session today and the first instrument i tracked was bass. When I recorded bass, the window prompted me to choose the Audio files destination folder, as normal. After I tracked bass, I started tracking guitars, but the files wouldn't rename to the track title. The guitar files and the files after would just rename as: bass#08, bass#09, etc... Do you know how to fix this?
Link to comment
Share on other sites

Just to be sure you understand what you're seeing in the audio window...

 

ACTUAL FILE NAME1

  region #01

  region #02

  region #03

 

ACTUAL FILE NAME2

  region #04

  region #05

  region #06

 

You can rename the regions to anything you want (as long as they're not exactly the same as the filename, i.e., if your actual file name is "Bass.aif", you can't name your region "Bass.aif".

 

Your filenames have to be unique. If they're not, Logic will say, "yo!" in a warning dialog box.

 

So regarding the track title, I'd suggest making an acronym of it, i.e., your song is called, "I Love You, But Can I Sleep With Your Sister Too?", name your files "ILUBCISWYST Bass", "ILUBCISWYST Guitar", etc... This way you have unique filenames and still some association with the song.

 

:mrgreen:

Link to comment
Share on other sites

I totally understand what you're saying and I'm doing everything correctly. I've been able to rename the regions, but I want the "Actual Audion File Name" to save as whatever the track is named. Here's an example:

 

"Elec Gtr"---------This name appears in the Audio and Arrange Window

--Elec Gtr #6

--Elec Gtr #7

 

"Acoustic Gtr"

--Acoustic Gtr #1

 

Why would everyone of my audio files be named:

 

"Bass#08"---------This is really supposed to be an Electric Gtr track

"Bass#09"

"Bass#10"

 

Do you know why it's automatically naming the files by the first audio track that I recorded into my "Audio Files" folder?

Link to comment
Share on other sites

As you can see in this screenshot (from your audio record path settings), you have the choice of having your audio files named after the audio object name, or, the explicit name that you enter in this very dialog box to name your files. I'll explain...

 

Regarding the first bit ("audio object"), in Logic 7 each 'channel strip' has a generic name like "audio 1", audio 15", etc. If you were to actually go into the mixer layer of the environment and change "audio 15"' to "guitar", say, then the files you record on the track assigned to that audio object will be automatically named "guitar".

 

In the screenshot, that option in unchecked. This sets up the other method, whereby when you set up the audio record path for the first time, you have to enter a name for the file you're going to record. That name will stick until you actually change it (that's what I meant by an "explicit" name).

 

So I'll bet that right now, the "File Name" field in your prefs says "bass". Change that to "guitar" (or whatever) and you should be good to go. And then change it for each subsequent track ("acoustic", "piano", etc.).

80042401_Picture1.jpg.4afd5d9e39f7feec035de5fb3df1d2d2.jpg

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...