Jump to content

LPX Control Multiple Instruments on Different MIDI Channels


David Nahmani
 Share

Recommended Posts

I've followed the instructions from David, but I'm having a strange problem with MIDI notes not stopping.

 

I'm using an Novation Remote SL61. I have multiple zones set up using different keyboard ranged to send to different midi channels.

 

Within Logic my tracks are armed and set to receive on the corresponding channels.

 

When I play in zone 1 everything works fine. When I move to zone 2 each note I play is sustained. Its like the MIDI note off message is not being received, but I can see from the transport display that the off message is being received.

 

If I disarm the track that relates to zone 1 (channel 1), then the notes I play in zone 2 (channel 2) work fine.

 

I have no idea of the problem is within Logic or with my setting in the SL.

 

If David or anyone has any ideas I would be very grateful for your help.

 

Cheers,

Andrew

Link to comment
Share on other sites

  • 1 month later...
OK I understand the steps outlined above. However how do I create an environment for my 003R+ interface and my Akai Mpc 2500 and then create a multi instrument? Urgent Please Help!!!!!!!!!!!

E sharp

imac dual core 3.06 ghz 4gb ram dual 500gb glyphs

logic pro 9 pro tools 8 Tascam msr 16, tascam da 80

mpc 2500

Link to comment
Share on other sites

OK I understand the steps outlined above. However how do I create an environment for my 003R+ interface and my Akai Mpc 2500 and then create a multi instrument? Urgent Please Help!!!!!!!!!!!

 

Since this is not related to this thread, I suggest you start a new thread with your question in the Logic forum, it'll get more visibility.

My new Logic Pro Book is out!

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

Little tip:

 

Remember to turn OFF the Demix MIDI function when you want to get back to playing by yourself. Or else you might spend 30 minutes fishing around days later, like me, trying to understand why you suddenly can't play more than one softsynth/sampler at a time!

Logic 10.7 | OS 11.6 | Mac Mini M1 | 16GB RAM | MOTU 896Mk3
Link to comment
Share on other sites

  • 2 months later...
  • 6 months later...
  • 7 months later...
Only PROBLEM with this setup is that ALL VIs in record mode are being CALCULATED on ONE processor and NOT 8. Additionally, try this.

 

1) Enable 2 VIs to play drums from an external sequencer like the MPC.

Set the Buffer in Logic to 32 or 64 samples. Play back and listen.

 

2) Now, with the same setup, up the buffer to 1024 or 2048. Listen to that and take note of how the timing changes to something which is impossible to listen to.

 

Using Logic as a host for VIs on a separate CPU is not good beyond a buffer of 32. Not because of latency but because Logic is

 

1) Altering the incoming midi timing based upon the set buffer

2) Logic wont distribute the CPU load to multiple processors while in this mode.

 

Only way to get a good timing is to use the stand alone versions of the VIs and leave Logic out of it. The stand alone versions WILL distribute to multiple cores very nicely and they WILL NOT alter their incoming midi timing regardless of buffer size

 

 

This is still a very big issue for me. What a waste of power. (1) core! Boooo! 9.1.6 and this is still not fixed.

 

Anyone have a work around for this?

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...

David,

 

I am having almost the exact same issue that was posted earlier on this topic... I am trying to record my midi keyboard and electric drum kit simultaneously into Logic Pro 9 via a MOTU micro lite. I configured it in the audio MIDI setup, and also deselected all the other transmit and receive channels for each instrument other than channel 1 for keyboard and 2 for drums. Now after I followed your instructions at the beginning of the post my results were as follows:

 

If track "Keyboard" (midi channel 1) is selected, both instruments come in on the keyboard track.

If track "Drums" (midi channel 2) is selected, both come in on their designated tracks.

If any other audio track is selected -- keyboard comes in on keyboard track, and drums don't work at all.

 

So the keyboard is consistent, and the drums record on whatever track is selected. :?: How do I fix this?

 

Thanks a lot!

Link to comment
Share on other sites

If track "Keyboard" (midi channel 1) is selected, both instruments come in on the keyboard track.

If track "Drums" (midi channel 2) is selected, both come in on their designated tracks.

If any other audio track is selected -- keyboard comes in on keyboard track, and drums don't work at all.

 

So the keyboard is consistent, and the drums record on whatever track is selected. :?: How do I fix this?

 

Instead of simply selecting the tracks, go straight for their R buttons and verify that they stay active when you select some other track.

 

J.

Mac mini 2018 3.2 GHz 6-Core Intel Core i7 - 67GB RAM | macOS 11.6.1 | Logic Pro 10.7.1
MacBook Pro 15" Retina i7 2.2 GHz - 16GB RAM | macOS 10.15.7 | Logic Pro 10.6.3
Merging Hapi | Merging Anubis | RME Fireface 400 | Akai MPK49 | Nord Micro Modular

Link to comment
Share on other sites

Thanks for the quick reply! Unfortunately your suggestion isn't working for me... When I click away from the midi tracks both of the "R" buttons are still red (not just the letter but the whole button) and I'm still having the same problem as before. I'm concerned that perhaps the MIDI channel 2 isn't locked onto the drum track somehow. Is it something I need to do with the micro lite?
Link to comment
Share on other sites

I'm concerned that perhaps the MIDI channel 2 isn't locked onto the drum track somehow. Is it something I need to do with the micro lite?

 

Before checking the micro lite, check that the kit is actually sending data on the intended MIDI channel.

 

Download this free MIDI monitor so you can see what is actually going in and out of your system MIDI-wise:

 

http://www.snoize.com/MIDIMonitor/

 

J.

Mac mini 2018 3.2 GHz 6-Core Intel Core i7 - 67GB RAM | macOS 11.6.1 | Logic Pro 10.7.1
MacBook Pro 15" Retina i7 2.2 GHz - 16GB RAM | macOS 10.15.7 | Logic Pro 10.6.3
Merging Hapi | Merging Anubis | RME Fireface 400 | Akai MPK49 | Nord Micro Modular

Link to comment
Share on other sites

Ahh you just saved my life! Turns out that the kit was sending on the default drum channel and all I had to do was select MIDI channel 10 in logic and it works like a charm. One other question though -- my micro lite has 5 ports each with their individual channels, so technically "channel 1" refers to 5 different inputs if I'm not mistaken. If I plug in a third MIDI instrument into port 3 of the micro lite it also comes in on channel 1. How do I get Logic to differentiate between ports as well as channels?

 

Thank you so much!

Link to comment
Share on other sites

Hi there everyone, as more and more of you write your successes here i get more and more frustrated!:(

 

Have a small family music room containing.

Alesis DM6 USB drums

m-audio Oxygen 49

m-audio Fast Track (Guitar only)

Logitech (Rock Hero) USB Microphone

 

MacBook Pro and Edirol active speakers.

 

I can't seem to separate the keyboard and the Drum kit, and i don't see the microphone.

I have tried the tips & trick suggested here with absolutely no luck!:(

 

Can anyone please walk me trough, step by step? Ill even grant you access to my computer by teamviewer if that makes it easier...

 

The goal is to play together.

Link to comment
Share on other sites

  • 1 month later...

Hi there,

 

I just purchased the Micro Lite in order to control and record 3 keys at the same time. the midi data gets into logic through different channels, now the problem is that it doesn't go back to the keys to reproduce the sound. all cables wired already. but no luck. already tried everything i can think of, even environment. need help asap.

thanks

Link to comment
Share on other sites

  • 9 months later...

I have a Yamaha MOX 8 and a Novation 49SL MKII both connect by USB (separate connections) as MIDI device and they both work with Logic 9 (OSX 10.8.3). Although I followed the posted instructions but I cannot get the different MIDI channel (each will play the same instrument, no matter what channel I select). NOTE: My devices are routed to different channels, as scenario works with standalone synths but not in Logic.

 

I believe that I have changed the channels on both but how can I verify which channels these two devices are using to transmit signal (can I use Audio MIDI Studio; if so how)? Also is there a tutorial on setting up Channel Splitter object?

Link to comment
Share on other sites

I believe that I have changed the channels on both but how can I verify which channels these two devices are using to transmit signal

In Logic's transport bar, where it says "No in" is a MIDI input monitor. Play a note on a keyboard and you'll see a little note icon and some numbers. The number directly to the right of the note icon is the MIDI Channel number.

My new Logic Pro Book is out!

Link to comment
Share on other sites

  • 4 months later...

Thanks for the tutorial David—it helped get my growing studio working with e-drums.

 

I've attached a Logic Pro X screenshot that goes along with step 1 in David's initial post in this thread in case anyone has a hard time locating the recording settings.

midi.thumb.jpg.0208dadb836ca5400ae3562b565b7351.jpg

Logic Pro 10.0.7 and 9.1.8 | Apogee Quartet and Focusrite Octopre | KRK Rokit 8 v2 | Nektar Panorama P4 | Mackie MCU |

MacBookPro 2.6 Ghz Intel Core i7 16 GB RAM with OS X 10.9.2 | Solid State drives (internal + external)

Link to comment
Share on other sites

  • 4 weeks later...

Ask your question in the Logic Pro X forum, if I see it, I'll help you there. Also make sure you click this link to your signature and add your system information:

• Logic version and sub-version (e.g. Logic 10.0.3)

• OS X version and sub-version (e.g. OS 10.8.4)

• Computer (e.g. MacBook, Mac Pro, iMac)

• Processor (e.g. 2 GHz Intel Core 2 Duo)

• Memory (e.g. 2GB)

• Audio interface manufacturer and model (e.g. Presonus AudioBox USB)

 

(most of that information can be found by choosing Logic Pro X > About Logic Pro X, and  > About This Mac)

My new Logic Pro Book is out!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...