Jump to content

Native Inst & Logic pro Incompatibility


Hadi

Recommended Posts

I have recently got my new MBP. I installed my Native Inst Komplete 5 first and then installed logic pro studio.

 

The problem is that Logic dosen't recognize most of the VST from NI's,

I have tried everything possible. at first there was a difficulty when logic stats scanning few times I have to reinstall some instruments till i got to the point where i can open logic with no messages or anything. ( missing files and all)

 

Logic recognizes few of the Komplete package. but massive battery and some don't show up. even the once i have don't make a single sound even though i think they are hooked up properly

I tried going Logic pro>Preferences>Audio units manager and still didn't work out.

 

I'd realy appreciate if someone has a suggestion because it's so frustrating.

Link to comment
Share on other sites

Did you install the Audio Units versions of all the instruments, and are the .component versions of the instruments in the HD/Library/Audio/Plug-ins/Components folder? I've recently switched from PC/Cubase to Mac/Logic and have had no problems with Logic seeing the the Komplete 5 instruments.

 

Chris

Link to comment
Share on other sites

[quote name="Hadi"

The problem is that Logic dosen't recognize most of the VST from NI's' date='[/quote]

 

The problem is actually that Logic wont recognise any vsts. but maybe you know this already and just wrote incorrectly. But if you didnt know that Logic doesnt suppert vsts then this is almost certainly the problem . though its strange that some of the NI instruments work while others dont....check to see if the ones that are NOT working are present as Audio Unit components, NOT vsts, in Library>Audio>plug ins>components. if not , then thats your answer.

 

but perhaps you know this stuff already and the problem is something more complicated.

Link to comment
Share on other sites

Did you install the Audio Units versions of all the instruments, and are the .component versions of the instruments in the HD/Library/Audio/Plug-ins/Components folder? I've recently switched from PC/Cubase to Mac/Logic and have had no problems with Logic seeing the the Komplete 5 instruments.

 

Chris

hmmm well, no. to be quite honest all I did is install the NI's on the HD not in the applications or anything and NO I didn't click and drag or any of that.

 

What actually works in Logic is The MIDI instruments which I don't think they arete real VST's I want. Battery, Massive, Kontact and all don't.

 

Yes it dose show as authorized I actually have true copy so I hope this is not the issue.(thanks for asking)

 

so from what I understood is that you have to place the VST's in a specific location in order for them to work efficiently with Logic.

Link to comment
Share on other sites

[quote name="Hadi"

The problem is that Logic dosen't recognize most of the VST from NI's' date='[/quote]

 

The problem is actually that Logic wont recognise any vsts. but maybe you know this already and just wrote incorrectly. But if you didnt know that Logic doesnt suppert vsts then this is almost certainly the problem . though its strange that some of the NI instruments work while others dont....check to see if the ones that are NOT working are present as Audio Unit components, NOT vsts, in Library>Audio>plug ins>components. if not , then thats your answer.

 

but perhaps you know this stuff already and the problem is something more complicated.

 

No, I actually don't know this stuff. thanks for asking, I followed the location and I did see all the VST's in the components folder they had weird icons(yellowish)

 

WHAT DO YOU DO TO MAKE LOGIC RECOGNIZE THE VST?

Link to comment
Share on other sites

logic will not recognise the vsts. full stop. (well, with a VST wrapper it will, but thats not what you need here).

 

Logic will instead recognise the AU versions of Kontakt, Massive etc.

 

bin the VSTs, and install/drag the AU components to the components folder. should fix it.

 

hey man. can you please explain it to me in a more simplistic way?

im kinda new to all this

Link to comment
Share on other sites

sorry, i actually probably explained it too simplistically: i.e not very accurately.

 

I cant remember how u go about installing NI instruments, but i wouldve thought that normally running the isntallation process should have put the Audio Unit Components automatically in: harddisk>Library>Audio>plug ins>components

 

if this has not happened automatically then i guess you need to manually drag the audio unit components into harddisk>Library>Audio>plug ins>components yourself.

 

and that should be it. they should now show up in logic next time you open it.

 

you said you already put the VST components in the components folder, right? so just delete them, and instead drop the AU components in the folder instead.

 

just one little question has occurred to me: you do have a mac version of NI komplete, right? otherwise all of this aint gonna get any of those instruments working under any circumstances. if you cant find any AU versions of the NI instruments then maybe its cos its a PC version of Komplete?

Link to comment
Share on other sites

Hi..Check to see if all the Komplete stuff is absolutely up to date..You may need to update the ones you mentioned due to thwm not being Leopard compatible at the time your Komplete5 box was recieved..I would say start there first..You can do this via the service center.

 

Do not do any custom instal for any updates..This should instal AU...VST...as well as RTAS versions in the appropriate folders..Update them all and do an easy instal..Even if they are up to date this will instal all three types of formats..Then it is allways best to open the NI stuff standalone..Some need to build a database,which is used by KORE and also for the attributes browser..

 

Even if you have done this once..Do it again with every uodate..Then see what happens..JON

 

Also Please read this and make the needed adjustments.. http://www.logicprohelp.com/viewtopic.php?t=29410

 

#5 is very important for anyone to be of help..JON

Link to comment
Share on other sites

sorry, i actually probably explained it too simplistically: i.e not very accurately.

 

I cant remember how u go about installing NI instruments, but i wouldve thought that normally running the isntallation process should have put the Audio Unit Components automatically in: harddisk>Library>Audio>plug ins>components

 

if this has not happened automatically then i guess you need to manually drag the audio unit components into harddisk>Library>Audio>plug ins>components yourself.

 

and that should be it. they should now show up in logic next time you open it.

 

you said you already put the VST components in the components folder, right? so just delete them, and instead drop the AU components in the folder instead.

 

1. the AU has been automatically installed in the lpugins because I tried to install them from the NI installation disk and it said that it is unnecessary.

2. I don't really know how to put the VST components there. do i like drag the actual VST"s to the component folder???

 

and yes i is a MAC NI version because they actually work on their own if I opened them but they won't be recognized by Logic as we said.

 

just let me know about the second point.

thanks for your help man.

Link to comment
Share on other sites

1> if the AU components have been installed correctly in the components folder then you have a different problem and probably need to forget most of what I have said and instead follow the advice of other people above. it sounds like your problem is more complicated.

 

2> please forget about VSTs forever now (or for as long as you use logic): you cannot use ANY VSTs EVER in logic. (this is an exaggeration, as there is a way round it, but I'm not sure its worth the bother). But to put it simply, you cannot use any VST in logic. so next time you are on a website that offers freeware VST instruments or whatever, but no AU version, forget it, you cant use them.

 

Im sorry I dont know how to solve your problem now cos I dont really know about NI stuff, but I'm sure someone else will help. try some of the suggestions made above.

 

but just the fact that you now know that VSTs will not work with logic, but that AU plugins will (and where to put the AU components manually) means next time you download a freeware synth or something you'll know what to do with it.

 

sorry i cant be of more help (Im in the middle of moving house and really sghouldnt be on here at all...its chaos).

 

good luck

Link to comment
Share on other sites

Hi..OK..As mentioned by prjkt you can start there..BUT do not just instal the AU units..It is best to allways do an easy instal or a custom instal if you need to designate a path for samples..An example is that NI's Kore software will NOT work in Logic if only the AU component is installed..Kore is a wrapper and needs the VST version to be installed for the AU version to open in Logic..So a basic rule of thumb is to instal all versions avaiable..AU,,VST,,RTAS...And they should certainly instal the components in the correct place..JON

 

And once again Please go and change your signature so it includes OS etc..

Link to comment
Share on other sites

  • 2 weeks later...
congrats. The NI stuff can be a big beeeotch. Use your Service Center regulary to keep everything up to date. I love Komplete.

 

(ps..if you haven't gotten Kore 2 yet..GET IT). You'll love your NI stuff even more.

 

=

 

dude - I'm not trying to argue, no way. but i kinda take a slightly different approach on updates. With Komplete 5, Kore 2, Logic, Live, UAD2, all the spectrasonics stuff and a few more i forget to mention, once i get things stable, unless I have a problem, I kinda just leave it. Updates don't always make things better...

 

And as you say, Kore 2 is very nice. it really does kinda glue it all together. plus it's the only sane way to deal with pro53 presets

 

i simply love Absynth, massive, reaktor, kontakt and pro53

 

peace

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...