Jump to content

What can i buy for my mac to stop "system overload&quot


N33MA

Recommended Posts

I bought this Mac with logic because i heard it was a stable platform to work from.

 

This seems more and more further from the truth the more i use it.

 

32 channels of audio with 20 plugins is definately not too much for the system..especially for a top end Mac.

 

Please PLEASE help me...deadlines are looming and i really need this fixed fast.

Link to comment
Share on other sites

N33MA... Ive been having same said problem like you and a zillion others. Wonder if this should be a sticky post for the amount of people that have touched on/talked about this issue in varying degrees. So much to be said about it and so much speculation. This is a very spread out topic on this forum and other forums as to the topics subject matter being the same but the topics subject header can be a myriad of different wordings. Of course every situation is going to be somewhat different due to everyones different system setup, what plugins their using etc etc...not knowing the specifics of your particular setup-im going ahead and posting this response to your question anyways. Its so broad and sweeping of a response that maybe it'll help someone if not you in particular. I wish there were ONE posting where everyone afflicted (and as i said earlier it appears to be in the "zillions") all chimed in together with suggestions ,tips, theory's, whatever, on this subject that plagues so many.... apple where the hell are you?

Anyways, here's a hodgepodge of tips Ive been collecting (Ive cherry picked these advice tidbits from so many various places that that i cant give credit to the authors of any of these ideas. My apologies if anyone reads any of this and the wording rings as if it were theirs).

-So here it goes

--- Turn off journaling on any external drive you might be using.

--- Try higher buffer size if you are not recording.

--- Ensure that Max Recording Time pref is set to 1 minute/5 minutes etc. (as required).... (i havent been able to figure this one out, maybe its talking about older versions of logic or something)

--- Optimize amount of memory song requires by Reorganizing Logics internal memory.... Options>project information (this one i dont really get either... it may be talking about the same thing as the tip directly above).

--- Turn off software update

--- Disable spotlight indexing

--- Disable spotlight shortcuts

--- Disable dashboard shortcuts

--- Turn Airport off

--- Turn off energy saver.....do not check "System preference->Energy Saver->Put the hard disk(s) to sleep when possible"

--- Uninstall, reinstall audio interface drivers.

--- Move the track that is higlighted ie select another one

--- It sometime helps to page down from the top of logic and manually trigger,or "wake" if you will,all the tracks...Very annoying..Or just turn the volume down and start and stop 10 or so bars in...

--- Set the input of EVERY AUDIO TRACK to "NO INPUT."

--- The Larger Disk Buffer check box governs how much data Logic buffers into RAM from the hard disk before playback. This setting represents a real trade-off between RAM and hard disk usage. If the System Performance meter indicates that Disk I/O is the source of overloads, then Larger Disk Buffer should be enabled. If the Audio meter in System Performance is peaking, then disabling Larger Disk Buffer may help.

--- The Process Buffer Range: setting determines how large a buffer Logic sets aside for its mixing engine. As with the I/O Buffer Size, smaller settings decrease latency, but increase CPU load. The default setting of Medium is usually fine, but if you experience frequent System Overloads, then try setting it to Large.

--- If most of your System Overloads seem to be accompanied by peaks in the Audio meter in System Performance, then enabling Virtual Memory may help, especially if you load lots of EXS24 samples in a typical project. If the Disk I/O meter is peaking, then turning off Virtual Memory may be the better choice. Settings in the Virtual Memory window are global—they affect all instances of the EXS24 in all songs.

---You also might want to look in your audio folder and empty out any takes there. If you've been doing a lot of overdubbing or comping, Logic plays all those audio files in the background in case you might want to audition them on the fly.

---(This part is only if you are using Synful Orchestra) ....The danger of CPU overload is greater when Delay for Expression is OFF for a number of tracks. Generally we suggesting having DFE on for most tracks except actively recording on a track. This not only improves performance but also makes the music sound better!

--- (Im suspicious of this one)... delete logic preferences that are found at..... User>Library>Preferences>com.apple.logic.pro.cs AND ...User>Library>Preferences>com.apple.logic.pro.plist

--- It could very well be a problem with a ReWire plug-in (Reason, Melodyne, etc.) Navigate to Library > Application Support > Propellerhead Software > ReWire and delete files ending in “.plugin” that contain the word “ReWire”. If this doesn’t fix the problem, you may have to delete the other files in that folder as well.

--- (Here's one that's been working well for me that i discovered by accident-and it befuddles me that no one else has touched on it) If using an external drive to record to and the errors start popping up try moving the whole song project to your internal drive and (obviously ) writing to it from there.Then (when or if the errors start again) moving it all back over to the external drive. Ive found i can get away with some error free time with this method of jumping back and forth. Though it is a pain and makes absolutely no sense to me. maybe it has something to do with fragmentation (and as i write this i realize defragging hasn't been mentioned in any of those tips above, i don't know, that's all voodoo to me- maybe David or one of the other great moderators here can shed some light on that).

 

Alright N33MA... good luck!

Link to comment
Share on other sites

--- Ensure that Max Recording Time pref is set to 1 minute/5 minutes etc. (as required).... (i havent been able to figure this one out, maybe its talking about older versions of logic or something)

Older versions of Logic only.

--- Move the track that is higlighted ie select another one

Move from a software instrument track to an audio track will help.

 

Also, see this thread

http://www.logicprohelp.com/viewtopic.php?t=33527

Link to comment
Share on other sites

--- Set the input of EVERY AUDIO TRACK to "NO INPUT."

No lagerfeldt- not confirmed... and though this is taken out of context the point comes across-here's the persons whole paragraph, wish i could remember where from (probably somewhere in this forum). "I set the input of EVERY AUDIO TRACK to "NO INPUT." Of course, the hiss disappeared, but to my surprise, the one meter that seemed to be carrying the entire load went down to a normal level and my workload was basically evenly distributed among the 4 cores of my processor!!!! I tried this on a very complex project with the same results. I opened a project with 70 tracks, both audio and midi, with automation and effects. The one meter of the cpu was constantly spiking. I set all audio track inputs to "NO INPUT" and the problem was fixed! All 70 tracks running smoothly with all four cpu meters carrying an equal load and each only peaking at about 50 percent!!!!"

-Dont know if doing this is irresponsible on my part (selecting snippets of others findings on the subject and posting/compiling them), im just thinking every little bit might help somebody.

Link to comment
Share on other sites

With your Mac Pro, you should have all the processing power you need. I have taken a more minimalist approach to mixing lately, and the only 3rd party plugins I use are from IK Multimedia, FXpansion, and PSP. Occasionally, I will get overloads, but since switching to Logic's native plugins for a number of tasks, I have avoided overloads for the most part. The problem is in Logic's relationship with 3rd party plugins.
Link to comment
Share on other sites

yowch Eric that looks like an important point. Though, Ive been using a program called spotless that completely disables spotlight's indexing and have been using logic's software instruments without any hiccups for a while now. I'm confused on that one cause what your saying makes sense.

 

Here are two examples:

 

http://support.apple.com/kb/HT1039

 

http://support.apple.com/kb/TS1123

Link to comment
Share on other sites

My system overload was solved by upgrading to more RAM and increasing the buffer size. Get something like iStat for OSX and it well tell you how your RAM is doing and conveniently load it into your top bar so you can monitor your RAM/CPU usage. It seems that I usually use about 3.25GB of RAM out of my 4GB for my sample libraries. I could probably benefit from more.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...