Jump to content

Hyper Editor Question


anthonymunoz

Recommended Posts

I'm sure there is a simple answer to this, but I am way new to Logic. In the hyper editor I am building a drum beat. But as I layer the drums, the past drum parts vanish. I can still hear them, but I cant see them while recording. When I hit stop, all I can see are the most recent parts. If I hit play, all sounds normal, but nothing but the most recent hits show up.

 

Is there a setting I am not aware of?

 

Thanks,

Anthony

Link to comment
Share on other sites

Sounds like your regions are layering on top of one another. go to Settings>Recording and set Midi Overlapping Regions to "Merge with Selected Regions". Managing regions is something Logic takes a little effort to get used to.
Link to comment
Share on other sites

Cool. That helped. I have another question though. Again in the Hyper Editor:

 

If I need to add parts to a particular beat/region: I push play so that I can hear it in real time (it plays fine). When I push Record, all of my previous drums hits disappear, but they are still audible (I like to use those as a visual point of reference). If I do not add anything they never show up, until I push play (to disengage recording) and they show up again.

 

AND if I record any midi, the Hyper Editor remains blank (except for my new midi), until the region loops back to the beginning, which all midi new and old now shows. Kind of weird and annoying.

 

Is there a setting that will change this?

 

Thanks in advance. -Anthony

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...