Jump to content

Assign MIDI controllers


David Nahmani
 Share

Recommended Posts

David,

 

It has been a while since I have been to the site due to travel, but I wanted t say 'thank you' for solutions and patience that you have when dealing with Logic and the great user base out there. Is there anyway to be taught and get certified anywhere in the Maryland area? I know this is probably a super novice question, but I would like to have the best knowledge about Logic so that I can share it with others while improving MY sound.

 

Try this link http://training.apple.com/locations?q=Maryland&c=logic

Link to comment
Share on other sites

  • 2 weeks later...
This has been a great thread...

 

I'm still stuck however, trying to assign the transport controls (play, record, stop, etc) to my keyboard controller.

 

I can assign other parameters without an issue, but the "learning mode" doesn't seem to respond to the transport controls.

 

Help? Thanks!

 

I am having the same problems with a new Axiom 49 and logic 8.0.1. I cant get the transport controls to assign correctly. I see its picking up and reading the midi message but it is setting to something else. What do I need to put in for settings to assign the play, stop, record etc. correctly. Burnt a few hours on this already, thanks in advance.

Link to comment
Share on other sites

The transport assignments can be done in the key commands area (option + K). There is a button Learn New Assignments - this can be used for midi learn of transport controls. Your new transport mappings will show up in the controller mapping page after you set them up.
OSX.6.8 MacBook - 2.4 Ghz Intel Core 2Duo Logic Pro 9.1.6 / M-Audio Firewire Audiophile & Conectiv - Oxygen 8 - Trigger Finger - Uc33 - Novation Remote SL Compact - Korg PadKontrol, NI Audio 2DJ NI Audio 8DJ etc...
Link to comment
Share on other sites

BIG Thanks cynetmedia!!!! Successfuly reassigned them threw Key Commands. :D

 

No problem,

 

Anything in the key commands menu can be assigned to midi messages. Its actually quicker than messing about with the controller window. Glad it worked out for you!

C.

OSX.6.8 MacBook - 2.4 Ghz Intel Core 2Duo Logic Pro 9.1.6 / M-Audio Firewire Audiophile & Conectiv - Oxygen 8 - Trigger Finger - Uc33 - Novation Remote SL Compact - Korg PadKontrol, NI Audio 2DJ NI Audio 8DJ etc...
Link to comment
Share on other sites

  • 4 months later...

Hi

 

I have a midi guitar with up/down midi buttons and a midi volume control.

 

How can I assign the up/down buttons so that I can move backwards and forwards through a soft synth's presets? Take a synth such as Albino, if I click on its preset navigation arrows it doesn't appear as a controllable parameter. This is something I could do with Cubase but have not figured out how to do it with Logic.

 

 

Also how can I assign the midi volume on my guitar to function as a modulation wheel? Because the modulation wheel is something most soft synths don't seem to actually physically display and thus you can't click on it, and with a soft synth that does i.e. FM8 its the same problem as above which is if you click on it then it doesn't appear as a controllable parameter.

 

Thanks

Link to comment
Share on other sites

  • 4 weeks later...

Hi David,

 

Thanks for the info re midi controller assigning. I've followed your steps, but it seems that it learns the assignment as soon as I have touched the controller knob, rather than letting me go down to zero and then up to full range. The problem then is that the knob is not controlling from it's full range 0 to 127, rather for a tiny segment in the middle somewhere. So as I twist nothing happens, nothing happens, until suddenly the soft controller has jumped from zero to full.

 

Am I overlooking a menu option to do with sensitivity? How do I allow Logic to learn the full range of my midi controllers?

 

thanks in advance!

Link to comment
Share on other sites

Hi David,

 

Thanks for the info re midi controller assigning. I've followed your steps, but it seems that it learns the assignment as soon as I have touched the controller knob, rather than letting me go down to zero and then up to full range. The problem then is that the knob is not controlling from it's full range 0 to 127, rather for a tiny segment in the middle somewhere. So as I twist nothing happens, nothing happens, until suddenly the soft controller has jumped from zero to full.

 

Am I overlooking a menu option to do with sensitivity? How do I allow Logic to learn the full range of my midi controllers?

 

thanks in advance!

 

Even if it learns as soon as you touch, keep going and give it a full turn in either direction.

My new Logic Pro Book is out!

Link to comment
Share on other sites

hey, i apologise if this has allready been brought up but i did scan through the thread.

 

 

my problem is like this:

 

i go through and make all my assignments, and they all work beautifully. its brilliant.

 

and then all of a sudden, they're gone. they just vanish.

 

its happened twice now, and this is after doing about a hundred assignments. so it is really annoying that i have to put them all back in. i havnt exactly noticed when my controller assignments vanish, but it is definitely when ive started a new project, and i think only after i have turned my computer off and on again.

 

ive only experienced this problem since i got my presonus firepod the other day, which has a midi in and out on it, but im still using my midi controller (m-audio axiom 61) connected through usb. I dont know if the firepod is anything to do with this because i hadnt actually been through and made assignments before i got the firepod.

 

 

Sam

Logic Pro 9.1.2 | Leopard 10.5.8 | 09 Macbook Pro 2.4Ghz 4GB RAM |Presonus Studiolive 24.4.2 | Presonus Firestudio Mobile | M-Audio Axiom 61

Link to comment
Share on other sites

  • 3 weeks later...

I have searched through this thread and could not find what I am looking for.....

 

I am able to use Command -L to set controls for Logic's instruments and Effects, but I am not able to get it to work with Guitar Rig. The Control Window that pops up when you hit Command-L does say that it has mapped the controller to the knob I select, but nothing actually ever happens. While I love the Logic effects, I would also like to be able to control my NI stuff as well.

 

FYI....Guitar Rig recognizes the midi controller when it is in stand alone mode.....just not in Logic as a plug-in.

 

Any thoughts are appreciated.

 

Thank you!

Logic Pro 8 / Live 7 / iMac 2.4 3G RAM, MBP 2.4 4G RAM/ Korg M3 w/Radias & FW / MPK49 / Roland Juno 106 / Tascam FW-1884/ tons of other random guitars, drums, gear and software
Link to comment
Share on other sites

  • 2 weeks later...

Hi, the only problem I seem to be having is getting the main Output (or Master) fader to respond to a learned command. After using the Command L and clicking on the button for the master output fader, nothing happens even though it seem to acknowledge the assignment in the learn menu. It works fine for the individual track assignment, however. Also I don't see this assignment parameter in the key command menu, is there another name for it.

 

tx,

e

Logic Express 8.0 - Mac Pro 2x 2.66 GHz Quad-Core Intel Xeon - OS 10.4 - 7 GB RAM,
Link to comment
Share on other sites

miraculously before even getting a response, the master fader assignment began working. this forum rocks. actually, the only thing i did was open up the actual mixer, then the control started to respond. Seems a little buggy.
Logic Express 8.0 - Mac Pro 2x 2.66 GHz Quad-Core Intel Xeon - OS 10.4 - 7 GB RAM,
Link to comment
Share on other sites

  • 3 weeks later...

Ok so I got the faders working the way I want with ease after reading that thread which , now that I mention, am surprised I didn't find in the first place. Anyway I am almost there. What I am trying to do is setup a template that will speed up my work flow(like everybody else does I'm sure.) So, I have 26 tracks, 24 of which will contain audio and midi data. The axiom has buttons below the faders which I would like to set to move between two sets of 8 channels. My guess is that I would have to set each button as a key command to hide or switch between groups of channels. Am I right? If so how would I go about this?

 

Thanks again

Link to comment
Share on other sites

  • 1 month later...
I am able to use Command -L to set controls for Logic's instruments and Effects, but I am not able to get it to work with Guitar Rig.

 

I'm in a similar situation with Amplitube. The only solution I've found is to run the plugin as an "instrument" on an instrument track, and side chain it to your audio track. This is the only way I can get Amplitube to recognize midi information.

 

Anyone have a simpler way I'd LOVE to hear it, as I don't like having to load AU plugins on instrument tracks just to control them via midi CC's.

iMac Retina 2017 - OS 10.14.6 - Logic 10.5.1
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...
  • 1 month later...

Ok, in one track I have the trigger finger controling the filtesr of the strings, while I am playing the piano from another track.

 

The thing is that I can not change the string's filters while I have another track active. How do I lock the knob to that specific string while I am playing another sound in another track?

 

Thanx

Link to comment
Share on other sites

Ok, in one track I have the trigger finger controling the filtesr of the strings, while I am playing the piano from another track.

 

The thing is that I can not change the string's filters while I have another track active. How do I lock the knob to that specific string while I am playing another sound in another track?

 

Thanx

 

1) Select another track.

2) On the unselected track, assign the filter knobs.

 

Voilà!

My new Logic Pro Book is out!

Link to comment
Share on other sites

My dear super new friend... is not happening as you told me :s

 

I have track 1 with a sequenced string. I am using the EXS24 and I am assigning one of the knobs of the trigger finger to the cut off filter. As long I am on that track activated everything is fine.

 

On track 2 I have my piano controlled by my super Roland D-50.

 

You are telling me that if I am on track 2 activated and choose Learn on the EXS24 and move the knob and quit learn everything will be ok. BUT even the assigment have been take place the EXS24 is not responding unless I have that track activated what means... I can not play the piano neither :(

 

Thank you for your previous quick response!

 

 

1) Select another track.

2) On the unselected track, assign the filter knobs.

 

Voilà!

Link to comment
Share on other sites

David, I spoke to a friend of mine who is one of those mayor eminences in midi stuff (he was one of the ones creating the sound libraries for Roland back when the U and JV series).

 

Any way, he told me Logic 8 has loads of bugs and it seems this is one of them. He recomended me to go back to Logic 7 that was a more realiable versión.

 

Still, I know I have done what I want to achive before but is not happening now.

Link to comment
Share on other sites

It should work fine. I just tried it again, works fine here. I teach that stuff to dozen of students every month, so I can guarantee you it's working in 8.0.2. Try this: close your project, quit Logic, trash ~/Library/Preferences/com.apple.logic.pro.cs, restart Logic, open a brand new template, and make sure you can make it work there?

 

With the procedure I described, I can control my EXS24 cutoff with a remote knob whether or not its track is selected.

My new Logic Pro Book is out!

Link to comment
Share on other sites

  • 2 weeks later...

I looked for the answer to this question but was not able to find it.

 

Is it possible to make Controller Assignment settings for Insert Effect parameters only work when that Effect is selected or highlighted?

 

Perhaps if I explain what I am trying to do you might better understand. I have the parameters for all of my virtual instruments assigned in my template project (and a back up of the preferences file) There is never a conflict in controller assignments with instruments because you can only have one per track.

 

Whereas you can have multiple effects on one track. I would like to be able to make controller assignments for all of the effects parameters for all of the Logic effects as part of my template project, so that I do not have to make all of the necessary assignments ever time I want to tweak them.

 

In Learn Mode, Class is automatically set to Channel Strip and Channel Strip is set to Selected Track. Is there a way to make it where only the selected effect will respond to the corresponding controller assignments? Or is there another way to do what I am trying to accomplish?

 

Any thoughts would be greatly appreciated. :D

Logic Pro 8 / Live 7 / iMac 2.4 3G RAM, MBP 2.4 4G RAM/ Korg M3 w/Radias & FW / MPK49 / Roland Juno 106 / Tascam FW-1884/ tons of other random guitars, drums, gear and software
Link to comment
Share on other sites

Hello, I am wondering if there is a way to actually disable logics pickup of midi control messages for channel strips? I have no interest in controlling channel strip functions, pan, volume ect.....and it is always picking up whatever midi controller I am using when that channel is selected.

 

I know you can go into midi filter and select control changes, but then that bypasses using controllers in general I believe

 

if not I can reprogram my control surfaces with new midi cc's that dont conflict I guess, but I am guessing I am just missing something...and I apologize if it was in this thread and I missed it.

 

thanks, lots of good info here, it actually solved quite a few issues I was having and wondering about

 

cheers!

 

-patrick

Link to comment
Share on other sites

  • 1 month later...
It should work fine. I just tried it again, works fine here. I teach that stuff to dozen of students every month, so I can guarantee you it's working in 8.0.2. Try this: close your project, quit Logic, trash ~/Library/Preferences/com.apple.logic.pro.cs, restart Logic, open a brand new template, and make sure you can make it work there?

 

With the procedure I described, I can control my EXS24 cutoff with a remote knob whether or not its track is selected.

 

My friend... several months later and I did what you said and nothing. Logic does not keep the assigment once I change tracks. Once I am back to the original instrument it works fine but as soon as I leave to another instrument... nothing.

Link to comment
Share on other sites

My friend... several months later and I did what you said and nothing. Logic does not keep the assigment once I change tracks. Once I am back to the original instrument it works fine but as soon as I leave to another instrument... nothing.

 

Another instrument? Hmmm... what exactly are you assigning? If you select a track, and assign a knob to a parameter of a plug-in in a slot, then select another track that has exactly the same parameter of the same plug-in in the same slot on the same channel strip type (instrument if the first one was an instrument, audio if the first one was an audio track, etc...), then it works fine.

 

If ONE of those conditions is not respected, then it won't work.

 

My guess is you have one of those conditions that is not respected.

My new Logic Pro Book is out!

Link to comment
Share on other sites

  • 5 months later...
Both Logic Pro 7 & 8 make it very easy to use your MIDI controller's wheels and knobs to control mixer and plug-in parameters. Here's how to assign knobs to parameters:

 

1• Press Command+L*
(L as in Learn) - The Controller Assignment window opens. Move that window out of the way (just leave it open, but don't even worry about what's in that window).

2• In Logic, click the fader or knob you want to control.

3• On your MIDI controller, move the knob you want to assign to that control.
(for the best results, move the knob down to zero, then from zero to max and back down to zero).

(you can repeat steps 2 and 3 for as many knobs as you want)

4• Close the Controller Assignment window

 

You're done.

 

* If Command+L is not assigned you can assign it (or any other key combination) yourself in your key command window ( Logic Pro > Preferences... > Key Commands...): search for the key command "Learn new Controller Assignment".

 

Be sure to click directly on the fader control for Volume assignments, not just the channel strip.

Edited by ckbarlow

Logic Pro 10.6.1

MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports) – 2.3 GHz Intel Core i5, 16GB RAM

Catalina (10.15.7)

iPad Mini ~fall 2013

iConnectivity iConnectAUDIO4+; UAD Satellite Duo

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...