Jump to content

I need help over this audio latency thing!!!


Recommended Posts

I went step by step and i got to a point where I just simply got stuck. Ill write comments next to the steps.

The thing is...This audio recording latency thing happens to me every once in a while. Yesterday I was recording vocals and it was real noticeable.

What am I doing wrong


To quote SKI:




Anyway, here we go!





STEP 0 -- very important!


• Turn software monitoring off

• Turn the metronome off

• Set the recording delay value to zero

• Set PDC off

• Make sure you have no plugins anywhere.




1. Arrange Window, Track 1, assigned to Channel 1 -- import a CD track or use any stereo track of your own, preferably something with sharp transients at the top, like drums or percussion. I'm going to refer to this track as "X". Align it to start at bar 2.




2. Arrange Window, Track 2, assigned to Channel 2 -- set this channel to record from INPUTS 1/2. This is the track you're going to record your looped-back audio on.



3. Make sure the fader levels for both channels (tracks 1 and 2) are set to 0 dB and that both of their outputs are set to OUTPUTS 1/2



4. Use patch cables to connect outputs 1&2 of your audio interface to inputs 1/2 of the interface


Although when i turn up the chanel gains on my soundcard I get a digital kind of fizz. What am I doing wrong?


5. Start playback at bar 1 and go into record a little before bar 2 (punch on the fly works well for this). This recording -- the "loopback recording" is going to be called "Y". You only need to record about 10 seconds of material max.



6. Take track 2 out of record and insert the Logic > Helper > Gain plug on this channel. Set the L & R channels to be out of phase.

Helper is Utility, right?


What's going to happen next: you're going to play back both "X" (the original) and "Y" (the loopback recording of "X"). Because of the settings on the gain plug, Y is now out of phase with respect to X. If Logic recorded a perfect copy of X (i.e., the timing of Y is identical to X) then playback at this point would result in silence. Yes, silence! That's because if you playback two exact copies of an audio file and put one of them out of phase, they will cancel each other out.


But chances are that X won't be aligned with Y due to the latency inherent in your audio interface and its driver software. You'll likely hear flamming (slapback echo), or a thin, flanger-like sound. This is a clear indication that your recording delay setting needs to be adjusted.


NOTE: the proper recording delay setting for some systems is indeed ZERO. So if at this point you do actually hear silence, you can conclude the test. If you don't hear silence, continue to the next step...



7. Reduce the level of output 1&2 by 6 dB (this is to prevent clipping at the output in case your tracks are loud)


8. Open "Y" in the sample editor. Zoom ALLLLLLLLLLL the way in to the anchor point as far as you can go. Set the sample editor's "view" to "samples".


9. Click/hold on the anchor point, being careful not to move it. You will now see two numbers in the upper left hand corner of the window. Write down the bottom number.

I click, I hold and i see no numbers?

At least no top and bottom numbers.

This is as far as Ive gone.


What am I doing wrong?

Link to comment
Share on other sites

ok I think I got it.

I counted the samples from the anchor to the very begining of the beat. I zoomed in heavily and found ere the wave crosses the axis 4 the first time. I used it as a measuring point. Then , by trial and error I, adjusted the recording delay.

Mine is set at -46

I am using a Focusrite Saffire SCard.

I managed to get the loopback recording to the same sample distance from the anchor as the original. I hope I did it right. I just kept adjusting the recording delay till the sample distance from the anchor of the both recordings were exactly the same.

Makes sense?

Link to comment
Share on other sites

Did you upgrade to LP9?
(ahem... hint, hint, hint!!! )



Well NOTHING on this earth should drive you mad except these two...




[original image removed by moderator]


Otherwise you will need aspirins...





Give it some thought....



Link to comment
Share on other sites

theonly thing is the beat doesnt cancel out....Its quiet alright but no silence.


In many cases you won't get perfect cancellation. As long as things are in phase, you'll be okay. What I used to do before Logic 9.0.1 was to use airwindows Sample Delay. Put that on track Y, and on playback adjust the samples. It even has a phase flip built in. You can hear in realtime what is the best delay for best cancellation. I also used Atificial Audio Latency Detector. It is sample accurate and very reliable.


Good luck!

Link to comment
Share on other sites

I dont get it!

I adjusted it. Then I poened up a project i am working on and its still late. How can it work in one project and in the next one its as if it makes no difference.

I even went to the extreme and just put in -5000 samples and it was still falling behind. I mean u can just tell the vocals are off with the beat. What the hell is happening?!?!?!?!

Link to comment
Share on other sites

Why is the recording sample delay different for every project I open?

I cannot seem to fin a logical explanation.


The answer is probably the interface you're using. For example, it's well known that firewire audio, (and video interfaces like a Canopus) have unstable timing if they are using the native drivers built into Mac OSX. If I recall correctly, that's the case with the Safire units which don't have proprietary drivers but use the native ones.

Link to comment
Share on other sites

so what should I do?

what are "native drivers"?


Try out a different interface and see if it improves. I'd recommend RME or Metric Halo.


Native drivers are the hardware drivers that come with OSX. It's easier and cheaper to build audio and video hardware that uses those drivers, as the developer doesn't have to maintain their own, but there's a sacrifice made in performance.

Link to comment
Share on other sites

  • 2 weeks later...

I wrote to Focusrite about the problems I am having and this is one of the replies.



"Hi Adam


Thanks for your email.


Connecting the power supply and disconnecting all other peripherals gives the Saffire the best possible chance of updating properly. It would be worth trying the firmware update after you have installed the latest software from our website (http://www.focusrite.com/support/software/saffire/).


Please can you open up Logic, and go to Preferences>Audio>Devices>Core Audio. If you disable software monitoring and instead monitor your audio inputs through the SaffireControl software (press the TRACK button in SaffireControl as a quick way to set this up), do you still get delays recorded?


Please can you also go to Logic Preferences>Initialise All Except Key Commands in case there is a funny setting in Logic somewhere.


Please can you go to Applications>Utilities>Audio MIDI Setup and select the Saffire in the "Properties For" drop-down menu. What is listed as the unit's clock source?


Best regards


Andy Poole




Whaddaya think?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...