Jump to content

Clicking noise before region (AU plug-in related bug ?)


Recommended Posts


I am new here and also a new Logic user, sorry if this is not a new question- I have read many pages and used search...still no answer so I decided to ask more experienced users to help:

My setup is Macbook Pro 2,93 ,RME Fireface 400, Snow Leopard, Logic 9.0.1, T-Racks 3 Deluxe

Fresh system, all updates made,newest drivers for RME installed, disk checked and permissions repaired after all installs.

When I insert T-rack plug ( or in fact any other CPU intensive non-logic plugin) and play the track just before the audio region ( a second before playhead touches it) a loud clicking sound ( and sometimes even a small fragment of the region) is heard . It is also there when I bounce ( in the bounce file)

I tried to check all setup- everything looks fine to me.... please help- this bug makes Logic completely unusuable for me and I don't want to go back to Cubase :(

Hope there is an answer....

Some more info:

the disturbing sound is sometimes loud, sometimes soft, sometimes even not there, but if I play repeatedly from say 3 seconds before the region start it is very often there. I observed one more thing looking at the CPU meter: when I start playback and logic plays the silence before the region processor meter is idle and then just a second before the audio region CPU starts working and the click is exactly THERE . It does not happen in other programs on the same machine and it does NOT happen with Logic onboard plugs( there is silence when CPU starts working) but ONLY AU plug-ins. Hope it heps to solve the problem. Anyone else has this? PLEASE HELP

Link to comment
Share on other sites

Try putting an empty region at the beginning of the offending track.


Unfortunately this does not help :( the click is still there. Must be something wrong with Logic handling AU plugins and it is not only on my computer- a friend checked it and reported same problem on iMac/Leopard :(

But still I hope there is a work-around or maybe even a setting that I could change. I experimented with different buffers and settings- still clicking. No way to use my favourite plugins :(

Anyone else experiencing this? And is there anyone who's AU plugs work with L9? Please put 3 or 4 CPU heavy plugs ( even apple AU plugs) on audio track and play 4 seconds before the audio region several times and you will see what I am talking about :(

Thanks for your time and hope that there is a way...

Link to comment
Share on other sites

It's an oldstanding bug in Logic, which seemingly involves Logic not properly telling third party AU plugins to flush their audio buffers. There's a lot of blame-shifting and finger-pointing going on between Apple and plugin developers, but the fact is that it happens on Logic only.


During production it's just highly annoying, but when doing recordings/bounces it really gets in the way. I have found that to close the Project, re-open it and then Bounce immediately is a safe workaround for the time being.


Still, it's highly unprofessional for a version 9 of a software.



Link to comment
Share on other sites

There's a lot of blame-shifting and finger-pointing going on between Apple and plugin developers


the 'funny' part that it happens also when you use Apple AU plugins. APPLE are you reading this???


fuzzfilth & redlogic: thank you so much for the answers.... I will write to Apple and be a pain in their a** and if I get to know anything I will keep everyone interested informed. Please if you have any more info/update about this topic let me know,

thanks again,


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...