Jump to content

ReWiring Multiple Reason Instruments


Recommended Posts



I'm still trying to learn how to ReWire Reason 4 into Logic 8.


can't figure out how to work with multiple reason instruments. I set up 2 aux channels and two tracks in the arrange window. The aux channels are outed to R:Cha 3/4 (where I have an NNXT) and R:Cha 7/8 (where I have a Thor). Then I clicked on each track in the arrange window and assigned it to its appropriate instrument (NNXT and Thor). The thing is, when I play NN-XT, it plays both NN-XT and Thor!


Ok that's lame. But let's say I go back to Reason and connect a subtractor to 5, then I make a new aux channel in Logic routed to R:Cha 5 and a new track in the region, which I connect to Subtractor in the library. When I play that Subtractor in Logic, it plays the subtractor and thor. Basically, the only thing I can get to play alone is the newest instrument I made in Reason. It is very confusing because I think I have it set up correctly.


Again, each instrument is chosen in the track in the arrange window (NN-XT, Thor etc.) and the Aux tracks below in the mixer are set up for the appropriate channel in Reason.


When I play Thor, it plays just Thor but other than that, all my previous instruments play along with thor. I don't get it. Thank you very much your help is appreciated!

Link to comment
Share on other sites

One thing I just noticed is when I record it in the NN-XT track, I hear the NNXT and the Thor while I record it but when I play it back I just hear the the NNXT.


Still that isn't much help because when I record, I need to hear just the sound I'm playing, not everything layered on top of each other. I could solo each sound but that doesn't work because I record something and when I want to play a melody over the original melody, I can't hear the original melody since my new instrument is soloed. It is really frustrating.


Thanks again!

Link to comment
Share on other sites

ok this is the process i go through when i do this.


1. open logic then reason (rewire mode)

2. open external midi channel

3. then create instrument in reason

4. place all instruments in the hardware device in reason. being sure to skip 1 & 2

5. choose from the library in reason the instrument that i want.

6. creating an AUX channel strip for each individual Reason instrument with inputs according to what you put into the hardware device.

7. make music.


i'm guessing the problem might be your not making individual AUX strips for each instrument? and your just doing a L&R AUX channel?


if your offended my me suggesting this sorry. but sometimes it could be the smallest thing that we're doign wrong that drives us crazy and halts our production

Link to comment
Share on other sites

No of course I'm not offended, but I am making individual AUX strips for each instrument and I'm very carefully sending them to the channel that instrument is connected to in Reason.


The strange thing is, tonight, while following your steps, I could at least get 2 instruments to work. But then, when I added a 3rd, the 3rd instrument will play when I play either of the first two.


So instrument 1 works by itself, instrument 2 works by itself, then I add a 3rd instrument and suddenly when I play instrument 1 it plays instruments 1 & 3. When I play instrument 2 it plays instruments 2 & 3. When I play instrument 3 it just plays instrument 3.


I have no idea what I am doing wrong. Could it have anything to do with the "Ascending" check box that shows when I add a new AUX strip?


Thanks for your help I appreciate it!

Link to comment
Share on other sites

make sure your hardware device and your aux match up. make sure if your using an instrument that's mono in reason is also mono for aux stereo for stereo.


try to keep with devices as pairs.

and skip when 1 when its mono using the odd number.


not sure if this might make a difference.


make sure your not using LR for anything in Logic. or that its muted.


i ussually use L&R to test the sounds then i mute it and reconfigure the hardware device according to the instrument then the aux.


also a lil extra thing you might notice is when you right click the instrument in the mix it can route it to what you want it to be. be sure your not routing it to the AUX channel but to the reason instrument you want i believe its under devices. (strictly from memory).


let me know how it goes.

Link to comment
Share on other sites

when you use the auto assort feature it assigns the first (or last) to reason's aux out, which combines all channels. You need to make sure that 1/2 are not used. Or something like that. I found a nice youtube video that helped run me through it the first time I set it up. Anyway not sure if my info is 100% correct as I don't hav elogic running at the moment.
Link to comment
Share on other sites

Pardon me if you thought of this already, but it sounds like reason is still responding to your controller directly as its master keyboard, even though you are driving logic with it.


You can try either disabling your controller in the Reason preferences while you are rewired, or making sure Reason's "tempo" track is the selected device in your reason rack. (click on the keyboard in the tempo track) This will make sure your reason is not directing midi to any instruments.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...