Jump to content

Can you upgrade from Logic 6.4.3 to Logic 9?!


eebert

Recommended Posts

So I'm almost embarrassed admitting that I'm still running Logic 6.4.3 but hey if it aint broke don't fix it. Anyhow, I recently purchased the Logic 9 Pro upgrade as I was told it should work. I'm running Leopard 10.5 on an Imac and I installed everything accordingly, however, the Logic will not open. I keep getting a message telling that "Logic has unexpectedly quit. Would you like to relaunch?" I've relaunched and reset several times, but nothing is working. Is this due to the fact that you simply can't upgrade from Logic 6 to 9 or is this an OS problem?

 

Any advice would be much appreciated.

 

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...