Jump to content

Flex mode on then off - Follo Tempo stays on?


Mojave

Recommended Posts

Say you pick a region and turn on Flex mode. Then, you turn off flex mode. If you look in the region parameter section, you will see the "Follow Tempo" box is left checked on. That screws up the audio region and you have to be sure to go back and 'UN-CHECK" each region that had a flex mode turned on. Is it possible to set the Region Parameter so that this Follow Tempo box will stay un-checked after you switch off flex mode? It's slightly annoying to simply turn on flex for a visual analysis then after turning it off especially if you hold shift and choose Flex mode since that will enable all the track to go int flex., your playback is goofed and you have to go shut things off you didn't want turned on in the first place.
Link to comment
Share on other sites

Yes, I have noticed the same thing. It can be reproduced like this:

 

1. Record a new audio region into arrange (a couple of secs of silence is enough) to make sure follow tempo is check-able

 

2. Enable any of the Flex modes for the track

 

3. Disable Flex for the track

 

And there you go, follow tempo is selected for the region. What bugs (heh) me a little is that at least in previous versions of Logic, checking follow tempo seemed to mean that Logic loads individual pieces of the audio file into memory, consuming lots of it. I don't know if that still is the case (previously, there was a brief "loading blabla into memory" or similar after checking follow tempo, not any more I think), but since we are already struggling with Logic running out of mem all the time, it's at least a little suspicious... :?

Link to comment
Share on other sites

You're right, I can reproduce now. I was working with imported tracks from an earlier Logic 8 project, and didn't get that behavior when I first tried.

 

What bugs (heh) me a little is that at least in previous versions of Logic, checking follow tempo seemed to mean that Logic loads individual pieces of the audio file into memory, consuming lots of it. I don't know if that still is the case (previously, there was a brief "loading blabla into memory" or similar after checking follow tempo, not any more I think), but since we are already struggling with Logic running out of mem all the time, it's at least a little suspicious... :?

 

Flex, Apple Loops & Follow Tempo all load the audio files in RAM.

Link to comment
Share on other sites

Simply put, I took an arrangement done in L8, Completed and working fine. Activated Flex on either a single or while holding shift, , multiple trax at the same time. Turn off flex on these very same trax and you will find on the region parameter, the follow tempo box remains checked. Where is this command designated? Or better yet, Is this a preference setting that can be turned on or off?
Link to comment
Share on other sites

, Apple Loops & Follow Tempo all load the audio files in RAM.

 

Funny you should say that, my project does have some apple loops in it. Would that cause the "Follow Tempo" box to auto activate on an audio region after using the Flex feature on that region? Are they somehow tied etc?

Link to comment
Share on other sites

No, there's no preference for it, you'll just have to turn it off manually. You can click the track header to select all the regions on that track and turn follow tempo off for all of them at once.

 

Ok, understood. Looking forward tot he book and CD in November. You must be a genius to know this stuff so well you can write a book about it. Did the Government try and recruit you for a think tank at one time?

Link to comment
Share on other sites

Funny you should say that, my project does have some apple loops in it. Would that cause the "Follow Tempo" box to auto activate on an audio region after using the Flex feature on that region? Are they somehow tied etc?

 

They use the same technology, yes. Except gives you more algorithms to play with. The "Rhythmic" one is the one used for Apple Loops. All the other ones are new to Logic 9.

 

You must be a genius to know this stuff so well you can write a book about it. Did the Government try and recruit you for a think tank at one time?

 

I can't say anything about it. My lips are tied. You know how the government is. :mrgreen:

Link to comment
Share on other sites

Flex, Apple Loops & Follow Tempo all load the audio files in RAM.

Hm, you sure about that? I just added a 600MB audio file into Logic, enabled Flex, let Logic analyze the file, then stretched the region a little to make sure some flexing was happening. During this, Logic's memory consumption grew about 10MB, no more.

 

I then tried Follow Tempo with the same file. As soon as I checked the option, changed the project's tempo a little and hit play, Logic's memory footprint jumped up about the same amount as the size of the file.

 

To me it seems Follow Tempo indeed loads everything into RAM (when it really needs to, for example if the project tempo changes), but Flex does not. If it did, I would be in even bigger trouble with memory than I am now, I have used so much Flexing in my large projects... :?

Link to comment
Share on other sites

To me it seems Follow Tempo indeed loads everything into RAM (when it really needs to, for example if the project tempo changes), but Flex does not.

 

I suppose Flex only loads into RAM what it needs to time-stretch, not the whole audio file - I have not run any tests. For a fair comparison, turn on Flex (not the Slicing mode), then change the project tempo. You should get the same results as with Follow Tempo?

Link to comment
Share on other sites

I suppose Flex only loads into RAM what it needs to time-stretch, not the whole audio file? For a fair comparison, turn on Flex, then change the project tempo. You should get the same results as with Follow Tempo. Just a guess.

Did that, didn't consume any more memory. Whatever stretching I do with the file, it doesn't seem to affect the memory it takes. It's actually strange why Follow Tempo does load everything into memory... at least I can't think of any good reasons for that. (Except that it was easier to code while working on more advanced Flex features, or something. :))

Edited by Captain
Link to comment
Share on other sites

Hi

 

I confirm that Follow Tempo only loads the audio into RAM if the tempo is changed.(Tested with 12 stereo 24bit 44.1k files 10 mins long.... ran into the 4GB limit and Logic crashed).

 

Also

 

Flex mode does NOT load the audio files into RAM, even with tempo change, and Flex timestretch along with some Flexing of all regions.

 

 

HTH

 

 

CCT

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...