Jump to content

MIDI track/channel question


gtomassetti

Recommended Posts

Hi:

 

I'm quite new to Logic, and I'm pretty confused about something.

 

I have several multi-timbral software instruments — sample players, specifically. If I create an instrument track using, say, Kontakt 4, and drop a sound into it on MIDI channel 1, everything is fine. And then, if I add more sounds to Kontakt, they automatically set themselves for channels 2, 3, etc. If I tell Logic "New track with next MIDI channel," everything works perfectly.

 

But, using this method, I can't set the instrument faders in Logic's Mixer to different levels. Changing the fader for one instrument changes the faders for all.

 

I've found that if I do command-D, and get a new track with duplicate settings, I CAN change the fader levels independently. I figured, great, I'll just do that and change the MIDI channels on each subsequent track.

 

But, then I can't get Logic to communicate with the sample player on anything other than channel 1. This happens in Kontakt, SampleTank, MachFive, you name it.

 

I realize that a way around this would be just to instantiate a new instrument on every track, but that seems like it would be so unnecessary — why have a multi-timbral sample player then?

 

So I'm wondering if anyone can tell me how to use the "new track with next MIDI channel" method while still having individual control over the faders, OR, how to use the "new track with duplicate settings" method, and change the MIDI channel and have Logic communicate with the sample player on several different channels.

 

Any help will be greatly appreciated.

 

Thanks,

 

Gary

Edited by gtomassetti
Link to comment
Share on other sites

First, try renaming your post from, "Probably a dumb MIDI question" to something that relates to its content snd you will have a much better chance of receiving meaningful responses from people who use multi-timbral instruments in Logic. Please refer to: Read Me before posting - Forum Guidelines (#2).

 

Just click the edit button in your post and you can freely rename it.

 

When you create an instrument track in Logic, an instrument audio channel strip is automatically created for you in the mixer. The track and the channel strip are not the same thing, they're just associated. The channel strip fader represents the Main audio out from that audio channel. It is not intended to control the MIDI volume of any instrument plug-in you place on that channel.

 

It's different for various plug-ins, so you need to be specific about what you're using, but in the case of Kontakt you need to manually assign a MIDI controller in Kontakt's MIDI Automation tab to control that instruments volume within the multi. Normally that's going to be CC11, expression. Don't assign CC7 or CC10 to anything in Kontakt. Logic hijacks these two controllers for setting volume and pan of the channel strip itself. This means a plug-in on the channelstrip will never see these two controllers.

 

So, if you have a 5 instrument multi in Kontakt, MIDI ch's 1-5, when you create "New Track with Next MIDI Channel", sequencing Expression on each of those tracks will control the level of each instrument in the multi.

 

Alternatively, you can load Kontakt as a multi-out and create the additional aux channelstrips in Logic's mixer to handle those instruments in the multi. Create tracks for those aux channels and you can automate their level in the Arrange. What you choose to do depends on what method works best for your workflow.

Link to comment
Share on other sites

OK, that's helpful. Thanks.

 

Now, can anyone explain why, when I do command-D to get a new track with duplicate settings, and then change the MIDI channel on the new track, I can't get Logic to communicate with the sample player on anything other than channel 1?

 

If I do the new track with next MIDI channel thing, it works perfectly in all my sample players. I can have as many as 16 instruments in a single instantiation of the sample player, and Logic communicates with them all flawlessly.

 

But with the command-D method, it doesn't matter if it's Kontakt, or SampleTank, or MachFive. I can have several instruments in the sample player, each set for its own channel. They all work when I click on the keyboard of the sample player. But it seems that Logic will only send information to the sample player on channel 1. I can even set an instrument to omni, and it still won't matter. Only the first instrument in the sample player gets MIDI from Logic. On any other channel, the instrument's MIDI indicator doesn't light up at all.

 

I suppose it doesn't matter, but I just wonder why it doesn't work? Am I missing something really obvious?

Link to comment
Share on other sites

But with the command-D method, it doesn't matter if it's Kontakt, or SampleTank, or MachFive. I can have several instruments in the sample player, each set for its own channel. They all work when I click on the keyboard of the sample player. But it seems that Logic will only send information to the sample player on channel 1.

Command-D, New with duplicate setting, will simply create a new channel and instrument instance exactly like the presently selected track. So if the selected track had channel 1 active then that's what you get. Check the track parameters in the Inspector to be sure. Then create new tracks with next MIDI channel to get further tracks for the new instrument.

Link to comment
Share on other sites

Command-D, New with duplicate setting, will simply create a new channel and instrument instance exactly like the presently selected track.

 

I'm sorry, but I'm really not understanding this at all. I see what you're saying, but when I just tried it, using command–D from the first track, set to channel 1, and then creating a new track with next MIDI channel from the second track, that new track, set to channel 2, still isn't communicating with the instrument. I added a screenshot of how things look, and it appears that everything is correct, but I guess that if I want to use multi-timbral instruments, I'm going to have to use the option-command–M method.

 

But I just don't see why, once I've created a track with duplicate settings, I can't change the MIDI channel of the new track in the Inspector. Or more accurately, I can change the MIDI channel in the Inspector, but it doesn't reach the instrument assigned to that channel.

 

[image deleted by moderator: too big]

Link to comment
Share on other sites

Hi

 

 

I agree with Fader8, this is not the best way forwards, but

 

 

 

Select Inst track 1

 

Cmd D (create new track with duplicate settings)

 

Select this new track, and in the Track Parameters box, change the MIDI channel from ALL to 1.

 

Create new track with next MIDI Channel (this is set to channel 2)

 

 

Works fine here using Kontakt 4 & Logic 9.0.2

 

 

Note that, by default, new Instrument tracks are set to MIDI ALL, and creating a track with next MIDI channel creates a track set to MIDI channel 1.

 

 

 

CCT

Link to comment
Share on other sites

I know I sound like a complete idiot here, but I simply can't get this to work.

 

I thought that maybe it was because my first instrument track was already set to 1 instead of All, though it doesn't seem like that should make a difference.

 

But even when following the steps you outlined, the only track that will sound is the original one. I opened a new document, created 1 instrument track with Kontakt 4 (and I'm also on Logic 9.0.2), and loaded an instrument.

 

I selected the track, hit cmd-D, changed the channel from All to 1.

 

I then hit option–cmd-M for the new track with next MIDI channel.

 

But still, the only instrument in Kontakt that shows any MIDI input is the first one. I can select any other track and play on my keyboard, but the only sound is coming from the first instrument. If I mute that one, I hear nothing at all. If I select any track other than the first one, the instrument associated with that track does not get any MIDI information from Logic, even though the track parameters box and the instrument in Kontakt are set to the same channel.

 

It just doesn't make any sense to me.

Link to comment
Share on other sites

Well, then I'm obviously doing something wrong, because even setting the tracks up to match up with your screenshot, I STILL can't get any MIDI information into Kontakt on any channel other than 1.

 

No problem deleting my screenshot.

 

If you feel like it, you can give me a step-by-step method of how you got it to work, because I sure can't figure it out.

 

Thanks for trying to help me, anyway…

Link to comment
Share on other sites

Well, then I'm obviously doing something wrong, because even setting the tracks up to match up with your screenshot, I STILL can't get any MIDI information into Kontakt on any channel other than 1.

 

No problem deleting my screenshot.

 

If you feel like it, you can give me a step-by-step method of how you got it to work, because I sure can't figure it out.

 

Thanks for trying to help me, anyway…

 

Could it be your midi input keyboard is transmitting ch 1,so that's what the problem is?

ie: you need to change the ch in the event list or on the keyboard if you're playing it in 'live'.

 

Just a thunk.

Link to comment
Share on other sites

OK, my exact workflow with Logic 8.0.2, Kontakt 3.5.0.025

 

File, New, Empty Project.

 

New Track dialog, Software Instrument, leave multi-timbral unchecked.

 

Insert Kontakt, drag 2 instruments in to populate the multi. They'll adopt MIDI ch 1&2.

 

The track parameter still has MIDI ch "All" so change that to 1.

 

Opt-Cmd-M for track with next MIDI channel. This new track is channel 2, work fine.

 

With either track selected, Cmd-D to create a new Instrument channel strip with the same settings. Change this track parameter to channel 1 if it isn't already.

 

Again, Opt-Cmd-M for track with next MIDI channel. This new track is channel 2, I play my keyboard and the channel 2 instrument in the Kontakt multi plays.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...