Jump to content

Broken in Logic 9?: Reindex loops from external drive


Recommended Posts

Adding loops from an external drive in Logic 9 does not seem to work any longer. It used to work great in L8. Anyone have similar experiences? Know any work arounds? Is it a bug? If it's a bug I'll file it with Apple.


Previously in Logic 8 it was easy to reindex loops on an external drive:

(1) Delete the loop indexes from root/Library/Audio/Apple Loops Index

(2) Use Finder to locate the loops on the external

(3) Drag the loop folders into the L8 media browser.

(4) L8 asks if you want to copy the loops or use them from their present location. Select present location intsead of copy locally.

(5) L8 takes 5-20 minutes to build index of loops from external drive


I have tried this procedure several times in L9 without success. Instead I get the following:

(1) Delete the loop indexes from root/Library/Audio/Apple Loops

(2) Use Finder to locate the loops on the external

(3) Drag the loop folders into the L8 media browser.

(4) L9 ask for my admin password.

(5) Enter my password

(6) I'm NOT asked if I want to copy loops locally or use them in their present location. Instead a reindex progress dialog comes up for 2 seconds then goes away.

(7) In the end nothing happened. No loops copied, indexed, or anything


There is only one way I managed to get loops into L9 but it is exactly what I'm NOT looking for:

(1) In the folder with all my loops spotlight search ".CAF" (In this case want to reindex Apple content which is all CAF)

(2) Make sure to click "show more" at the bottom of the search results.

(3) Drag the search results to the loop browser.

(4) L9 indexes them all right, AND also copies them to my user library! All 30 GBs worth. Definitely not what I want.


In the end, I had to reinstall the Loops from the DVDs and specify an external location for them. (This whole mess got started when I tried to move the GarageBand and iLife loops to an external drive. The installer does not let you specify a location for them.)


Just so you know I've done some homework:

I've scoured other Logic forums and found these relevant threads that in the end did not solve the issue. They mostly seem to refer to Logic 8 which does not have this issue.



Thread 1


@ Logic Pro Help

Thread 1

Thread 2

Thread 3 this fellow seems to have a similar problem as I. He drags folders into the loop browser but nothing happens.


@ Apple Discussions

Thread 1

Thread 2

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...