Jump to content

Logic Pro 8, distorted sound & delay [SOLVED]

Uno Lady

Recommended Posts



I would greatly appreciate some assistance. Any audio track I record in Logic Pro 9 is distorted and delayed.


I own a 1.67 Power PC G4 (1.5). I recently upgraded to Mac OS X 10.5.8, and Logic Pro 8.0.2. I have a Blue Snowball USB mic. 99% of my recordings are Accapella.


It was originally an OS X 10.4.1 w/ Logic Pro 7, academic version (usb key).

It did not have the same problems but would occasionally show the message "core audio, system overload."


A few months ago someone installed a new hard drive and upgraded my operating system. ( my computer was FULL) After that my logic recorded things distorted & delayed, sometimes sounding robotic. My cd drive also broke. The person assisted me at no cost, and wants to continue to try and fix it.


All additional upgrades were made in an attempt to fix the problem in Logic (i.e. maybe old Logic is not pals with OS X 10.5, lets introduce Logic 8).


Anyways. I wish I knew what to do, but I don't. Should buy an external sound card (Something I honestly know nothing about or what kind to buy).

Is my program/computer$&@+%? Like many musicians I am broke.


I have gotten by with knowing just enough for the past 3 years and now I need your digital musical genius help.


The person who helped me out has the "finger print" of my old hard drive stashed away. Should I try going back to the way it was?

Attached is an MP3 of the sound problem.


Thanks for your time. I tried to put what I thought was useful but if you need more info, please feel free to ask.


Warmest regards,

Christa, the Uno Lady

Link to comment
Share on other sites

Could be a problem with the mic and/or USB connection. Check if you have the latest driver for that mic and for your operating system version.

How do you listen back to your music? Headphones?


Eventually you want to consider an interface.


Could also be that the computer is not up to snuff anymore. Logic 8 and Leopard are more taxing for a G4 than Tiger and L7

Link to comment
Share on other sites

Thank you for your reply. I know it is not my mic or USB connection because it works on another computer (not my own).


Do you have any suggestions of what interface to buy, is this something internal or external? Is this something that could be purchased for around $200? My computer guy is really nice but also the reason why it is not working.

I'd like to have all the parts ready for him to undo the problem, or for someone else to undo the problem. I think I will have him downgrade it back to Tiger as well.


Thanks again though. I really appreciate your advice.

Warmest regards,


Link to comment
Share on other sites

If you're not recording more than 2 tracks simultaneously, you can get a USB interface.

You can try a Presonus Audiobox.

I consulted with another person about that noise and he said that's typical when the I/O buffer is too low, and raising the buffer in Logic's Audio preferences would increase the latency. The other thing he said is that the computer might be too slow already.


I suspect your G4 is a laptop, right?

Link to comment
Share on other sites

yup, laptop.


I only record one audio track at a time with the USB mic but I only record vocals. I was told that is taxing on my computer.



So the interface would help with the sound jumbles I currently get as long as I buy a regular mic as well. (I'm assuming I dont plug a USB mic into a USB interface.)


thank you!

Link to comment
Share on other sites

Throwing money at the problem will most probably not solve it. In my opinion the only good way to throw money at this problem would be to get a newer Mac computer.


Triplet hinted at the I/O buffer being the possible source of your problem - try this: in Logic, open Preferences > Audio and try to raise the I/O buffer size. Let us know?

Link to comment
Share on other sites

Wow, holy thank you.


I had the I/O buffer size turned up the the maximum (1024) BUT apparently overlooked the I/O Safety Buffer option. Clicked that and now it works alight.


There is still a slight delay (that does not change regardless of where I slide the recording delay) but at least the robot sound is gone.


Attached is a screen shot so if anyone else encounters this problem.

Thanks for your help.


Link to comment
Share on other sites

It broke again. 2 tracks in, it gave me a system overload message and turned into a robot. I'm going to have the person reset it to my old operating system and logic 7 (what I had before the problems). Thanks for your advice. I'll let you know if that works once it is done.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...