Jump to content

DirectLink Won't Detect Logic in Standard User Mode in OS X

Recommended Posts


I just received a 3rd gen Oxygen 25 a few days ago, and was attempting to set it up on my MacBook Pro so that the controller will work with Logic Pro.


My OS X version is 10.6.5. I have set up a standard user account that I use by default (no admin privileges), and it's the preferred location that I'd like to use Logic Pro (9.1.3) and DirectLink. In my admin account, when Logic appears after the keyboard is plugged in and detected for the first time, the Control Surface window automatically appears and the Oxygen keyboard is detected.


However, this is not the case in my user account. Though Audio-MIDI Setup in my user account does see the keyboard, for some reason Logic in the user account cannot find it. Even when I tried temporarily changing the user account to an admin one just long enough for Logic to find the keyboard, it still doesn't work.


My guess is that some permission issue in the user account is causing Logic not to detect the keyboard. I'd appreciate it if someone can offer a way around this, short of having to implore a separate admin account.


Thanks for reading; looking forward to your reply.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...