Jump to content

Logic 8 projects not playing properly in Logic 8 & 9


martinf

Recommended Posts

I use both an iMac (latest Leopard update, with 4 Gb RAM) and a Macbook Pro laptop (with the same spec) to make music with. I'm also using the latest versions of Logic 8 & 9. I have recently purchased a new external drive to store all my audio files, instrument files and samples. I had a 500Gb drive and have now replaced it with a 1Tb drive. Both drives are formatted Mac OS Extended. When I started to test to see if everything was working OK, I found what is to me, quite a big problem. I opened some old completed project files created in Logic 8 to see if there were any problems loading the instrument libraries. The project opened in Logic 9 and a message came up saying some of the instruments failed to load. I thought that was strange, as some of the instruments used were open but not all instances of it. There are about 6 or 7 guitar tracks with Guitar Rig 4 on inserts but only one instance loaded, the rest had a diagonal red line through the writing in the slot. I checked to make sure that Guitar rig was properly authorized which it was. Also only one instance of Addictive Drums was playing with another two with red diagonal lines. The same thing happened with Amplitube3, Amplitube Fender & PSP Vintage Warmer too, but I did notice that no native logic plugins were affected.

I closed the project without saving then launched Logic 8. From the file menu I opened the previous project but exactly the same thing occurred. I then opened another project from the same sessions and it was the same again. I haven't got any projects made in Logic 9, with multiple instances of 3rd party plug ins to test so I can't go along that route. I then tried to see if it would work from my Macbook Pro but it was again exactly the same.

I haven't tried to open any of my old Logic 8 projects for quite some time, and many plugin updates have been and gone, so I can't pinpoint where the problem could be. Does anyone know how this problem can be solved.

Link to comment
Share on other sites

Thanks Jordito, I've read the links and it seems I'm not the only one with this problem. In my case it's not just Native Instruments plug ins affected either. I think you are right when you say it is related to upgrading Logic or the OS.
Link to comment
Share on other sites

I have Snow leopard running on another external hard drive. If I open my Logic 8 projects on the Snow Leopard system everything loads fine. Even if I run them from Logic 9 they load fine. Must be a problem with Leopard and updated software. I wonder if I save my projects in Snow Leopard and then boot back into Leopard, will the projects open OK this time. When I get some time I might give it a go. I'm just glad I can get them working, even if it is only in Snow Leopard. I'm still predominantly using Leopard and not quite ready to make the jump to Snow leopard.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...