Jump to content

MIDI keeps resetting presets


JoceyMusic
 Share

Recommended Posts

Hey everyone. Just joined this forum, and going to introduce myself in just a few hours, just need to ask this quick question, I've tried to use the search function but hasn't been able to find any appropriate answer on the pages I've been scrolling trough.

 

Whatsoever, I am going to do a remix of a track, and I imported the MIDI needed. But, whenever i then apply a VST (Sylenth-1 In this case) it keeps going to back to the first preset of the sound-bank. Therefore, whenever i make choose another preset, and I push play, it goes back to the first preset of the sound bank chosen.

 

I hope somebody out there are able to help me, and thanks for letting me join this forum. And i apologize if this question has already been solved for some, but I haven't been able to locate it.

 

I hope I'd get some good times in here, and meet some nice friends, all using Logic:)

 

Thanks in advance.

 

- Jocey

Link to comment
Share on other sites

it sounds like there is a program change in the MIDI data

 

select the MIDI region in the Arrange and hit "E" - this will open the Event List for the MIDI region.

 

check the Event List for an unwanted Program Change and delete it!

 

p.s. you may also have unwanted control data (volume?) in the list that you'd also want to delete. this data would interfere with Automation

Link to comment
Share on other sites

Thanks mate! I figured out the problem.

 

The reason the problem is, is that when you import MIDi it makes it on the Grand Piano. Therefor in the E section, it creates 5 programs, in which the presets are lying in. Just delete them, and it'll be fine once again! :)

 

Thanks a lot man! Helped me really much!

 

- Jocey

Link to comment
Share on other sites

  • 4 years later...
  • 2 years later...
Well Jakob, well said, but work smarter not harder, try to keep one element as you suggested the sustain see if it work for you, for me I have imported midi files with notes,sustain, and velocity it worked, the rest was chucked in the bin, it all depends who and where you import midi files, as some do put codes in the midi events to restrict or loop. its all about try and error buddy !
Link to comment
Share on other sites

  • 3 years later...
very Simple

 

if you have Midi assigned to a vst,

 

1- Open the midi file, go to events, un tick the Notes, and delete everything else in the midi file information, your vst will work and wont change back to default .

 

DJJITENUK

 

Hi there, new to Logic and having this same issue - trouble is I can't find HOW to 'untick the Notes and delete everyhing else' - anyone know a fix or able to recommend step by step key strokes? Thanks in advance..

Link to comment
Share on other sites

Hi there, new to Logic and having this same issue - trouble is I can't find HOW to 'untick the Notes and delete everyhing else' - anyone know a fix or able to recommend step by step key strokes? Thanks in advance..

Press D to open the Event List. Click the "Notes" button to deselect it. Press Command-A to select all and Delete to delete.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...