Jump to content

Samples not recognised when opening saved EXS Instrument


Ultrafonic

Recommended Posts

Whenever I create a new ESX instrument and save it, it doesn't recognise the samples when I open it again. I can see the samples listed when I go into the EDIT screen. I can see them all mapped to individual keys. But the instrument just plays the default EXS tones. It works fine the first time when I initally load the samples. The problem occurs when I save and then reopen.

 

I am no stranger to the EXS, I've been creating instruments for years. But this has started happening recently (possibly after an interim update of Logic, I am not sure).

 

Some more information

 

1. If I hover the cursor over one of the WAV samples in the edit screen, it shows me the location of the sample. I've checked and the path is correct.

 

2. In the "zone" tab, I've tried using the "update selected zone info from audio file". It doesn't work.

 

3. I've tried clicking on the individual samples and using the "load audio sample" and it does not work. It still plays the default EXS tone

 

4. Creating the EXS from scratch and then saving it in the project, by ticking the "copy EXS instruments to project folder" and "Copy EXS samples to project folder" doesn't work either.

 

And here's how I create my EXS instrument. I'm using it to create a soundbank of kicks, snares etc

 

1. Click on EDIT in the main EXS screen

2. Click Zone -> Load Multiple Samples

3. Select the samples I want

4. On the next screen, take the "Contiguous Zones" option

5. At this point, I can use the instrument fine.

6. Click Instrument -> Save As, and save to an EXS folder I've set up

 

Any help greatly appreciated.

 

Here's my specs.

 

Logic 9.1.3

Leopard OSX

Model Identifier: iMac7,1

Processor Name: Intel Core 2 Duo

Link to comment
Share on other sites

Thanks for the detailed description - it sounds very odd, especially since it works before you save it. This save destination, is it on an external disk? And how about other (prefab) EXS instruments? They load fine?

 

The first thing I would do is run disk utility and verify & repair disk and repair permissions, although I would expect an error message if it was a permissions problem.

Also, does it make a difference if you save your instrument to a different path or even a different disk?

It could also be a Spotlight issue, EXS uses the Spotlight index to locate samples. You can rebuild the Spotlight Index via the Privacy screen in the Spotlight system preference panel. Just drag your disk(s) to the privacy list, close the panel, reopen it and remove the disk(s) again by selecting them and clicking the "-" (minus) key. The reindexing will start 20-40 seconds after this, and will take 5 to 20 minutes per disk (roughly).

Link to comment
Share on other sites

Thanks very much for the advice. Unfortunately I tried all the things you suggested below, and I still have the same problem.

 

In answer to your other questions

1. My save location is my hard drive, not an external drive

2. I have tried saving the instrument in different paths, and I still have the same issue

 

I am at a complete loss... Any other ideas?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...