Jump to content

CPU Efficiency with Kontakt 3/4 in Mainstage


thinkofone

Recommended Posts

Using Kontakt 3 or 4 in Mainstage works fairly well, but they both seem to drain a lot of CPU unnecessarily. For instance, while playing an Ivory Grand patch that is 14GB, the CPU stays at a smooth 50-60%. Running the 1.5GB Scarbee Rhodes in Knotakt 4 keeps the CPU at 85-100%!

 

Anyone know why this could be? I've tried varying all the settings in Kontakt, but at best I still get the CPU in the red while playing most patches. Too bad so many newer libraries are Kontakt only.

Link to comment
Share on other sites

I just reverted back to the old Scarbee Vintage Keyboard Collection version of the Rhodes (which is essentially the same library as the newer Mark I) running in the EXS sampler. What a difference! The EXS is WAY less taxing on the CPU.

 

Still if anyone has any info on making Kontakt run smoother, please post.

 

Thanks.

Link to comment
Share on other sites

  • 2 weeks later...
I just reverted back to the old Scarbee Vintage Keyboard Collection version of the Rhodes (which is essentially the same library as the newer Mark I) running in the EXS sampler. What a difference! The EXS is WAY less taxing on the CPU.

 

Still if anyone has any info on making Kontakt run smoother, please post.

 

Thanks.

 

depends on how you have Kontakt setup as a plugin. I dont find it too bad. there are buffer sizes in Kontakt itself. Also I use an alias for Kontakt so if I have multiple patches with a different Kontakt sound it it is not loading dozens of Kontakts just the one instance

Link to comment
Share on other sites

  • 4 weeks later...
  • 3 months later...
Yes i have the exact same problem when running the vintage rhodes pack through Kontact.

Any help would be awesome~! :D

 

Hi, since my post I've done a lot of troubleshooting/tweaking and have made some progress. Here are some things you can try:

 

1: Click the tool icon and then under "Source" choose "Sampler" instead of "DFD" from the drop down menu. This will take more ram might be more efficient.

 

2: Click the preferences in Kontakt and under engine, turn "Multiprocessor support" to 2/4 cores (depending on your machine). You will have to restart you host. Switch it back if that makes things worse. For me. Mainstage and Logic work better with it on. i'm using the new i5 MBP with 2 dual cores and I have it set to 4 cores.

 

3: As an alternative to #1, you can go into Kontakt prefs and under the memory tab increase the instruments preload buffer size. This only applies to DFD mode and not sampler apparently.

 

Other things I've noticed are that you have to be careful what effects plugins you put on your channel strips. just above the name of each strip is a number in miliseconds. That's the extra latency that any plugs are causing. Most native Logic plugs are fine, but many 3rd party plugs introduce unusable latency and cause efficiency problems in my experience. PSP plugs introduce 5-7 ms of latecy and cause inconsistent latencies, so I avoid those. Also, Kontakt/Mainstage doesn't like multiple instances. Sometimes you can get away with it, but try to avoid it and open thing with the EXS sampler instead. Unfourtunately more and more libraries are switching to Kontakt exclusively (Scarbee).

 

Hope that helps.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...