Jump to content

Volume Changes when Selecting Track? [SOLVED]


rivertunes

Recommended Posts

In using Logic 9.1.3 I have begun to run into problems. I have OS10.6.6. I at first had problems with the Logic not quitting and would have to force it to quit. It stopped reading my m-audio midi driver. I would have to restart the computer to clear it so it would open correctly again, and eventually it ceased to read the midi driver, even with a reinstall of the driver. I ran the apple software and hardware tests (from the manual instructions and from the external disk) and that seemed to help with the starting and quitting. Now it reads the driver. However, now when I click on a track name to select that track the volume level collapses to -13.1 or so no matter what track name I click on. When I play back the automation on that tracks acts like a bucking bronco up and down popping and clipping. I have not yet found a solution for this. It will bounce okay, but you can't play and work on a project without continually encountering this impossible handicap.
Link to comment
Share on other sites

However, now when I click on a track name to select that track the volume level collapses to -13.1 or so no matter what track name I click on.

 

Logic's channel strip faders respond to incoming MIDI volume data (controller #7). Your MIDI controller is most likely sending that data.

 

When I play back the automation on that tracks acts like a bucking bronco up and down popping and clipping.

 

That's what happens when the same kind of data reaches the channel strip from 2 different sources: Track automation and your MIDI controller.

 

I have not yet found a solution for this.

 

 

-Make sure you have the latest driver for your MIDI controller.

-Try resetting the controller (check its manual).

-Check the slider or knob that sends controller 7 on your keyboard. Configure it so that it doesn't send that controller number.

 

If the above fail, you can work around the issue from within Logic by:

 

1-Using the MIDI input filter in Settings > MIDI > Input filter and checking the Control Changes box (this will filter all other control change messages...modwheel, expression, etc).

 

2- Setting up a transformer object between the physical input and sequencer input objects in the environment's Click and Ports layer, like this:

 

http://www.logicprohelp.com/files/filter7_146.png

 

J.

Link to comment
Share on other sites

You're welcome, just keep in mind that using the input filter for control change events will also cause the modwheel, sustain pedal, etc to stop reaching things in Logic. That's why trying to solve the problem at the source (the keyboard) is usually the best option. If you can't figure it out but still want to be able to use a sustain pedal (for example, and if you have one), then filtering just controller 7 with a transformer is the second best option.

 

J.

Link to comment
Share on other sites

  • 3 years later...

Hello Jordi

I know this is an older post so I hope your still around ..

 

I have this exact same problem.

When I select a track it automatically jumps up to a certain value somewhere from 2.6 to 3.1 … (Give or take .. )

The selected fader keeps physically moving even though the rack is not running.

And this happens on new empty projects just as well as on older ones.

 

This problem first occurred after I tried to assign a key on my Novation SL Mk II to the "jump to beginning' button.

I used Apple + K to open "Controller Assignment"

I might have accidentally used 'Apple + L' first.

It was a long time ago when I last tried to map a control to a button so I was searching around a little ... :(

 

After this the jumping faders started.

So I think I screwed up somewhere when trying to link the button.

 

Now when I follow your instructions:

 

1-Using the MIDI input filter in Settings > MIDI > Input filter and checking the Control Changes box (this will filter all other control change messages...modwheel, expression, etc).

 

Then the problem is solved ...

But only for that one project.

With every new project I open the problem is back … :(

 

Now I rather not check the 'Control Changes box' every time I open a project.

Mainly because problem screws up at least one tracks of the opened project before I can check the box.

 

Is there anyway to make sure this problem does not persist at all …?

 

This problem occurs always, when I have the SL MkII connected and when it's not.

The problem is on every track both midi- and audio tracks.

 

I hope you or someone else is able to point me in the right direction.

 

I'm working on an older iMac, almost 4 years old.

I'm using OSX 10.7.5 and Logic Pro 9.1.8.

My controller is a Novation SL MkII, 49 keys.

And Automap is version 4.7.0

I have already reset the SL MkII, that did not help.

Link to comment
Share on other sites

I feel sooo stupid.

I found the problem.

I had my old Roland RD-300 piano still hooked up to the MIDI-in connection of my soundcard.

I hardly ever use the damn thing so I totaly forgot about it.

I feel like such a noob … :(

I found the problem after a complete reinstall of Logic … bummer … lol

Well at least the problem is solved and I can get back to mixing.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...