Jump to content

Using stereo instead of multi to save CPU


Soundhound

Recommended Posts

I'm wanting to save CPU headroom (and RAM) by freezing some tracks in some projects I'm working on. I'm running an older 2.16ghz imac core 2 duo, with some newer, hungrier instruments and need to freeze tracks in order be able to run everything.

 

So far so good. But here's the trick, you can't freeze a multi instance of an instrument, so my thought is to do some stereo instances (Kontakt, Garritan ARIA etc) and use their internal mixing capabilies (limited, but should do the job).

 

The problem with this is I get one track in the arrange area, with several different instruments info in it. Kind of cumbersome. I can look at the info by midi channel, which works okay I guess. Can anyone think of a better way to do this? Is there a way to have multiple tracks in the arrange area all going to the same plugin perhaps?

 

thanks!

Link to comment
Share on other sites

Hi

 

Try bounce in place:

Region:BiP

Track: BiP

 

 

Note that some plugs using sample streaming may not like the 'offline' BIP functions. You may need to resort to 'old-school' bouncing (route the output of a track to a bus, and make a new audio track to record this bus).

 

 

HTH

 

CCT

Link to comment
Share on other sites

Nice, thanks! That will take care of the multi problem. Looks like you can have it create a new track below the current one, whether audio or midi, which means if you want to deal with it after doing a bounce in place, you'd probably have to unmute the original regions and delete the new track created by BIP? Not the end of the world, but an extra step. Maybe this is how I'll handle it.

 

Unless anyone can think of another approach to dealing with multiple midi regions/information needing to sit on the same track in the arrange area. Any way to split that to different tracks in the arrange area, which all use the same instrument and go to the same channel strip in the mixer? (I guess if they could go to different channel strips that would be even better.)

 

Hi

 

Try bounce in place:

Region:BiP

Track: BiP

 

 

Note that some plugs using sample streaming may not like the 'offline' BIP functions. You may need to resort to 'old-school' bouncing (route the output of a track to a bus, and make a new audio track to record this bus).

 

 

HTH

 

CCT

Link to comment
Share on other sites

Hi

 

If the only problem is Multi-timbral instruments not dealt with by Freeze then you are kind of stuck with more than 1 track (MIDI/sw instruments and the corresponding audio).

 

If the issues you are dealing with are CPU based, BIP followed by Bypassing the Instrument Plugins used might help.

 

If the issue is RAM, you will need to "unload" the instrument plugins.

 

2 ways to achieve this that I can think of:

 

A

 

Save the Instrument setup as a Channel Strip setting (in case you need to reload it), then Reset the Channel Strip

 

 

B

 

In the Environment, select the Instrument Object and set it's 'Channel" to OFF in the Inspector. Re-setting this should to the correct Inst Channel should re-load the plugins.

 

 

HTH

 

 

CCT

Link to comment
Share on other sites

Thanks again. I think the issues are both CPU and RAM, so I'll use a combination of what you suggest. How do you Bypass an Instrument Plugin?

 

Many thanks again..

 

Hi

 

If the only problem is Multi-timbral instruments not dealt with by Freeze then you are kind of stuck with more than 1 track (MIDI/sw instruments and the corresponding audio).

 

If the issues you are dealing with are CPU based, BIP followed by Bypassing the Instrument Plugins used might help.

 

If the issue is RAM, you will need to "unload" the instrument plugins.

 

2 ways to achieve this that I can think of:

 

A

 

Save the Instrument setup as a Channel Strip setting (in case you need to reload it), then Reset the Channel Strip

 

 

B

 

In the Environment, select the Instrument Object and set it's 'Channel" to OFF in the Inspector. Re-setting this should to the correct Inst Channel should re-load the plugins.

 

 

HTH

 

 

CCT

Link to comment
Share on other sites

Gotcha. WIll this relieve the CPU of processing the instrument? But it won't save anb RAM right? For that I need to unload the instrument (or use the proceddure in the environment that CCT outlined above?

 

How do you Bypass an Instrument Plugin?

 

Option Click the plugin on the channel strip

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...