Jump to content

ALIAS channel strip not working?


Recommended Posts

I'm using an heavy piano that I'd like to use in different patch for keyboard 1

I select it and then Copy - (edit-copy or command-C)


After I go to another patch, i go to Edit-paste as Alias, and the channel strip is copied properly,

but is not really an alias.

There is not any Alias Icon on it and is not working actually as an alias (parameter linked from original one).

So it's just a new channel strip, using more memory, that is not what I need.

Some of you got the same issue?

Any tips?

Link to comment
Share on other sites

Actually, I specifically tested it before I posted, and it works fine. I did a guitar channel strip (audio) and a keyboard channel strip (software instrument) and tested them in the same layer, different layers, etc.


I think I can remember others posting on this problem with version 2.x earlier on. Maybe search and see if you can find problems and solutions. Sorry I can't be of more help.

Link to comment
Share on other sites

It seems to work, but actually I can't see the green alias icon as described in the manual,

so I'm not sure the alis is int here or just a copy.


Can you see the green alias icon on the top of the channel strip ?

what is your mainstage 2 version?


Can you add a picture of what you see in order to compare with mime?


thank you in advance

Link to comment
Share on other sites

In screen swipe you can see an alias on the patch level, set level (blue folder) and concert level (brown folder). I'm using version 2.1.2.


Might also try key command:option command v


Thank you Doug Z for supporting me for this troubleshooting.


ok, we got the same version, and I'm doing the same operation as well.

I'm opening mainstage in 32 bit for using the rewire with reason, but this shouldn't be a problem.


Actually what I've noticed is that the alias seems to work in this way:

1 - If I add an fx in the "original channel strip" is added as well also in the alias - OK !!!

2 - If I change the volume on the "original" sound, it doesn't change in the alias

OK ???? it is correct?

3 - I don't have any Green flag as mentioned in the manual on page 51. This is NOT OK

4 - I can't see any sign showing me where I've added an alias and where not. Actually I have multy sounds in layer and split in many patches. I don't have set.

How I can know and remember where is the alias if I don't see the flag ? This is NOT OK

5 - When I try to remove the "original" channel strip is asking me "confirm channel delete because there is 1 alias" - THIS IS OK


Can you confirm me the points above or you have some feature that I don't have?

Consider that if you have some feature that I don't have for some unknown reason I'm going to kill you and steal your computer :)

Link to comment
Share on other sites

Confirming I'm running in 32 bit mode.


Have you tried creating an alias CS in a new project - I'm wondering if you have some corruption going on. Quite odd you don't get the alias badge.


Regarding points 1 through 5


1) good

2) independent volume = good

3) bad - try in new project

4) You do have sets available - you may not be choosing to use them. FInding alias is tough without the flag....

5) yes

Link to comment
Share on other sites

S O L V E D !!!!!!


I tried everything..... and then.....

i right click on the channel strip... and what I found?

"Badges" was not flagged !


Flagging badges I got finally my green signs for Alias.


Something so stupid made me crazy for a while.


Thank you Doug Z for your support

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...