Jump to content

Midi keyboard works on laptop not on desktop


Recommended Posts

My midi keyboard (ReMote 25 original) suddenly stopped working today on my desktop. It still works with Logic on my laptop. On the desktop there is simply no in or out midi on the transport bar. The usb cable is brand new and as I said it works fine on my laptop.


I recently installed Komplete 8 on the desktop computer and also changed my audio interface from an mBox to a Fireface 400. The midi keyboard worked fine after this at first, however Logic started behaving strangely, f.eks. it doesn't shut down properly, I always have to force-quit.


Should I re-install Logic on the desktop? That seems like a headache, is it pretty straightforward or to I have to do a complicated un-install?


Logic is version 8 on both machines.

My desktop is a MacPro 3,1.

Interface is a Fireface 400

Midi Keyboard is a Novation ReMote 25 original


Thanks in advance.

Link to comment
Share on other sites

It's core midi compliant. I never installed a driver and there isn't one available on the Novation website. It worked fine on the MacPro yesterday, didn't do anything today other than starting up Logic but it's not working today. No midi in or out.


It works fine on my laptop.. I'm at a loss..

Link to comment
Share on other sites

Thanks again, ok.. I read the thread and think we are having the same problem. I was running off a usb hub but I've now connected the ReMote directly into a USB port on the Mac Pro. It's still not working though!


I deleted the ReMote icon from the audio midi setup window (it was there but grayed out when I looked) and tried a re-scan but it didn't see it. Tried re-installing the Firecface driver and re-scanned again and it still didn't find it. I connected a MIDI cable into the Fireface and the Mac Pro started seeing MIDI!


So, I'm at a loss because I've been using the hub for years, since 2004 or thereabouts and never had a problem before. It's working now with the midi cable but it's annoying that it's not working via USB.


Thanks a lot for your help, at least I can make music now!


Do you think there is a possibility of the USB working again?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...