Jump to content

Updated OS X to Snow Leopard, Logic is not happy! ::SOLVED::


Recommended Posts



A bit behind the times, but I recently overhauled my setup which included updating from Leopard to Snow Leopard 10.6.8 32 bit (I run an Intel G5 2.8 Dual Quad Core with 8 GB RAM).


At the time I was still running Logic Pro 8, and immediately upon upgrading my OS I began experiencing troubles -- freezing, frequent unexpected crashes, etc. Any time I give Logic something processor-intensive to do, my screen will "flash" a lighter color and the program crashes.


I thought upgrading Logic would change my luck, so I got Logic Pro 9.1.1, then upgraded to 9.1.3 and finally 9.1.5. Regardless, things remain exactly the same. Logic is extraordinarily unstable and I am left with the inability to make much productive use of the program.


I can work fine with most plug-ins and software instruments, but any time I attempt to bounce a track or, KEY here, adjust my input / output in Preferences > Audio, Logic crashes. Because of this I am unable to select my interface for physical recording.


I am using an M-Audio Fast Track Pro, and have downloaded the latest driver for OS X 10.6.8. I have repeatedly attempted to uninstall / reinstall the driver for this interface to no avail.


So...anyone have any ideas? It's really cramping my ability to work or share my work with co-writers.....


Thanks for your time.

Link to comment
Share on other sites

What a mess.


Following Jordito's suggestion initially I tried upgrading to the ProKIT 7.0.1. This stabilized Logic a bit -- I am now able to bounce tracks down and it doesn't necessarily crash immediately upon loading my Preferences pane. However, Logic is still unable to process a switch in Input/Output, it will occasionally crash on startup trying to load a plugin (Native Instruments Guitar Rig seems to be the culprit) and it now refuses to recognize my interface at all.


I have attempted to downgrade the ProKIT (5.0.1 seems to be the favorite according to forums I've found) however OS X does not allow the install and the Terminal instructions I've found are incomplete (and as I don't know precisely what I'm doing in there, I'll take it no further).


Has anyone else had to take it this far? Any tips or specific instructions?

Link to comment
Share on other sites

Managed via manually extraction to install ProKIT 5.0 and then 5.0.1...and no change under either. OS X simply will not let me view the package contents of the 6.0.1 ProKIT upgrade, so no dice there.


At this point I am going to try upgrading back to the 7.0 ProKIT, under which it appears most stable, and then following Ski's suggestion and trashing the .plist prefs. I know you say it's a drastic measure but...nothing else seems to be working. Also, the fact that Logic crashes any time I try to adjust any parameter in the Preferences pane seems to point here...

Link to comment
Share on other sites

So a reinstall of Logic 9.0 solved some issues (a few I even neglected to mention), and overall the program has stabilized. However, even though it is now once again recognizing my interface, Logic still crashes whenever I try to select it as my Input (it begins to initialize Core Audio and then quits with the "Logic has Unexpectedly Quit" message).


I have once again reinstalled the newest driver for the Fast Track Pro and have searched around for any known issues between this interface and Logic 9...so far nothing. I am going to reupdate to 9.1.5 in case this solves the issue but I'm doubting that will help anything this time around either.


Sorry for the quandary, any further thoughts?

Link to comment
Share on other sites

Okay, epic of a crash report it is...I apologize if I posted too much of this, never dealt with one before...


Anyone see anything...?




Process: Logic Pro [266]

Path: /Applications/Logic Pro.app/Contents/MacOS/Logic Pro

Identifier: com.apple.logic.pro

Version: 9.1.5 (1700.9)

Build Info: Logic-17000900~1

Code Type: X86 (Native)

Parent Process: launchd [169]


PlugIn Path: /Library/Audio/Plug-Ins/Components/Guitar Rig 3.component/Contents/MacOS/Guitar Rig 3

PlugIn Identifier: Guitar Rig 3.MusicDevice.component

PlugIn Version: (3.1.1, Copyright © 2008 Native Instruments)


Date/Time: 2011-10-05 19:55:13.078 -0400

OS Version: Mac OS X 10.6.8 (10K549)

Report Version: 6



Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000bcf38be2

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Link to comment
Share on other sites

So I deduced from the (now abbreviated) crash report there that in fact my Native Instruments Guitar Rig 3 was the culprit. After removing the plug-in, I am able to change my interface, bounce tracks, etc etc.


I haven't found any reports elsewhere claiming that GR3 just clashes with Snow Leopard, so I may attempt a reinstall or potentially upgrade to Guitar Rig 4. So I suppose the only question is what happens to my effected tracks!! :shock:


MANY thanks to everyone who offered help, it is GREATLY appreciated.


Thank you.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...