Jump to content

Weird fader behavior


anamorphis

Recommended Posts

Well, now that I'm here, I have one more for you guys, one that's been bugging me for a while.

Anyone noticed a weird fader behavior that puts a fader at its maximum with no apparent reason? This happened to me a few times in these last couple projects, and it kind of sucks, not just because it scares the st out of me, burns my ears and speakers, and sometimes I can't get the fader to its previous exact level, because I can't remember the level of all the faders all the time ;)

At first I thought it might have been some automation that I might have entered by mistake, but I've double checked it, and there was no automation whatsoever in the tracks where that fader behavior happened.

And it's kind of random as well. So far I haven't been able to spot why it happens on a specific fader at a specific time.. :?

Anyone has any idea what might be causing it?

 

Thanks a lot,

Rui

Link to comment
Share on other sites

Yep, you were right!

I tried running the session with MIDI Monitor open, and in fact, at some point, the Keystation sends several Control messages on channel 1, and the Data column reads "Channel Volume (coarse) 125" or 126 or 127.

I can't remember this behavior ever happening since I use Logic, all the way back to Logic 7.2!

Do you know what I could do to stop it?

 

Thanks a lot

Link to comment
Share on other sites

I can't remember this behavior ever happening since I use Logic, all the way back to Logic 7.2!

 

Probably because your Keystation 49e was working properly back then...or you didn't have it at all.

In other words...it has nothing to do with Logic! :)

 

It's not the first time I've seen someone with this kind of problem with that particular keyboard:

 

Fader volume "stuck"

 

Judging from what was tried in that thread, it seems there's little you can do to fix it right on the keyboard (or in Audio MIDI Setup, but by all means try what's suggested there).

 

So your options are:

 

Enable the Input Filter for Control Change messages in your project's MIDI settings. (Keep in mind this will filter all CC's, not just volume).

 

Put a transformer somewhere between the Physical Input object and the Sequencer Input object in the environment's Click and Ports layer to filter out CC7 specifically, like this:

 

filter7_146.png

 

Regards,

 

J.

Link to comment
Share on other sites

Hey guys, thank you both for your replies.

 

J.: that looks like a lot of work (specially for a non-environment-expert like myself) to eventually achieve something ;)

 

shivermetimbers: so, I went up and read pages 9/10 of the manual, but I wasn't able to find an explanation to this issue. Although I admit I'm not that good with some of the MIDI mambo-jambo, and I probably missed the point you made.. From what I understand, I could change what the Mod Wheel is assigned to, but that wouldn't be permanent, right? Please let me know if I got it all wong. I really appreciate.

 

The other solution is to just go out and buy a new MIDI keyboard, this one has already done its job anyways :)

Link to comment
Share on other sites

Hey guys, thank you both for your replies.

 

J.: that looks like a lot of work (specially for a non-environment-expert like myself) to eventually achieve something ;)

 

shivermetimbers: so, I went up and read pages 9/10 of the manual, but I wasn't able to find an explanation to this issue. Although I admit I'm not that good with some of the MIDI mambo-jambo, and I probably missed the point you made.. From what I understand, I could change what the Mod Wheel is assigned to, but that wouldn't be permanent, right? Please let me know if I got it all wong. I really appreciate.

 

The other solution is to just go out and buy a new MIDI keyboard, this one has already done its job anyways :)

 

You can also change what the Volume slider is assigned to, and yes it is a temp thing that changed with every power cycle.

I had problems like that in MainStage using the m-audio keys. Another problem I had with that keyboard is the sound would cut out if the keys were pressed either too fast or hard. I would have to power it off/on and redo the settings. It became frustrating and I started to slam that thing to the ground.

 

If the volume thing is the only issue, setting its value to something other than the basic midi functions (volume, modulation, pitchbend, etc) is quick and easy.

 

A new keyboard is always a welcome option. :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...