Jump to content

Sending midi messages to controller keyboards


DJ

Recommended Posts

Hi,

I was hoping someone could enlighten me on the following? I have searched high and low for the answers but to no avail.

I have the following setup Imac, 3.06GHz Intel Core 2 duo, logic 9.7, 2 external controllers Fatar Studiologic 90plus, Oberheim MC1000, Motu 828 MK2, ICON midi 5 in 5 out

 

I can set up both the Fatar and Oberheim IE split the keyboards, change the octave settings etc and save the setting to a program number on the respective controller. So for example each song has its own keyboard setup. Want I cannot do and understand is how to get logic to send the relevant midi information to the relevant keyboard so when I load a new song each keyboard program number changes and so does the keyboard setup. At present when I load a new song the keyboards stay on the same setup as the previous song.

At present the Fatar has 3 midi outs set to midi channel 1-3 the Oberheim has 2 midi outs set to 4-5.

I can see the relevant ports in the environment window! but I'm not certain if I need to set up external instruments for the fatar and the oberheim? and get the only to respond to the midi channels they are setup to.

I also need to know if this can be done in Logic can it be done in mainstage?

I'm at a loss, I have tried to explain this the best I can

Thanks for any advise

Link to comment
Share on other sites

Want I cannot do and understand is how to get logic to send the relevant midi information to the relevant keyboard so when I load a new song each keyboard program number changes and so does the keyboard setup. At present when I load a new song the keyboards stay on the same setup as the previous song.

 

You need external MIDI tracks in your project set to output to the appropriate ports (the ones connected to your keyboards MIDI inputs) and MIDI channels (the MIDI channels your keyboards are set to receive).

 

In the external MIDI track inspector, you can set the desired program number (making sure the program checkbox is checked).

 

Go to your project settings > MIDI > General and make sure the Send After Loading Project: Used instrument MIDI settings box is checked.

 

If you save the project, whenever you open it again, the program change numbers will be sent to your keyboards.

 

1245509286_MIDISettings.thumb.png.d0fa41e60c00a01a2eb1dad9b0c2f273.png

 

J.

Link to comment
Share on other sites

Hi,

Many thanks for your help but unfortunately I cannot get it working.

First of all I noticed on your reply you have put midi inputs the fatar only has midi out puts.

When I do create external tracks I always get the GM device appearing, I have gone into the environment and removed the device but every time you create a new external track the GM device show up.

I have looked online and I found that if you create multi's (what ever they are) in the environment and then delete the GM device and save it to a template this deactivates the GM device, I assume these are multi instruments if the are I can create them but cannot find an interface icon in the environment so as usual I cannot get it to work

 

I assume cabling wise I would have to midi out of the mac to the in on the keyboard and out the keyboard to the in on the mac?

I hope this makes sense.

Thanks for you help

Link to comment
Share on other sites

First of all I noticed on your reply you have put midi inputs the fatar only has midi out puts.

 

So how do you plan on sending MIDI messages from Logic to it if it doesn't have MIDI inputs? :?

 

When I do create external tracks I always get the GM device appearing, I have gone into the environment and removed the device but every time you create a new external track the GM device show up.

 

Yes, by default new external MIDI tracks are automatically assigned to GM Device, and it outputs to All ports. But, you choose whichever port you need from the Library like in my pic (or from the track inspector). It doesn't have to be a GM Device and by the way you definitely don't have to go into the environment for any of this.

 

J.

Link to comment
Share on other sites

Hi J,

Well I think I have answered my own question really, the fatar doesn't have midi inputs only outputs, the oberheim has I midi in and 2 midi outs, I suppose the only answer is to manually change the controllers after each song.

Thanks for your help

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...