Jump to content

Sample Editor View


eclectic

Recommended Posts

I've been recording some acoustic claps today and the problem is that when I cut out a clap I like from this long audio region (containing loads of random claps) and move this separate region to another place in the edit window. I still get the view of the whole original audio region (of all the claps) in the Sample Editor, while I only really want to view the audio region of the newly made clap alone. Is this possible?

 

Thanks in advance.

Link to comment
Share on other sites

That will only happen if you save it as a new audio file.

 

By cutting sections out, you're creating new regions, but not new audio files.

 

Quickest way, I reckon, is to do a "strip silence" on the audio, then select all the regions and save as new audio files.

 

Obviously, creating new audio files will take up more HD space.

Link to comment
Share on other sites

Are you sure the only way to do this is to save it as a new audio file? This would probably be a bit too time consuming if I had to that the whole time. The problem is that when I'm aligning the anchor and I want to move around at the level where I can see individual oscillations, the mouse shift the sample editor drastically sometimes, which can be quite frustrating.

 

Anyway if that's the only way, I'll just have to be more careful with the mouse. Thanks a lot for your help.

Link to comment
Share on other sites

I still get the view of the whole original audio region (of all the claps) in the Sample Editor, while I only really want to view the audio region of the newly made clap alone. Is this possible?

 

The sample editor is an audio file editor, NOT an audio region editor. Therefore when you open a region in the sample editor, it actually opens the parent audio file. If you want the file to have the same boundaries as the region, you need to trim the audio file or create a new audio file. It's quick: in the Arrange area, select your region and choose Audio > Convert Region to New Audio File.

 

The problem is that when I'm aligning the anchor and I want to move around at the level where I can see individual oscillations, the mouse shift the sample editor drastically sometimes, which can be quite frustrating.

 

Hmmm sorry to hear about that issue but I haven't noticed any issue like that, so you shouldn't have to live with that. Do you have that issue in all your projects?

Link to comment
Share on other sites

Hmmm sorry to hear about that issue but I haven't noticed any issue like that, so you shouldn't have to live with that. Do you have that issue in all your projects?

 

It's more the fact that the mouse wheel is very sensitive, therefore when zooming around the anchor the file size changes quite quickly, but that's the mouse's and my fault, not that of logic. I'm using the arrow key commands instead now.

 

I now just use the option in the editor window, edit > "Selection -> Region", and then Strip Silence the audio file or just strip silence the whole region. Then when I know I want to keep this file in the project, I save it as a new Audio File. Doing it this way also nicely clears up the project, as I can delete the original tracks containing all the obsolete samples.

 

Thanks both for your help. I'm a lot more efficient now, at dealing with these samples!

Link to comment
Share on other sites

It's more the fact that the mouse wheel is very sensitive, therefore when zooming around the anchor the file size changes quite quickly, but that's the mouse's and my fault, not that of logic.

Note that you can adjust the speed of your mouse: click the apple menu, then System Preferences, choose Keyboard & Mouse, click the mouse tab and adjust the "tracking speed" to taste. Mine is virtually all the way up, but it's a personal choice.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...