Jump to content

Logic opening ESX24 instrument editor - bug? [SOLVED]


amygdala

Recommended Posts

Hi all,

 

In a Logic project of mine, the ESX24 has developed the nasty habit of opening the instrument editor window, while Logic is playing. It happens at the same place in the project *every time* - as the playhead passes bar 101. I don't want it to do that.

 

Have you experienced something similar - I have searched to figure out if I stumbled on a feature, but no one speaks about this. I have trawled all the event lists to no avail.

 

Bug or feature?

 

Thanks!

 

- A

 

Logic Pro 9.1.6

Link to comment
Share on other sites

By accident I discovered a way to open the instrument editor with a fader event (it's a Logic-specific kind of MIDI data that's generated when moving controls on plugins). By any chance did you happen to open the instrument editor while the song was running, and with automation enabled (touch or latch) on that track?
Link to comment
Share on other sites

Hi Ski,

 

Thanks for your reply! As with all other kinds of problems, this is of course not unique. Glad to hear it happened to someone else.

 

I hardly ever open the instrument editor, so the event to spring it at we has probably not been recorded. I use automation heavily, and frequently have problems with it, because it is easy to use, I thus I haven't bothered figuring out what touch or latch *actually* means.

I have tried muting all tracks that the event could come from, but that doesn't help anything...

 

Your lead is definetly something to go on though, since it appears it is most likely a feature I stumbled into - then I should be able to find the culprit and delete it. Thanks again!

 

- A

Link to comment
Share on other sites

Hi all,

 

I managed to get rid of the window popping up. Here is how:

 

- I removed the data on the track that caused the problem. Finding out which one was purely guesswork. The data removed was (as I could see it) only a looped region.

- I then put in an empty MIDI region over the place in time where the window popped up

- I did the "Move all track automation to region" thing

- I deleted the region.

 

Et voila!

 

Thanks for your reply Ski!

 

- A

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...