Jump to content

iZotope Radius doesn't work [SOLVED]

Recommended Posts



trying to tune a vocal part using Radius but seems that tweaking in the Radius' window does not influence on the results.

Actually the result is not good by default.


What settings I have to set in the Time & Pitch Machine and the Radius to change the pitch let's say by +5 semitones without timing being altered?

Should the Radius window be launched before Logic?


I have 8 days until demo period will end and I have to make decision if this plugin is worth to spend 400$.

Link to comment
Share on other sites

Set the Algorithm to one of the Izotope algos, then set Transposition to 500, and use Harmonic Correction if desired:




PS: Just tried the demo here, it works as expected and changing settings in the Izotope Radius window do change the results I get when using Radius in the T&P Machine. Are you sure you selected Izotope Radius in the T&P Machine?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...