Jump to content

MIDI roundtrip delay, environment workaround


robertg

Recommended Posts

I have to advance all of my midi parts about 14 ms to account for sound card roundtrip latency for live playback in the composition stage. I have to do this for every region; changing the multi-instrument's "delay" value seems to do nothing.

 

Interestingly this isn't needed when it's time to record midi synths, only for live playback, I wonder why that is. Seems like a design flaw.

 

Anyway, is there some way in the environment to cable in an auto-delay mechanism or something of that nature so that each region doesn't need to tediously be adjusted?

Link to comment
Share on other sites

Not sure what you mean by auto-delay mechanism. You can use a delay object to delay the output of your MIDI events, if that's what you need?

 

Thanks, that seems logical except the delay line object does not advance, so it's backwards.. Could there be another way to make midi play early?

Link to comment
Share on other sites

If i understand correctly, what you are asking... and as an alternative to using the environment...

 

You can do so in the Track Parameters Box

 

There you can advance and delay all the notes on that track (rather than by region) by using the Track Parameters Box

 

Click on the Track Parameters Box disclosure button and then set up the required delay for the entire track.

 

1172738838_TrackInspectorDelay.png.c3b8bb3aebeb2e2c661744c0eb12b850.png

 

Hope this helps

Link to comment
Share on other sites

If i understand correctly, what you are asking...

 

You can do so in the Track Parameters Box

 

There you can advance and delay all the notes on that track (rather than by region) by using the Track Parameters Box

 

Click on the Track Parameters Box disclosure button and then set up the required delay for the entire track.

 

[attachment=0]Track Inspector Delay.png[/attachment]

 

Hope this helps

 

That delay parameter does absolutely nothing. The only one that works is the one above it, for regions, and I have to set that for every single region..

Link to comment
Share on other sites

That delay parameter does absolutely nothing.

 

It works just fine here....

 

(I just did a test with 9.1.7 moving the delay back and forward 500ms... in case it had been broken during one of the updates as i haven't used it in a while..but no.... works fine)

 

...though I am using it with software instruments... and not with external midi.

 

Maybe it is bugged when used with external midi? (Can't test that at the moment due to where i am and my minimal setup here)

Link to comment
Share on other sites

That delay parameter does absolutely nothing.

 

It works just fine here....

 

(I just did a test with 9.1.7 in case it had been broken during one of the updates as i haven't used it in a while..but no.... works fine)

 

...though I am using it with software instruments... and not with external midi.

 

Maybe it is bugged when used with external midi? (Can't test that at the moment due to where i am and my minimal setup here)

 

That's probably it, it only works for audio instruments and not external midi. So I'm going to try something that may or may not be clever, and that is to cable the audio instruments to midi channels.

Link to comment
Share on other sites

That's probably it, it only works for audio instruments and not external midi.

 

Maybe.. though according to the manual.. it should and i know it used to do so as I had to use it with the Korg Oasys to correct a small delay that occurring when running the early versions of Stephen Kay's built in Karma modules....

 

Odd it doesn't now..... I wonder if someone else could test this out and see if it affects everyone...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...