Jump to content

How to disable dynamic keyboard ? [SOLVED]


Recommended Posts



Is there any way to turn off the dynamic keyboard in Logic Pro ? I've got external midi keyboard without deactivating dynamic. When I recorded it I already know how to do it, but I would like to turn it off when playing live...


Thnx for any ideas...

Link to comment
Share on other sites

Signature updated ;)


I do not mean Caps Lock keyboard... I mean external keyboard controller. I hit softly - the sound is quieter, I hit harder - it is loud. So, how to disable dynamic keys ?


Thanks for updating your signature! :)


I understand what you mean now. If your keyboard does not allow you to do it locally, you can use the Dynamics and Velocity parameters in the MIDI Thru settings in the inspector:




To view the MIDI Thru settings, make sure no region is selected. Set the Dynamics parameter to "Fixed", and then adjust the Velocity parameter until the incoming notes sound as loud or soft as you want.


Keep in mind that:


Any live MIDI input (in Stop mode, as well as during recording or playback) is played with the settings chosen here. When you record a new MIDI region, the settings in the MIDI Thru Parameter box are carried across to the new MIDI region’s Parameter box. The MIDI Thru Parameter box can be viewed as an adjustable default Parameter box.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...