Jump to content

'Download Additional Content' greyed out [SOLVED]


Recommended Posts

Hi folks -- I know a lot of people have had problems with the additional content, but I still couldn't find an answer to my own.


I downloaded Logic 9.1.8 from the App Store. Had a look at it, then selected Download Additional Content from the menu.


Everything downloaded and I entered my admin password. The installation appeared to be fine until it came to Jam Pack 1. It hung on that for well over an hour. Clearly nothing was happening.


I was able to quit the app normally. When I reopened it I was asked if I wanted to resume the download. I selected that but got the beach ball. Force quit and tried it a few times, same result each time.


Next time I selected 'cancel download'. Now the 'Download Additional Content…' menu option is greyed out. But I can't see the content. If I click on Loops everything is greyed out, as if nothing is installed.


I'm new to Logic and might be missing something daft, I don't know. Appreciate any help at all. Thanks very much.


(MacBook Pro, 10.6.8)

Link to comment
Share on other sites

Many thanks for your quick responses, folks. At least I knew there was no obvious answer. I called Apple and the guy simply clicked a button and I could suddenly click on 'Download Additional Content' again. There wasn't much to download, though. A few hundred MB here and there, seemingly at random from each of the packs. (If I had to do it again, I would download each pack separately.)


When it was done, the loops browser was still completely empty. I went to Library > Audio > Apple Loops > Apple and dragged one of the loops from one of the folders at random into the Loops browser to add it. I thought that that might've added the rest of the loops when I restarted the program, but it didn't. I ctrl-clicked the Loops browser and selected 'Reindex library' and after a couple of minutes it filled the Loops browser. I now have 15,653 items in there, which I hope is everything. If not, it should keep me going for a while!


I don't know if everything is okay yet. I'll be working through the tutorial manual at the weekend and should find out then. I'm just posting this in case anyone else suffers the same problem.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...