Jump to content

Computer Won't Shut Down Completely after LogicPro Session


Recommended Posts

Hey Guys!


I have had a problem with my Macbook Pro (late 2011... details in my signature), not shutting down completely after running Logic Pro sessions. When running Logic Pro, I have two harddrives connected, a G Drive 7200 RPM via firewire for sample libraries and a LaCie SSD via Thunderbolt to record on to / save Logic Pro Projects. I use an external monitor connected via minidisplay from the second thunderbolt port on the LaCie SSD. Also connected is my Babyface via USB and a USB hub (Belkin 4 port powered hub) with an apple keyboard/mouse, Axiom Pro and Maschine connected.


Everything runs smoothly and works really well when I'm using Logic Pro. No issues with anything.


The problem occurs when I go to shut down my macbook pro after running a Logic Pro session. I will first eject / disconnect my two harddrives and the monitor. Ill then disconnect and shut down the Maschine and Axiom Pro.


Then I'll disconnect the USB hub completely and disconnect the Babyface (and quit totalmix and fireface usb settings apps).


Then I will shut down the macbook pro. However, when I shut it down, it won't shut down completely. The screen will go black like usual, but when I close the laptop, the light on the front/outside is still on like the computer is still on. I've tried opening and closing the laptop lid, pressing the power button, trying different combos on the keyboard, but it won't respond to anything, just a black screen. The only way to shut it down after this happens is to hold the power button.


Recently, I've tried a different order of operations in shutting down the macbook pro, to no avail. Instead of disconnecting the usb hub and babyface, I've kept them connected when I shut down the macbook pro, but still get the same problem. (It's more obvious too because the babyface is still receiving power and is "on").


This problem shutting down the computer does not happen unless I've been using logic pro... If I just turn on my computer to browse the internet, listen to iTunes, etc. it shuts down just fine.


Any ideas?? Any help would be much appreciated. Here is an example of the most recent "Problem Report" I received after turning on my macbook after the most recent failure to shut down properly.



Interval Since Last Panic Report: 288900 sec

Panics Since Last Report: 4

Anonymous UUID: E327693A-3B99-4CE2-A308-AE40B8708BBE


Wed Dec 19 11:37:07 2012

panic(cpu 4 caller 0xffffff80002c4794): Kernel trap at 0xffffff7f8078efb0, type 14=page fault, registers:

CR0: 0x000000008001003b, CR2: 0x0000000000000001, CR3: 0x0000000000100000, CR4: 0x00000000000606e0

RAX: 0xffffff7f81fdb130, RBX: 0xffffff8020886400, RCX: 0x0000000000000200, RDX: 0xffffff8020886408

RSP: 0xffffff81d0d03bd0, RBP: 0xffffff81d0d03be0, RSI: 0x000000000000ffff, RDI: 0x0000000000000001

R8: 0x0000000000000008, R9: 0xffffff8020891a00, R10: 0x000000000000008b, R11: 0xffffff800063dc04

R12: 0xffffff80203c6000, R13: 0xffffff8020658280, R14: 0xffffff80008df700, R15: 0x0000000000000005

RFL: 0x0000000000010202, RIP: 0xffffff7f8078efb0, CS: 0x0000000000000008, SS: 0x0000000000000010

CR2: 0x0000000000000001, Error code: 0x0000000000000000, Faulting CPU: 0x4


Backtrace (CPU 4), Frame : Return Address

0xffffff81d0d03880 : 0xffffff8000220792

0xffffff81d0d03900 : 0xffffff80002c4794

0xffffff81d0d03ab0 : 0xffffff80002da55d

0xffffff81d0d03ad0 : 0xffffff7f8078efb0

0xffffff81d0d03be0 : 0xffffff80005e5444

0xffffff81d0d03c10 : 0xffffff80005e55c3

0xffffff81d0d03c30 : 0xffffff80005f8167

0xffffff81d0d03c50 : 0xffffff8000627ccb

0xffffff81d0d03cc0 : 0xffffff80006283a8

0xffffff81d0d03d00 : 0xffffff8000628d14

0xffffff81d0d03d70 : 0xffffff8000623068

0xffffff81d0d03d80 : 0xffffff7f8081bba3

0xffffff81d0d03db0 : 0xffffff7f80c8bc77

0xffffff81d0d03de0 : 0xffffff7f80c8e5c0

0xffffff81d0d03e40 : 0xffffff7f80c85016

0xffffff81d0d03e70 : 0xffffff7f80c88141

0xffffff81d0d03ec0 : 0xffffff800062fd10

0xffffff81d0d03f50 : 0xffffff800063019e

0xffffff81d0d03f70 : 0xffffff800023dbbc

0xffffff81d0d03fb0 : 0xffffff8000820057

Kernel Extensions in backtrace:


dependency: com.apple.driver.AppleKeyStore(28.18)[03A494E4-AA15-35DF-85EF-D8B2C7A9F05B]@0xffffff7f80770000


dependency: com.apple.iokit.IOPCIFamily(2.7)[5C23D598-58B2-3204-BC03-BC3C0F00BD32]@0xffffff7f807e7000


dependency: com.apple.iokit.IOUSBFamily(5.1.0)[71AF5A29-1AE2-3812-A0FF-96DD1CC6534D]@0xffffff7f80805000


BSD process name corresponding to current thread: kernel_task


Mac OS version:



Kernel version:

Darwin Kernel Version 11.4.2: Thu Aug 23 16:25:48 PDT 2012; root:xnu-1699.32.7~1/RELEASE_X86_64

Kernel UUID: FF3BB088-60A4-349C-92EA-CA649C698CE5

System model name: MacBookPro8,2 (Mac-94245A3940C91C80)


System uptime in nanoseconds: 19117707230884

last loaded kext at 16836812951003: com.apple.driver.AppleFireWireStorage 3.0.6 (addr 0xffffff7f808ea000, size 16384)

last unloaded kext at 16898180467259: com.apple.iokit.IOFireWireAVC 4.2.2 (addr 0xffffff7f80878000, size 110592)

loaded kexts:

com.paceap.kext.pacesupport.snowleopard 5.9

com.caiaq.driver.NIUSBMaschineControllerDriver 2.5.2

de.rme-audio.driver.FirefaceUSB 1.76

com.digidesign.iokit.DigiDal 10.3f28

com.steelseries.BoardListener 8

com.apple.driver.Oxford_Semi 3.0.6

com.apple.driver.AppleRAID 4.0.6

com.apple.driver.AppleHWSensor 1.9.5d0

com.apple.filesystems.autofs 3.0

com.apple.driver.AppleMikeyHIDDriver 122

com.apple.driver.AppleHDA 2.2.5a5

com.apple.driver.AppleMikeyDriver 2.2.5a5

com.apple.kext.ATIFramebuffer 7.3.2

com.apple.driver.AudioAUUC 1.59

com.apple.driver.AGPM 100.12.75

com.apple.driver.AppleUpstreamUserClient 3.5.9

com.apple.driver.AppleSMCPDRC 5.0.0d8

com.apple.iokit.IOUserEthernet 1.0.0d1

com.apple.driver.AppleSMCLMU 2.0.1d2

com.apple.driver.AppleMuxControl 3.1.33

com.apple.driver.ACPI_SMC_PlatformPlugin 5.0.0d8

com.apple.driver.AppleLPC 1.6.0

com.apple.iokit.IOBluetoothSerialManager 4.0.8f17

com.apple.ATIRadeonX3000 7.3.2

com.apple.driver.AppleIntelHD3000Graphics 7.3.2

com.apple.Dont_Steal_Mac_OS_X 7.0.0

com.apple.driver.AppleMCCSControl 1.0.33

com.apple.driver.AudioIPCDriver 1.2.3

com.apple.driver.ApplePolicyControl 3.1.33

com.apple.driver.SMCMotionSensor 3.0.2d6

com.apple.driver.BroadcomUSBBluetoothHCIController 4.0.8f17

com.apple.driver.AppleUSBTCButtons 227.6

com.apple.driver.AppleUSBTCKeyboard 227.6

com.apple.driver.AppleIRController 312

com.apple.iokit.SCSITaskUserClient 3.2.1

com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1

com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1

com.apple.BootCache 33

com.apple.driver.XsanFilter 404

com.apple.iokit.IOAHCISerialATAPI 2.0.3

com.apple.iokit.IOAHCIBlockStorage 2.1.0

com.apple.driver.AppleUSBHub 5.1.0

com.apple.driver.AppleFWOHCI 4.9.0

com.apple.driver.AirPort.Brcm4331 561.7.22

com.apple.driver.AppleSDXC 1.2.2

com.apple.iokit.AppleBCM5701Ethernet 3.2.4b8

com.apple.driver.AppleEFINVRAM 1.6.1

com.apple.driver.AppleSmartBatteryManager 161.0.0

com.apple.driver.AppleAHCIPort 2.3.1

com.apple.driver.AppleUSBEHCI 5.1.0

com.apple.driver.AppleACPIButtons 1.5

com.apple.driver.AppleRTC 1.5

com.apple.driver.AppleHPET 1.7

com.apple.driver.AppleSMBIOS 1.9

com.apple.driver.AppleACPIEC 1.5

com.apple.driver.AppleAPIC 1.6

com.apple.driver.AppleIntelCPUPowerManagementClient 195.0.0

com.apple.nke.applicationfirewall 3.2.30

com.apple.security.quarantine 1.4

com.apple.security.TMSafetyNet 8

com.apple.driver.AppleIntelCPUPowerManagement 195.0.0

com.apple.iokit.IOSCSIBlockCommandsDevice 3.2.1

com.apple.iokit.IOFireWireSerialBusProtocolTransport 2.1.0

com.apple.iokit.IOFireWireSBP2 4.2.0

com.apple.driver.AppleThunderboltPCIUpAdapter 1.2.5

com.apple.kext.triggers 1.0

com.apple.driver.DspFuncLib 2.2.5a5

com.apple.iokit.IOFireWireIP 2.2.5

com.apple.iokit.IOSurface 80.0.2

com.apple.driver.AppleHDAController 2.2.5a5

com.apple.iokit.IOHDAFamily 2.2.5a5

com.apple.driver.IOPlatformPluginLegacy 5.0.0d8

com.apple.driver.AppleSMBusPCI 1.0.10d0

com.apple.driver.IOPlatformPluginFamily 5.1.1d6

com.apple.iokit.IOSerialFamily 10.0.5

com.apple.driver.AppleBacklightExpert 1.0.4

com.apple.driver.AppleThunderboltDPOutAdapter 1.8.5

com.apple.driver.AppleSMBusController 1.0.10d0

com.apple.kext.ATI6000Controller 7.3.2

com.apple.kext.ATISupport 7.3.2

com.apple.driver.AppleIntelSNBGraphicsFB 7.3.2

com.apple.iokit.IOAudioFamily 1.8.6fc18

com.apple.kext.OSvKernDSPLib 1.3

com.apple.driver.AppleGraphicsControl 3.1.33

com.apple.iokit.IONDRVSupport 2.3.4

com.apple.iokit.IOGraphicsFamily 2.3.4

com.apple.driver.AppleSMC 3.1.3d10

com.apple.driver.AppleUSBHIDMouse 175.8

com.apple.driver.AppleHIDMouse 175.8

com.apple.driver.AppleUSBHIDKeyboard 160.7

com.apple.driver.AppleHIDKeyboard 160.7

com.apple.driver.AppleUSBBluetoothHCIController 4.0.8f17

com.apple.iokit.IOBluetoothFamily 4.0.8f17

com.apple.driver.AppleThunderboltDPInAdapter 1.8.5

com.apple.driver.AppleThunderboltDPAdapterFamily 1.8.5

com.apple.driver.AppleThunderboltPCIDownAdapter 1.2.5

com.apple.driver.AppleUSBMultitouch 230.5

com.apple.iokit.IOUSBHIDDriver 5.0.0

com.apple.driver.AppleUSBMergeNub 5.1.0

com.apple.driver.AppleUSBComposite 5.0.0

com.apple.iokit.IOSCSIMultimediaCommandsDevice 3.2.1

com.apple.iokit.IOBDStorageFamily 1.7

com.apple.iokit.IODVDStorageFamily 1.7.1

com.apple.iokit.IOCDStorageFamily 1.7.1

com.apple.iokit.IOSCSIArchitectureModelFamily 3.2.1

com.apple.driver.AppleThunderboltNHI 1.6.0

com.apple.iokit.IOThunderboltFamily 2.0.3

com.apple.iokit.IOUSBUserClient 5.0.0

com.apple.iokit.IOFireWireFamily 4.4.8

com.apple.iokit.IO80211Family 420.3

com.apple.iokit.IOEthernetAVBController 1.0.1b1

com.apple.iokit.IONetworkingFamily 2.1

com.apple.iokit.IOAHCIFamily 2.0.8

com.apple.iokit.IOUSBFamily 5.1.0

com.apple.driver.AppleEFIRuntime 1.6.1

com.apple.iokit.IOHIDFamily 1.7.1

com.apple.iokit.IOSMBusFamily 1.1

com.apple.security.sandbox 177.8

com.apple.kext.AppleMatch 1.0.0d1

com.apple.driver.DiskImages 331.7

com.apple.iokit.IOStorageFamily 1.7.2

com.apple.driver.AppleKeyStore 28.18

com.apple.driver.AppleACPIPlatform 1.5

com.apple.iokit.IOPCIFamily 2.7

com.apple.iokit.IOACPIFamily 1.4

Model: MacBookPro8,2, BootROM MBP81.0047.B27, 4 processors, Intel Core i7, 2.5 GHz, 16 GB, SMC 1.69f3

Graphics: AMD Radeon HD 6770M, AMD Radeon HD 6770M, PCIe, 1024 MB

Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 512 MB

Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1333 MHz, 0x8502, 0x505344333847313333333253000000000000

Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1333 MHz, 0x8502, 0x505344333847313333333253000000000000

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6), Broadcom BCM43xx 1.0 (

Bluetooth: Version 4.0.8f17, 2 service, 11 devices, 1 incoming serial ports

Serial ATA Device: APPLE SSD TS512C, 500.28 GB

Serial ATA Device: HL-DT-ST DVDRW GS31N

USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8509, 0xfa200000 / 3

USB Device: hub_device, 0x0424 (SMSC), 0x2513, 0xfa100000 / 2

USB Device: BRCM2070 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0xfa110000 / 5

USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821a, 0xfa113000 / 8

USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0252, 0xfa120000 / 4

USB Device: hub_device, 0x0424 (SMSC), 0x2513, 0xfd100000 / 2

USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd110000 / 3

Link to comment
Share on other sites

Try shutting down the computer first and then disconnecting the USB hub, drives etc...


The 'crash' is apparently being caused by a failure of the USB ports to properly 'clear' according to your log... so shutting done first and then disconnecting everything, should 'fix' this..

Link to comment
Share on other sites

Reporting back....


I was able to successfully shut down my macbook today with no issues by shutting it down before disconnecting or turning off anything. (This includes the monitor, the harddrives, the usb hub and everything attatched to the usb hub, and the babyface). Granted, this has only been one time because its only been one day of logic sessions but I'm very hopeful that this is the solution to properly shut down my macbook pro.


I will try shutting down the macbook first again after today's sessions and see what happens, but the fact that this worked the first time I tried it is def progress... it would almost never shut down completely before.


Thanks so much! I'll report back again if this method stops working.

Link to comment
Share on other sites



I think you will find you won't have such an issue again (or at least very rarely) now you are shutting down before unplugging everything... I had a similar issue a couple of years back until I too, adopted this method and since then, I think i have had one 'crash'.... when trying to shut down.


Fingers crossed....

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...