Jump to content

Feedback loop Automap problem (Noob)


Recommended Posts

Hello, Im very new to this business, working my way through the Logic book which i'm enjoying very much, however i have one very annoying problem, feedback loops, I'm set up with a Nocturn Keyboard and automap software (dont get me started on that) Ok so what happens is, if i disable the Automap software and just use the keyboard as a midi keyboard i dont have a problem with sounds at all but i cant use the pots to control anything, i can only use the keys plus pitch bend, i then think "ok i want to be able to assigned pots etc so i'm gonna turn on auto map" then problem happens, feedback loop. louder and louder and louder until i hit record off on the track.


Someone please help this noob out.


Many thanks.



Link to comment
Share on other sites

I don't see how the feedback is related to your MIDI controller. Audio feedback as you describe (getting louder and louder, etc) has more to do with your audio routing than your MIDI setup. It does exist a MIDI feedback, but that would appear as a repeat of notes or bizarre synth/Logic behaviour something like there is.ghost that plays with your gear...

However, you can test the implication of your controller by Bypassing all Control Surfaces (temporarily) to check if that solves the problem (temporarily).

If indeed your controller is involved, I would recommend that you reinstall your Automap driver according to this procedure I posted a while ago

Link to comment
Share on other sites

Ok first of all thanks for replying, this makes sense, when I start logic up I get a dialogue box indicating something about mixer, hui, setup etc etc, I will try and post a picture, I'm thinking it has something to do with routing, I hoop you can help me out.


I'll try posting it later.





Link to comment
Share on other sites

It would be important to know what is installed/connected in your setup, and what the latter is made of, so please comply to the board rule #5.

These messages usually appear when the MIDI Controller that was installed was either not well installed, unduly installed, disconnected since the creation of your project, and/or depending of you currently connected gear.

In order to check what you have installed there, could you please post a screen capture of your Controller Surface Setup window, and tell us which controller you actually have connected? Have connected in the past and disconnected since you started using this version of Logic?

Link to comment
Share on other sites

Hi, ok i'll do my best here, I atached the Nocturn Keyboard/Controller via usb, I start up logic then before the logic interface comes to the screen it is then where i get the message, the first photo that i posted, i then have to close the Automap interface in order to play the keyboard, it is then though i get the second pop up, second photo.


I dont think it is the keboard because if i do not hook up the keyboard at all I.E just use logic from the Laptop with no devices connected i get the same two messages.



Any ideas?


Thanks a lot.

Link to comment
Share on other sites

If you don't use any other controller than the Nocturn, it seems that a controller was installed by error in Logic. Same happened to me and the solution is to remove it from the Setup window.

In order to do so:

1- Go back in the same window (Logic>Preferences>Control Surfaces>Setup...)

2- Select the icon named HUI in order to highlight it, then hit the Delete key on your Mac in order to delete that unduly installed MIDI controller.

3- Move the Novation Icon up so it occupies the upper left spot in that Setup window.

4- Highlight the Novation icon and check that (on the left) under Automap Mixer, that the Ouput Port and that the Input Port are set to Automap Logic; additionally that the Module and the Mode are set to Automap Mixer.

5-Once done, quit that Setup window.

6- Quit Logic.

7- Turn off the Mac.

8- Make sure that your Nocturn is plugged in properly.

9- Reboot your Mac in 32bit mode.


If the problem remains, you will have to repeat the same procedure but this time you will have (also) to uninstall the Novation and Automap completely as well and proceed with a clean re-installation of the Automap. Make sure that when you do the re-installation (or any update of the Novation/Automap drivers) that Logic reboots in 32bit mode.


These kind of problem are prone to occur when there is a MIDI issue somewhere in a system, such as a MIDI loop caused by a faulty cable for instance or problem in the MIDI interface (if you use one). Mine was caused by a loop in my MH box.

Link to comment
Share on other sites

You don't start your Mac in 32bit mode.

It is Logic that you have to start in 32bit mode!


To set Logic in 32bit mode:

Quit Logic Pro, if it is running.

Navigate to and select the Logic Pro application in the Applications folder.

Choose File, then Get Info.

Select the "Open in 32-bit mode" checkbox to run Logic Pro in 32-bit mode.




When the tick is not there, Logic runs in 64bit mode...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...