Jump to content

LPX acts weird during Additional Content Download? [SOLVED]


Recommended Posts

MMmmKay, so I install LPX, then the 2Gb 'essentials'. After this I run LPX, choosing to also download the additional content, being sure to look through the list & not select stuff that's already shown as installed. While the additional content is downloading I choose to open an existing project I created in LP9. After opening it and saving it in LPX format I hit the spacebar to play the song. First thing I notice is I do NOT get the overload error, which ALWAYS shows itself when I hit play on a freshly loaded project (and usually multiple times through the first play as the playhead encounters first regions on additional tracks. So, ok, cool. While it's playing I notice the Arrange (I know, it's called something else now, I forget LOL) display isn't updating at all. The playhead isn't moving (although I'm hearing the song play), the CPU and HD indicators are not moving, the information in the display next to transport controls isn't doing anything.


Hmmm, weird thinks I.


When I stop playback, the playhead jumps to wherever it's supposed to be when I've stopped it. So I open a plugin window, the Adaptive Limiter that I have on the Main out to boost the level a little. Then go to close it by clicking the 'x' top left of the plug window. The screen flashes, like Logic 9 does when you click something that's not supposed to be clicked. Clicking the 'Power Button' does not turn the effect on and off but doing so on the mixer (Command Click I think) does, in fact turn it on and off with no lag.


Hmmmmm, weird, thinks I again.


So I double clicked the CPU meter just to see if it opens, it does. I go to close it. Same thing as when I try to close the limiter window, the 'Screen Flash'.


Oh crap thinks I!


So I hit the spacebar to stop playback. Nothing. It won't stop. Keeps playing. So I go to the transport bar to click stop there. What the %#&(#(? There's no Stop button! So I hit the play button, thinking it might have not updated when I initially started playback, but that doesn't stop it.


Uh Oh thinks I!


Then I notice, in the transport bar, there are two buttons with the 'go back to beginning' icon (left facing arrow with a vertical line), one where the 'go to end' button should be. So I click that and playback stops - at which time I remove the headphones and place them, gingerly, on the desk. The limiter window is still open, as is the CPU meter window, still showing exactly what it showed when I opened it.


Would like to quit and restart LPX but the additional content is still downloading, so I'll wait till that's done. With my luck if I force quit in the middle, I'll end up missing some of the additional content.


Anyone run into something like this?

Link to comment
Share on other sites

Hi Benco,

I kind of figured this was the case. Actually, I'd read in a few posts here people talking about browsing through LPX while the content was downloading so I figured that would work LOL! Otherwise I probably wouldn't have even opened a project until it was done.



Link to comment
Share on other sites

Just as we all suspected, once the content was downloaded and installed, this behavior ceased. I've played with it a little and it does seem to be running considerably smoother than LP9 did! Still too early to tell, of course, but it feels like an upgrade in performance. TO me the new look is also good.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...