Jump to content

Can't understand Logic Pro X mixer behavior


mysticfm

Recommended Posts

I have been struggling to get my head wrapped around what happens when I allocate multiple output mixer channels for a multi-timbral instrument in Logic Pro X. I am seeing a variety of what seem to me to be inexplicable and inconsistent behaviors, albeit mostly in the UI at this point, and finally decided to write up a step by step recipe and document some of what I am seeing in 10.0.1. If anyone looks this over and spots something that I am doing wrong, or some mistaken assumption that I am making, I'd certainly appreciate it. (I apologize in advance for the length of this, but the behavior seems to vary unpredictably based upon even the slightest added or omitted step, so I felt I needed to provide an exact recipe that someone could try to duplicate if they wanted to.)

 

  • First I created a new, empty project.
  • I add a new Software Instrument track, multi-timbral, with 1 channel. It is automatically named "Inst 1", and gets a mixer channel of the same name.
  • I select a multi-output Omnisphere instance for the track, with a patch assigned to output A.
  • I record a MIDI region for the track. All is well … it plays back and through the single mixer channel "Inst 1", which had its input automatically set to "Omnisphere"
  • I select Track / Other / New Track With Next Channel. Creates another track, also called "Inst 1". A new mixer channel is not added automatically (as expected).
  • I rename the newly added track "Inst 2".
  • I click the (+) button on the "Inst 1" mixer channel. This adds an "Aux 1" channel, with input automatically set to "Omnisphere 3-4".
  • I choose a patch for channel 2 in Omnisphere and assign it to output B, and record a region onto the "Inst 2" track.
  • At this point both tracks play back, each apparently through the correct mixer channel going by the meters only. But now muting and soloing either of the mixer channels behaves just like the track mute and solo buttons: clicking either the one on the "Inst 1" or "Aux 1" mixer channel engages that button on BOTH mixer channels, and mutes/solos BOTH patches.
  • I select Track / Other / New Track With Next Channel again, to add a 3rd track for the Omnisphere instance. New track is named "Inst 1". But after doing this, without having changed anything else on the mixer, the only meters that move anymore on playback are on Aux 1 … the original Inst 1 mixer channel appears to be dead based upon no meter activity. But moving the slider on the Inst 1 mixer channel still changes the volume on the first patch! The Mute and Solo buttons on the mixer have also changed now:
    • Clicking on the Mute button on Inst 1 has no visual effect … the button doesn't change, nor does anything else on the mixer channel. BUT, both of the original two tracks in the Tracks view have their Mute buttons light up. BUT, only the 1st instrument is muted.
    • Clicking on the Mute button on Aux 1 (the 2nd mixer channel) does light up only that channel's Mute button, and nothing changes visually on the Tracks view at all. The audio from the 2nd instrument is muted.
    • Clicking on the Inst 1 Solo button on the mixer channel lights it up, solos the 1st patch, and makes mixer channel Aux 1's Mute button flash. But in the Tracks view, BOTH solo buttons for the first two Omnisphere patches light up, even though I am only hearing the first one.
    • Clicking on the Aux 1 Solo button on the mixer channel does solo the 2nd patch audibly, and lights up that Solo button. The Mute button on the Inst 1 mixer channel does NOT flash … but BOTH Mute buttons on the two tracks in the Tracks view flash, including the one corresponding to the soloed instrument that is still playing back on Aux 1!

    [*]Taking a tip from the board, I select the first (Inst 1) track only and create a folder stack. Now Inst 1 is inside a Sub 1 track, and a Sub 1 mixer channel has also been added. For some reason this brings the meters for the Inst 1 mixer channel back to life. But now the Mute and Solo buttons on the mixer channels have changed their behavior AGAIN:

    • Clicking on the Mute button on the Inst 1 mixer channel now lights up the Mute button on that mixer channel and mutes just the first patch … but also lights up the Mute button on all THREE of the Omnisphere tracks. (Prior to putting the original Inst 1 into a folder, it was only lighting up the first 2 tracks.)
    • Similarly, the Solo button on mixer channel Inst 1 lights up its solo button and solos the first patch, but illuminates the Solo buttons on all three tracks.
    • The Mute button on Aux 1 lights up and mutes the 2nd patch, and nothing else changes.
    • The Solo button on Aux 2 lights up and solos the 2nd patch, and the Mute button on mixer channel Inst 1 and all THREE of the tracks in the Tracks view start to blink (including on the channel corresponding to the 2nd patch which is soloed and playing back.

 

If anyone can make heads or tails of any of the above behavior, then by all means please enlighten me.

Link to comment
Share on other sites

Since no one has responded, am I safe in assuming that the variety of different behaviors of mute and solo buttons on the mixer channels with multi-timbral and/or multi-output instruments just means that those mixer controls are totally bug-ridden right now in LPX?
Link to comment
Share on other sites

Since no one has responded, am I safe in assuming that the variety of different behaviors of mute and solo buttons on the mixer channels with multi-timbral and/or multi-output instruments just means that those mixer controls are totally bug-ridden right now in LPX?

 

I will go through this tomorrow, but as i've been experimenting a lot with Track Stack i can confirm that multi-intruments Track Stacks / patches are buggy as hell, eg. weird metering, lost channel names and so on. This is why i made my multi patches with single Kontakt instances, it seems it was only way i got it to work somehow.

Link to comment
Share on other sites

I wish I had more time to go through your description while experimenting in LPX - but meanwhile what I can tell you is that Track Mute and Solo buttons in LPX behave like the Mute and Solo buttons in LP9 when the LP9 preferences for Track Mute/Solo buttons are set to "Remote Channel Strip". So basically they work the same as clicking the mute/solo button on the channel strip assigned to the track.

 

To get the old "CPU-Saving (slow response)" behavior of LP9 you can use the Track on/off buttons.

Link to comment
Share on other sites

I wish I had more time to go through your description while experimenting in LPX - but meanwhile what I can tell you is that Track Mute and Solo buttons in LPX behave like the Mute and Solo buttons in LP9 when the LP9 preferences for Track Mute/Solo buttons are set to "Remote Channel Strip". So basically they work the same as clicking the mute/solo button on the channel strip assigned to the track.

 

To get the old "CPU-Saving (slow response)" behavior of LP9 you can use the Track on/off buttons.

 

I am actually aware of and have reconciled with the Track mute and solo button behaviors. My concerns expressed in this thread are about the Mixer Channel Strip mute and solo buttons. I know the latter buttons didn't work this way in LP9 because I used those buttons constantly via my MCU Pro.

Link to comment
Share on other sites

Ah ok. So I started testing your step by step:

 

  • (...)
  • At this point both tracks play back, each apparently through the correct mixer channel going by the meters only. But now muting and soloing either of the mixer channels behaves just like the track mute and solo buttons: clicking either the one on the "Inst 1" or "Aux 1" mixer channel engages that button on BOTH mixer channels, and mutes/solos BOTH patches.

Both channel strips are selected so they are temporarily grouped. To deselect them, click the background of the mixer.

Link to comment
Share on other sites

Both channel strips are selected so they are temporarily grouped. To deselect them, click the background of the mixer.

 

Ah, yes, you solved that one! Thank you muchly, David! However, I think the subsequent observed issues may not be as easy. :D (I just repeated the steps myself after making sure not to have extra channels selected at any time, and the rest of the "recipe" holds true.)

 

I also noticed that, once I had added that 3rd track, when it is selected it automatically also selects the 1st mixer channel strip. I can understand that perhaps it doesn't know which mixer channel strip should be selected, but the confusing part to me is that selecting either of the first two tracks at that point does not select any mixer channel strip at all. (At least the audio is actually playing back correctly through each of the mixer channels as per the multi-timbral synths multi-output settings ... in general 10.0.1 seems to have improved a lot with respect to the behavior of the actual audio.)

Link to comment
Share on other sites

Really weird. Are you aware that when you create a new track with next channel, a new channel strip object is created in the environment, set to the same core audio channel (so two objects, same channel strip), only with a different MIDI channel? This was already the case in LP9.

 

So normally muting any of the tracks should mute both objects (since they're using the same channel), and muting the channel strip visible in the Mixer should also mute both objects and therefore both tracks. And that's how LP9 behaves.

 

Now in LPX they have seemingly tried to change that behavior? But the instant you open the environment and just move one of the objects, everything goes back to the (expected) LP9 behavior.

 

WEIRD to say the least.

 

EDIT: I just started the entire procedure again and now it behaves as expected (as in LP9). :shock:

Link to comment
Share on other sites

Really weird. Are you aware that when you create a new track with next channel, a new channel strip object is created in the environment, set to the same core audio channel (so two objects, same channel strip), only with a different MIDI channel? This was already the case in LP9.

 

So normally muting any of the tracks should mute both objects (since they're using the same channel), and muting the channel strip visible in the Mixer should also mute both objects and therefore both tracks. And that's how LP9 behaves.

 

Now in LPX they have seemingly tried to change that behavior? But the instant you open the environment and just move one of the objects, everything goes back to the (expected) LP9 behavior.

 

WEIRD to say the least.

 

EDIT: I just started the entire procedure again and now it behaves as expected (as in LP9). :shock:

 

Wow. The one thing I know about it is that the behavior of those strips changes from one moment to the next based on what actions one takes with them, but any pattern of said changes was undetectable to me. You've already taken that further than what I could have, which I'm glad about, because maybe you have a chance of communicating something meaningful about this back to Apple, whereas I'm mostly just befuddled by it. :oops:

 

Thanks very much for confirming that something is acting strangely.

Link to comment
Share on other sites

I deleted my logic X preferences and tried again, I am getting the expected (LP9) behavior now:

 

Soloing/muting the Inst 1 channel strip in the mixer soloes/mutes both tracks in the Tracks area.

Soloing/muting the Aux 1 channel strip in the mixer soloes/mutes neither tracks.

 

Can you try deleting your preferences? Do you need help with that?

Link to comment
Share on other sites

Damn, it get's compicated. My head hurts.

 

At this point both tracks play back, each apparently through the correct mixer channel going by the meters only. But now muting and soloing either of the mixer channels behaves just like the track mute and solo buttons: clicking either the one on the "Inst 1" or "Aux 1" mixer channel engages that button on BOTH mixer channels, and mutes/solos BOTH patches.

 

At this point when i press solo or mute in the Main Window it VISUALLY soloes / mutes all the channels IF channels has a midi region on it. If it dosen't it won't mute /solo the channel which is empty. If you click mute / solo on empty channel it mute / soloes all the channels. Visual representations work right on the Main Window.

 

BUT when i hit solo on Inst 1 channel i can hear audio getting soloed (visual representation = all channels soloed). If i mute Inst 1 i can hear Inst 2 playing (visual representation = all track muted) However, if i solo Inst 2 i can see visual presentations of every channels soloed, but i only hear Inst 1 playing. If i hit solo on Inst 2, it dosen't solo Inst 2 i can hear Inst 1 playing (visual representation = all channels soloed). If i mute Inst 2 i can hear Inst 2 playing, it dosen't mute, although visual representation is all channel muted.

 

When i go to mixer, pressing solo on first created Inst 1 channel soloes all channels. Mute mutes all channels, and visual representations are ok. When i go to Inst 2 channel in the mixer and press solo i can see on the Main Window all the regions turn gray = mute visual representation. When i press mute on Inst 2 channel on the mixer nothing happens, not on the buttons neither on visual side of things. More importantly audio gets muted and soloed.

 

Nobody probably can't follow what i just wrote.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...