Jump to content

Problems with Screensets, Bug? - LP 10.0.1


jackballed

Recommended Posts

Can someone look and see if this is a bug or just limited to my system?

 

Screenset menu > Duplicate (creates new Screenset and junk) > immediately hit your key command for that newly created Screenset. On my system, when I do this, Logic opens up the key commands window and shows me that Screenset key command. If I restart Logic and hit that new Screenset key command, it works as it should. Kind of a bummer to have to close and reopen Logic just to save a Screenset.

 

Thanks for helping.

Link to comment
Share on other sites

Screenset menu > Duplicate (creates new Screenset and junk)

Not sure what "and junk" means? Here it creates the duplicate and pops up an alert asking for the new screenset number and name. I fill those out and click OK which takes me to the new screenset.

 

immediately hit your key command for that newly created Screenset. On my system, when I do this, Logic opens up the key commands window and shows me that Screenset key command.

On my system it simply reloads the current screenset as expected.

 

The only way I can open the key command window with that screenset key command selected is if I hold Control while choosing a screenset from the screenset menu.

Link to comment
Share on other sites

Screenset menu > Duplicate (creates new Screenset and junk)

Not sure what "and junk" means? Here it creates the duplicate and pops up an alert asking for the new screenset number and name. I fill those out and click OK which takes me to the new screenset.

 

"And junk" referring to "you know the drill: follow the steps Logic has when creating a new Screenset." Didn't know this would be any kind of issue. :?

 

 

The only way I can open the key command window with that screenset key command selected is if I hold Control while choosing a screenset from the screenset menu.

 

Thanks for trying this out. I'm wondering if this is happening because my Screensets are control-1,2,3,4,etc. However, it doesn't explain why when I close and reopen Logic these key commands work like normal without opening the key commands window.

Link to comment
Share on other sites

Wait your key commands for opening say, screenset 1, is Control-1?

 

That's got to be very confusing for Logic because normally Control is the modifier you use to indicate to Logic that you're about to enter a 2-number screenset. So for example to reach screenset 34 I'd have to press Control-3 then 4 (using the default key commands).

Link to comment
Share on other sites

Wait your key commands for opening say, screenset 1, is Control-1?

 

That's got to be very confusing for Logic because normally Control is the modifier you use to indicate to Logic that you're about to enter a 2-number screenset. So for example to reach screenset 34 I'd have to press Control-3 then 4 (using the default key commands).

 

Yeah, it was my key command for Screensets. Right after your last post I changed it to option-1,2,3,etc. and it seems fine so far. Unfortunately, I didn't know that about control and additional Screensets.

Link to comment
Share on other sites

I started to have issues with screensets on Logic X today. First, at a moment, when duplicating a screenset, Logic opened 2 boxes, and I was not able to close them, all was blocked. But, it happened just on time. Now, I start to have crashes with screensets. I made a new template for my work (so not a Logic 9 project imported), when I change sreenset and come back to the first loaded in beginning, it crashes. I will transmit the crash report to Logic feedback form.
Link to comment
Share on other sites

Eric, no full screen mode for me, after duplicating this buggy screenset, and replacing it by the one I copied, all is working fine. However, my screensets are locked, maybe an issue with locked screensets, or a memory leak somewhere at the moment I locked the screenset.
Link to comment
Share on other sites

I've been having this problem from day one and mentioned it on this forum before.

For me, when I'm changing screen sets manually (with the mouse and NOT with key command) once, I can no longer do it with the key command until I reboot Logic X (or I'm always getting the key command dialog box)

My work around has been, not to use the mouse at all when it comes to screen sets, I even made a key command for locking-unlocking screen sets.

Dani

Link to comment
Share on other sites

  • 5 months later...

Want to come back on this topic and share my experience:

 

I have a Screenset issue in 10.05, i am on Mavericks 10.9.1:

 

- I have screenset 1 and 2 in a project. (keycommands APPLE + 1 and APPLE +2)

- i load the project, go to screenset 2 from 1, then back to 1 : CRASH.

- I then load the project again, go to screenset 2 from 1, then back to 1 : blanc screenset.

 

I am not in Full screen mode.

I deleted logic prefs : no solution

I made a fresh new project and made the 2 same screensets in that: same behaviour as described.

It makes no difference to switch screensets from keycommands or from choosing screenset in the screenset menu.

 

Annyoing ... :evil:

 

Rob.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...
I'm having problems with my screen sets crashing Logic (quitting without warning) since I upgraded to LPX in December. I have 5 screen sets. 1,2,3,4, & 5 which I activate via my MacBook Pro keyboard keys 1,2,3,4, & 5 (no modifiers) - as opposed to an external keyboard or pad etc. The problem appears to be with the #2 screen set. All of the other ones work fine, but when I switch to #2 - which is my 'Arrange/Mixer' screen set - Logic either crashes or gives me a blank screen - take your pick; it either does one or the other. When it's giving my the blank screen, I cannot seem to get it to crash by switching back and forth between all the screens and #2. However, I just crashed and reopened LPX three times and got it to crash reliably (LOL - I like that... "crash reliably" :?) each time. On the fourth try, I just got the blank screen. When on screen set #2, the entire screen set menu is greyed out, so there is no option to delete the offending screen set. I'm assuming that I can delete it from the folder somewhere and just over?
Link to comment
Share on other sites

  • 3 months later...

In both newly created files and 9-era template-generated files, I'm experiencing both

-- the crash on change screenset, and

-- once I relaunch, go to 2, switch back to 1, the blank screen set 1.

 

I really like screen sets; they can help you get a lot of mileage out of a single laptop screen, efficiently... but this is so persistent and a real time-suck. I've been sending the report every time and commenting simply, "Changed from screen set 2 to 1. Crashed." ...and sometimes a few other comments. ;-)

Link to comment
Share on other sites

In the project I was just wrapping up tonight, which was exhibiting the switch crash (3 times in rapid succession), I deleted all three saved screens and recreated them. No further crashes. This file was *not* based on a 9-era template, but was a save as of an earlier X-era project. Hmm.
Link to comment
Share on other sites

  • 2 years later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...