Jump to content

digital clicks and pops with plugins, CPU meters read low.


Recommended Posts

Here's my setup

logic pro 7.2.3

M-box 2

Mac Pro Quad, 2.66 GHz

4 Gigs RAM


I have my preferances set to the most CPU intensive (32 sample I/O buffer, and smallest CPU level in the preferance pane). When I have two sculptors up and two space designers, and I have all of them running, I hear digital clicks and pops. When monitoring my CPU meters, one of the four cores gets up to about 50%, while the other three remain below 10% or so.

The clicks and pops disappear when I set the I/O buffer higher, and set the CPU level to "large".

Has this happened to anyone else? It would make sense that I wouldn't hear clicks and pops until all four cores were maxed out, and I'm nowhere near that level.

Called Apple, their help was poor. Said that I was using too many plug-ins. Only 4!!

Link to comment
Share on other sites

I experienced something similar - audio would start stuttering. This was with 3-4 AU instruments, and only one of the cores were up about 60%, the other 3 at 10% or so. I don't know... maybe Logic isn't coded very well to use all cores? This was at a buffer size of 256 samples btw., with a Firewire audio card. Reminds me of the way Logic 5.5 could behave on PC with VST plugins. More evidence that virtual instruments implementation isn't up to scratch? I don't know.
Link to comment
Share on other sites

"...The clicks and pops disappear when I set the I/O buffer higher, and set the CPU level to 'large' "


That makes perfect sense...If it pertained to my old iMac, but not on your set up.


I am not sure about the M-box, but my US-122 has some buffer settings to change.


It may not matter, but what sample rate and bit resolution are you set at?


...OH! I usually mention this. Look at your Track mixer (via the audio Environment screen) you may find some unwanted plug-ins hidding there. You may not have put them there, but Don't assume they aren't there. It's worth a look.

Link to comment
Share on other sites

Definately no extra plugins. I am also monitoring all my audio object and a master fader, there is no normal clipping.

I am running at 24-bit, 48Khz.

It just doesn't make sense, I literally cannot get my CPU meters to max out. I understand there are limitations to native systems, but my computer is supposed to be a fireball right?I told the Apple Tech that and he said "i can't remember if Logic is meant to use all the cores", and after laughing, I said "then what's the point of multi-CPU computers" and he told me "to multitask", i.e. multiple programs at once. The help was indeed laughable.

I've never had problems with my M-Box 2. In fact, I also have Protools LE on the same computer, and I've loaded the maximum number of tracks (I believe 16 stereo) and I started putting the factory reverbs on each track. I had the "large hall" setting, with a 4 second decay time. The I/O buffer settings were as low as possible. I got more than three reverbs per track, that's more than 48 plugins before there was a hiccup.


anymore ideas?

Link to comment
Share on other sites

Duh me!! :oops:


Raise up your I/O buffer size till the noise disappears. It won't hurt and you will be happier.


Here is some tech stuff if your interested.




(Edit note: I lowered my I/O buffer and played using Sculpute. Clicks and pops galore with hardly any CPU activity. Raised it up and the trouble was gone.)

Link to comment
Share on other sites

Okay, so if i/o is handled by cpu core, then conceivably there still is not much of a point to multiple cpus. Am i missing something? And still, I shouldn't be hearing clicks and pops until at least one of the cores is maxed out.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...