Jump to content

Latency compensation issues with UAD Apollo


GregManning

Recommended Posts

First of all: Happy New Year!

 

I have an issue that is confusing to me and I hope that you smart people can help me out. The issue is Logic's latency compensation. I've addressed this last year, but I'm even more confused now ... lol.

 

Let me give you an example:

 

I have a kick drum that plays exactly on beat 1. There are several UAD plugs on the kick drum channel and also on Logic's stereo master out channel. With Logic's latency compensation set to "all" I would expect that the kick drum stays exactly on the downbeat when I bounce the track in real time. Unfortunately, bouncing introduces latency to the audio file, and when I import the bounced track the kick will be late (about 2030 samples). I understand that going through my Apollo box will introduce a lag because of the time it takes to process the signal, but shouldn't Logic's compensation take care of that problem?

 

When I do the same thing with native plug-ins, there is no problem at all! What am I missing? Shouldn't the UAD driver tell Logic the amount of latency to adjust?

 

I'm looking forward to your answers.

 

Best,

 

Greg

Edited by GregManning
Link to comment
Share on other sites

Thanks for your replies triplets and shivermetimbers! I appreciate it.

 

I went to the UA link and now I'm totally confused about the buffer size of Apollo and Logic.

 

When Apollo is connected via FireWire, UAD plug-ins used within the DAW run at a 512 minimum buffer size in order to operate reliably. Apollo’s dynamic buffering enables lower hardware I/O buffer settings (256, 128, 64 etc.) while maintaining a stable 512 buffer for UAD plug-in processing.

 

Is this what's confusing Logic (and me)? Although my Logic buffer is at 64, Apollo is actually doing 512???

Link to comment
Share on other sites

Hi Greg, I have an Apollo Quad and had similar issues you described. After fiddling around with some settings I essentially have no latency issues unless I have a whole slew of cpu intensive plugins loaded up. In Logic I set the buffer to 512. In the UAD Control Panel I have the FW UAD Bandwidth Allocation set to 70%. There are some plugins that will take up a lot of the UAD DSP, esp from the mastering suite. What is your DSP % when you get latency? Try removing plugins, one at a time, from your master strip as well and see if that helps.

 

Regards,

 

Rob

Link to comment
Share on other sites

Hi Rob,

 

Thanks for your help!

 

I thought changing Logic's buffer to 512 would take care of the problem, but I was wrong.

 

To answer your question: I never have an issue with bandwidth. There is plenty of bandwidth left, but when I bounce a file and import it into Logic the timing is off by about 2040 samples.

 

Can you check something for me on your system? Do you use the Apollo with FireWire, or Thunderbolt?

 

- record a hi-hat (quarter notes) for two bars (generated by midi, or played live)

- put a UA mastering plug-in in the stereo output channel. I'm using the Fairchild comp.

- Bounce the two bars in real time using Logic's latency compensation set to "all".

- Import the audio file into Logic and see if it lines up with the original hi-hat?

- Mine doesn't ... :evil:

 

Thanks!

Link to comment
Share on other sites

  • 7 months later...

I Have discovered similar issue here and made some break throughs.

 

When i bounced in place tracks and had UAD FX running on Aux sends, it introduced some major latency to the newly bounced audio.

Having fiddled with the Setting of UAD and Logic Plugin Latency compensation i can not find a way to get rid of this latency.

 

Its really quite a pain in the arse in all honesty.

 

Not much of a problem realigning by eye when you have a hard transient sound that comes clean on a beat or off beat.

But try realigning something with a less obvious starting transient and you can get into some really murky waters.

This can lead to massive second guessing about how the groove of parts sit once bounced in place.

 

But at this time i can't find a way to fix this glitch.

 

Im Using logic 9 with an apollo twin.

Have tried number numerous fiddled with setting but to no avail.

Bounce in place with AUX sends to UAD induces Lattency. No FIX!!

 

BOGUS

Link to comment
Share on other sites

  • 1 year later...

Hey there, 

 

after two years of silence here, i come up with the same problem now. has somebody found a solution to this issue meanwhile or did you all surrender?

i have exactly the same problem that greg describes in his first post in this thread.

 

please give me some help.

 

greetings from germany,

 

luke

Link to comment
Share on other sites

  • 3 weeks later...

Hey, I don't know if my UAD latency issues are exactly what people have been experiencing (for TWO YEARS!). 

 

But after a couple hours of self-harm, I've sorted the latency I'd been having when inserting UAD stuff (Quad Tbolt satellite) on buss channels (while mixing) & wanted to share. 

 

In audio prefs, I switched FROM "All" TO " Audio and Software Tracks," and voila. Settings within UAD menu are - extra buffering, release UAD DSP, Force Use of Logic live mode on input.  

Link to comment
Share on other sites

So, that might've been a bit premature... 

 

While it fixed one, somewhat predictable problem, it created another, less predictable one - specifically, other tracks falling out of sync, for not-entirely-apparent reasons

 

BUT, at the risk of being the boy who posts "wolf!" , 

 

***clicking the microphone-shaped icon on the lower left of the plugin window completely solved the issue***

 

the mic turns red, like it's been record-enabled / input monitoring. 

 

that's it. phew.

Link to comment
Share on other sites

While it fixed one, somewhat predictable problem, it created another, less predictable one - specifically, other tracks falling out of sync, for not-entirely-apparent reasons

This is because you now have non compensated aux tracks. All audio passing through them will be delayed by the amount of latency they induce. Tracks not passing through the aux will not get that delay.

Have you tried using Low Latency Mode when recording?

Link to comment
Share on other sites

  • 7 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...